]> git.pld-linux.org Git - packages/perl-DBI.git/blobdiff - perl-DBI.spec
- updated to 1.42
[packages/perl-DBI.git] / perl-DBI.spec
index ad2f1e2067378b007cbc2a452fdf28ec6d6c7efd..39be76a0cd8558597c75b515ae17ee367dbc1b75 100644 (file)
@@ -1,22 +1,38 @@
 #
 # Conditional build:
-# _with_tests - perform "make test"
-#
+%bcond_without autodeps        # don't BR packages needed only for resolving deps
+%bcond_with    tests           # perform "make test"
+
 %include       /usr/lib/rpm/macros.perl
 %define        pdir    DBI
 %define        pnam    DBI
-Summary:       DBI - Database independent interface for Perl
+Summary:       DBI - database independent interface for Perl
+Summary(cs):   API pro pøístup k databázím pro Perl
+Summary(da):   En database-API for Perl
+Summary(de):   Ein API Datenbankzugriff für Perl
+Summary(es):   Acceso de base de datos API para Perl
+Summary(fr):   Une IPA pour l'accès aux bases de données pour Perl
+Summary(it):   API di accesso a database per Perl
+Summary(ja):   Perl Íѥǡ¼¥¿¥Ù¡¼¥¹¥¢¥¯¥»¥¹ API
+Summary(ko):   ÆÞ¿¡ »ç¿ëµÇ´Â µ¥ÀÌŸº£À̽º ¾×¼¼½º API
+Summary(nb):   Et database-API for Perl
 Summary(pl):   DBI - niezale¿ny interfejs baz danych dla perla
+Summary(pt):   Uma API de acesso a bases de dados para o Perl
+Summary(pt_BR):        Uma API de acesso a bases de dados para o Perl
+Summary(ru):   âÉÂÌÉÏÔÅËÁ ÄÌÑ ÄÏÓÔÕÐÁ Ë ÂÁÚÁÍ ÄÁÎÎÙÈ ÄÌÑ Perl
+Summary(sv):   Ett databasåtkomst-API för Perl
+Summary(zh_CN):        Perl µÄÊý¾Ý¿â·ÃÎÊ API¡£
 Name:          perl-DBI
-Version:       1.32
-Release:       2
-License:       GPL/Artistic
+Version:       1.42
+Release:       1
+License:       GPL or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
+# Source0-md5: ca8c8a1a4797d98121b41c1d0a5b3b7c
 Patch0:                perl-DBI-changes.patch
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6.1
-%if %{?_with_tests:1}%{!?_with_tests:0}
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: perl-devel >= 5.8
+%if %{with autodeps} || %{with tests}
 BuildRequires: perl-PlRPC
 BuildRequires: perl-Storable
 BuildRequires: perl-Net-Daemon
@@ -29,31 +45,135 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 The DBI is a database access module for the Perl programming language.
-It defines a set of methods, variables, and conventions that provide
-consistent database interface, independent of the actual database
+It defines a set of methods, variables, and conventions that provide a
+consistent database interface, independent of the actual database
 being used.
 
+%description -l cs
+DBI je Application Programming Interface (API) pro pøístup k databázím
+pro programovací jazyk Perl. Specifikace DBI API definuje sadu funkcí,
+promìnných a konvencí, které poskytují konzistentní databázové
+rozhraní nezávislé na právì pou¾ité databázi.
+
+%description -l da
+DBI er en databaseadgangsprogrammeringsgrænseflade (API) for
+programmeringssproget Perl. DBI API-specifikationen definerer et antal
+funktioner, variable og konventioner som tilbyder et konsistent
+databasegrænseflade uafhængigt af den faktiske database som bruges.
+
+%description -l de
+DBI ist ein Datenbankzugriff Application Programming Interface (API)
+für die Programmiersprache Perl. Die DBI API Spezifikation definiert
+ein Set von Funktionen, Variablen und Konventionen die ein von der
+aktuell benutzten Datenbank unabhängiges, konsistentes
+Datenbankinterface bereitstellen.
+
+%description -l es
+DBI es una interfaz de programación de aplicación del acceso de base
+dedatos (API) para el lenguaje de programación de Perl. La
+especificación de DBI API define un conjunto de funciones, de
+variables y de las convenciones que proporcionan a un interfaz de base
+de datos constante independiente de la base de datos real que es
+utilizada.
+
+%description -l fr
+DBI est une interface de programme d'applications d'accès aux bases de
+données (IPA) pour le langage de programmation Perl. La spécification
+de l'IPA DBI définit des fonctions, des variables et des conventions
+qui fournissent une interface de base de donnée indépendante de la
+base de données utilisée.
+
+%description -l it
+DBI è un'API (Application Programming Interface) di accesso a database
+per il linguaggio di programmazione Perl. La specifica API di DBI
+definisce una serie di funzioni, variabili e convenzioni che
+forniscono un'interfaccia database conforme e indipendente dal
+database in uso.
+
+%description -l ja
+DBI ¤Ï Perl ¥×¥í¥°¥é¥ß¥ó¥°¸À¸ìÍѤΥǡ¼¥¿¥Ù¡¼¥¹¥¢¥¯¥»¥¹ API
+(Application Programming Interface) ¤Ç¤¹¡£DBI API ¤Î»ÅÍͤϡ¢¼ÂºÝ¤Ë»ÈÍÑ
+¤µ¤ì¤ë¥Ç¡¼¥¿¥Ù¡¼¥¹¤È¤ÏÊ̤ΰì´ÓÀ­¤Î¤¢¤ë¥Ç¡¼¥¿¥Ù¡¼¥¹¥¤¥ó¥¿¡¼¥Õ¥§¥¤¥¹¤òµ¬
+Äꤹ¤ë´Ø¿ô¡¢ ÊÑ¿ô¡¢Ë¡Â§¤Î¥»¥Ã¥È¤òÄêµÁ¤·¤Þ¤¹¡£
+
 %description -l pl
-DBI jest modu³em dostêpu do baz danych dla Perla.  Definiuje grupê metod,
-zmiennych i konwencji, zapewniaj±cych spójny interfejs do baz danych,
-niezale¿ny od typu aktualnie u¿ywanej bazy.
+DBI jest modu³em dostêpu do baz danych dla Perla. Definiuje grupê
+metod, zmiennych i konwencji, zapewniaj±cych spójny interfejs do baz
+danych, niezale¿ny od typu aktualnie u¿ywanej bazy.
+
+%description -l pt
+O DBI é uma API (Application Programming Interface) de acesso a bases
+de dados para a linguagem Perl. A especificação da API do DBI define
+um conjunto de funções, variáveis e convenções que oferecem uma
+interface de bases de dados consistente e independente da base de
+dados que é usada para o efeito.
+
+%description -l pt_BR
+O DBI é uma API (Application Programming Interface) de acesso a bases
+de dados para a linguagem Perl. A especificação da API do DBI define
+um conjunto de funções, variáveis e convenções que oferecem uma
+interface de bases de dados consistente e independente da base de
+dados que é usada para o efeito.
+
+%description -l ru
+DBI ÜÔÏ ÂÉÂÌÉÏÔÅËÁ ÄÌÑ ÄÏÓÔÕÐÁ Ë ÂÁÚÁÍ ÄÁÎÎÙÈ ÄÌÑ ÑÚÙËÁ Perl. DBI API
+ÏÐÒÅÄÅÌÑÅÔ ÎÁÂÏÒ ÆÕÎËÃÉÊ, ÐÅÒÅÍÅÎÎÙÈ É ËÏÎ×ÅÒÓÉÊ; ÏÂÅÓÐÅÞÉ×ÁÅÔ
+ÎÅÚÁ×ÉÓÉÍÙÊ ÉÎÔÅÒÆÅÊÓ ÂÁÚÙ ÄÁÎÎÙÈ.
+
+%description -l sv
+DBI är ett databasåtkomstprogrammeringsgränssnitt (API) för
+programmeringsspråket Perl. DBI API-specifikationen definerar ett
+antal funktioner, variabler och konventioner som erbjuder ett
+konsistent databasgränssnitt oberoende av den faktiska databas som
+används.
+
+%description -l zh_CN
+DBI ÊÇÓÃÓÚ Perl ±à³ÌÓïÑÔµÄÊý¾Ý¿â·ÃÎʳÌÐò±àд½çÃæ (API)¡£ DBI API
+Ã÷ϸ±í¶¨ÒåÁËÒ»×麯Êý¡¢±äÁ¿ºÍ¶¨¹æ£¬ËüÃÇÌṩÁËÒ»¸ö¶ÀÁ¢ÓÚʵ¼Ê±»Ê¹ÓõÄÊý¾Ý
+¿âÖ®ÍâµÄÁ¬¹áµÄÊý¾Ý¿â ½çÃæ¡£
+
+%package ProfileDumper-Apache
+Summary:       DBI::ProfileDumper::Apache - capture DBI profiling data from Apache/mod_perl
+Summary(pl):   DBI::ProfileDumper::Apache - przechwytywanie danych parametryzuj±cych DBI z Apache/mod_perl
+Group:         Development/Languages/Perl
+Requires:      %{name} = %{version}
+
+%description ProfileDumper-Apache
+This module interfaces DBI::ProfileDumper to Apache/mod_perl. Using
+this module you can collect profiling data from mod_perl applications.
+It works by creating a DBI::ProfileDumper data file for each Apache
+process. These files are created in your Apache log directory. You can
+then use dbiprof to analyze the profile files.
+
+%description ProfileDumper-Apache -l pl
+Modu³ ten sprzêga DBI::ProfileDumper z Apache/mod_perl. Korzystaj±c z
+niego mo¿na pobraæ dane o parametryzacji z aplikacji mod_perl. Dzia³a
+on w oparciu o tworzenie przez DBI::ProfileDumper pliku danych dla
+ka¿dego procesu Apache'a. Pliki te tworzone s± w katalogu logów
+Apache'a. Mo¿na je analizowaæ za pomoc± dbiprof.
 
 %prep
 %setup -q -n %{pnam}-%{version}
 %patch0 -p0
 
 %build
-%{__perl} Makefile.PL
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
 
-%{?_with_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT{%{perl_vendorlib}/DBIx,%{perl_vendorarch}/auto/DBD}
 
-install -d $RPM_BUILD_ROOT{%{perl_sitelib}/DBIx,%{perl_sitearch}/auto/DBD}
+# no reason to include Bundle::* in rpms
+rm -rf $RPM_BUILD_ROOT{%{perl_vendorarch}/Bundle,%{_mandir}/man3/Bundle::*}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -62,17 +182,30 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc Changes README ToDo
 %attr(755,root,root) %{_bindir}/*
-%dir %{perl_sitelib}/DBIx
-%{perl_sitearch}/DBI.pm
-%dir %{perl_sitearch}/DBI
-%{perl_sitearch}/DBI/Const
-%{perl_sitearch}/DBI/[DFPS]*.pm
-%{perl_sitearch}/DBD
-%dir %{perl_sitearch}/auto/DBD
-%dir %{perl_sitearch}/auto/DBI
-%{perl_sitearch}/auto/DBI/*.h
-%{perl_sitearch}/auto/DBI/Driver.xst
-%{perl_sitearch}/auto/DBI/DBI.bs
-%attr(755,root,root) %{perl_sitearch}/auto/DBI/DBI.so
+%dir %{perl_vendorlib}/DBIx
+%{perl_vendorarch}/DBI.pm
+%dir %{perl_vendorarch}/DBI
+%{perl_vendorarch}/DBI/Const
+%{perl_vendorarch}/DBI/[DFPS]*.pm
+%{perl_vendorarch}/DBI/DBD
+%{perl_vendorarch}/DBD
+%dir %{perl_vendorarch}/auto/DBD
+%dir %{perl_vendorarch}/auto/DBI
+%{perl_vendorarch}/auto/DBI/*.h
+%{perl_vendorarch}/auto/DBI/Driver.xst
+%{perl_vendorarch}/auto/DBI/DBI.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/DBI/DBI.so
 %{_mandir}/man1/*
-%{_mandir}/man3/D*
+%{_mandir}/man3/DBD*
+%{_mandir}/man3/DBI.*
+%{_mandir}/man3/DBI::Profile.*
+%{_mandir}/man3/DBI::ProfileData.*
+%{_mandir}/man3/DBI::ProfileDumper.*
+%{_mandir}/man3/DBI::ProxyServer.*
+%{_mandir}/man3/DBI::PurePerl.*
+%{_mandir}/man3/DBI::[!PW]*
+
+%files ProfileDumper-Apache
+%defattr(644,root,root,755)
+%{perl_vendorarch}/DBI/ProfileDumper
+%{_mandir}/man3/DBI::ProfileDumper::*
This page took 0.08545 seconds and 4 git commands to generate.