]> git.pld-linux.org Git - packages/perl-Coro.git/blobdiff - perl-Coro.spec
perl 5.38.0 rebuild
[packages/perl-Coro.git] / perl-Coro.spec
index 583ef80fda77a1488f755ec08237c720b5d93cf3..30cefdf73906e1d568573f44989e311a8bfb3f7f 100644 (file)
@@ -1,21 +1,43 @@
 #
 # Conditional build:
-%bcond_without tests   # do not perform "make test"
+%bcond_with    tests   # do not perform "make test"
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    Coro
 %define                pnam    Coro
 Summary:       Coro - do events the coro-way
+Summary(pl.UTF-8):     Coro - obsługa zdarzeń na sposób coro
 Name:          perl-Coro
-Version:       1.9
-Release:       0.1
+Version:       6.57
+Release:       5
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-# Source0-md5: 63efa9fb31ded80f2c7d1fb900163824
-BuildRequires: perl-devel >= 1:5.8.0
+Source0:       http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
+# Source0-md5: fa5970a2a2f3df9d68d4369c7dde1a55
+Patch0:                kill-blocked-test.patch
+URL:           https://metacpan.org/dist/Coro
+BuildRequires: perl-AnyEvent >= 2:5.0
+BuildRequires: perl-Canary-Stability
+BuildRequires: perl-EV >= 1:4.0
+BuildRequires: perl-Event >= 1.08
+BuildRequires: perl-ExtUtils-MakeMaker >= 6.52
+BuildRequires: perl-devel >= 1:5.8.9
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
+BuildRequires: sed >= 4.0
+%if %{with tests}
+BuildRequires: perl-AnyEvent-Impl-EV
+BuildRequires: perl-AnyEvent-Impl-Event
+BuildRequires: perl-Guard >= 0.5
+BuildRequires: perl-Storable >= 2.15
+BuildRequires: perl-Time-HiRes
+BuildRequires: perl-common-sense
+%endif
+Requires:      perl-AnyEvent >= 2:5.0
+Requires:      perl-BDB >= 1.5
+Requires:      perl-EV >= 1:4.0
+Requires:      perl-Guard >= 0.5
+Requires:      perl-Storable >= 2.15
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -23,18 +45,30 @@ This module enables you to create programs using the powerful Event
 model (and module), while retaining the linear style known from simple
 or threaded programs.
 
+%description -l pl.UTF-8
+Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
+(i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
+wątkowych programów.
+
 %prep
 %setup -q -n %{pnam}-%{version}
+%patch0 -p1
+
+%{__sed} -i "s^/opt/bin/perl^%{_bindir}/perl^" Coro/jit*pl
 
 %build
-echo "y
-l
-16384" | %{__perl} Makefile.PL \
+# CORO_INTERFACE: use setjmp on x32 (asm fails tests)
+echo "y" | \
+%ifarch x32
+       CORO_INTERFACE=s \
+%endif
+%{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 %{__make} \
+       CC="%{__cc}" \
        OPTIMIZE="%{rpmcflags}"
 
-%{?with_tests:%{__make} test}
+%{?with_tests:%{__make} -j1 test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -47,11 +81,14 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ANNOUNCE ChangeLog README TODO
-
+%doc COPYING Changes INSTALL README README.linux-glibc
 %{perl_vendorarch}/Coro.pm
 %{perl_vendorarch}/Coro
 %dir %{perl_vendorarch}/auto/Coro
-%{perl_vendorarch}/auto/Coro/*.bs
-%attr(755,root,root) %{perl_vendorarch}/auto/Coro/*.so
-%{_mandir}/man3/*
+%dir %{perl_vendorarch}/auto/Coro/EV
+%attr(755,root,root) %{perl_vendorarch}/auto/Coro/EV/EV.so
+%dir %{perl_vendorarch}/auto/Coro/Event
+%attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/Event.so
+%dir %{perl_vendorarch}/auto/Coro/State
+%attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/State.so
+%{_mandir}/man3/Coro*.3pm*
This page took 0.083609 seconds and 4 git commands to generate.