]> git.pld-linux.org Git - packages/perl-Carp-Assert.git/blobdiff - perl-Carp-Assert.spec
- up to 0.20
[packages/perl-Carp-Assert.git] / perl-Carp-Assert.spec
index 400089298046b514352156ae05d337dd62df950e..38013bf9419b0f1d7d437be2ee3f1ed5d7204085 100644 (file)
@@ -1,43 +1,60 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Carp-Assert perl module
-Summary(pl):   Modu³ perla Carp-Assert
+%define                pdir    Carp
+%define                pnam    Assert
+Summary:       Carp::Assert - executable comments
+Summary(pl.UTF-8):     Carp::Assert - wykonywalne komentarze
 Name:          perl-Carp-Assert
-Version:       0.13
-Release:       2
-License:       GPL
+Version:       0.20
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Group(de):     Entwicklung/Sprachen/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/Carp/Carp-Assert-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 9dafe361b9e5e93e8e3e70e015f6b191
+BuildRequires: perl-devel >= 1:5.8.0
+%if %{with tests}
+BuildRequires: perl-Pod-Tests >= 0.18
+BuildRequires: perl-Test-Simple >= 0.40
+%endif
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Carp-Assert perl module.
+Carp::Assert is intended for a purpose like the ANSI C library
+assert.h. An assertion is used to prevent the impossible from being
+asked of your code, or at least tell you when it does.
 
-%description -l pl
-Modu³ perla Carp-Assert.
+%description -l pl.UTF-8
+Moduł Carp::Assert służy do tego, co assert.h z ANSI C. Używa się
+zapewnień (assertion), aby wykluczyć występowanie rzeczy niemożliwych,
+albo przynajmniej wiedzieć, gdzie się zdarzają.
 
 %prep
-%setup -q -n Carp-Assert-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf Changes README
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitelib}/Carp/Assert.pm
+%doc Changes README
+%{perl_vendorlib}/Carp/Assert.pm
 %{_mandir}/man3/*
This page took 0.088353 seconds and 4 git commands to generate.