]> git.pld-linux.org Git - packages/perl-Carp-Assert.git/blobdiff - perl-Carp-Assert.spec
- BR fix, rel. 3
[packages/perl-Carp-Assert.git] / perl-Carp-Assert.spec
index 7e848316962f5078eb37c5525b6a4b3a53ceb72d..1fc06dc3dd1054a692071a97c224ff8f1c966459 100644 (file)
@@ -1,96 +1,54 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-%define                pdir    Carp
-%define                pnam    Assert
-Summary:       Carp::Assert Perl module
-Summary(cs):   Modul Carp::Assert pro Perl
-Summary(da):   Perlmodul Carp::Assert
-Summary(de):   Carp::Assert Perl Modul
-Summary(es):   Módulo de Perl Carp::Assert
-Summary(fr):   Module Perl Carp::Assert
-Summary(it):   Modulo di Perl Carp::Assert
-Summary(ja):   Carp::Assert Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   Carp::Assert ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul Carp::Assert
-Summary(pl):   Modu³ Perla Carp::Assert
-Summary(pt):   Módulo de Perl Carp::Assert
-Summary(pt_BR):        Módulo Perl Carp::Assert
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl Carp::Assert
-Summary(sv):   Carp::Assert Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Carp::Assert
-Summary(zh_CN):        Carp::Assert Perl Ä£¿é
+%define        pdir    Carp
+%define        pnam    Assert
+Summary:       Carp::Assert - executable comments
+Summary(pl):   Carp::Assert - wykonywalne komentarze
 Name:          perl-Carp-Assert
-Version:       0.17
-Release:       5
-License:       GPL
+Version:       0.18
+Release:       4
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6.1
+Source0:       http://www.cpan.org/modules/by-module/Carp/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 8137794654f5802730c05167327d496e
+BuildRequires: perl-devel >= 1:5.8.0
+%if %{with tests}
+BuildRequires: perl-Test-Inline >= 0.16-3
+BuildRequires: perl-Test-Simple >= 0.40
+%endif
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Carp::Assert perl module.
-
-%description -l cs
-Modul Carp::Assert pro Perl.
-
-%description -l da
-Perlmodul Carp::Assert.
-
-%description -l de
-Carp::Assert Perl Modul.
-
-%description -l es
-Módulo de Perl Carp::Assert.
-
-%description -l fr
-Module Perl Carp::Assert.
-
-%description -l it
-Modulo di Perl Carp::Assert.
-
-%description -l ja
-Carp::Assert Perl ¥â¥¸¥å¡¼¥ë
-
-%description -l ko
-Carp::Assert ÆÞ ¸ðÁÙ.
-
-%description -l no
-Perlmodul Carp::Assert.
+Carp::Assert is intended for a purpose like the ANSI C library
+assert.h. An assertion is used to prevent the impossible from being
+asked of your code, or at least tell you when it does.
 
 %description -l pl
-Modu³ perla Carp::Assert.
-
-%description -l pt
-Módulo de Perl Carp::Assert.
-
-%description -l pt_BR
-Módulo Perl Carp::Assert.
-
-%description -l ru
-íÏÄÕÌØ ÄÌÑ Perl Carp::Assert.
-
-%description -l sv
-Carp::Assert Perlmodul.
-
-%description -l uk
-íÏÄÕÌØ ÄÌÑ Perl Carp::Assert.
-
-%description -l zh_CN
-Carp::Assert Perl Ä£¿é
+Modu³ Carp::Assert s³u¿y do tego, co assert.h z ANSI C. U¿ywa siê
+zapewnieñ (assertion), aby wykluczyæ wystêpowanie rzeczy niemo¿liwych,
+albo przynajmniej wiedzieæ, gdzie siê zdarzaj±.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -98,5 +56,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes README
-%{perl_sitelib}/Carp
+%{perl_vendorlib}/Carp/Assert.pm
 %{_mandir}/man3/*
This page took 0.033241 seconds and 4 git commands to generate.