]> git.pld-linux.org Git - packages/perl-Carp-Assert.git/blobdiff - perl-Carp-Assert.spec
- BR fix, rel. 3
[packages/perl-Carp-Assert.git] / perl-Carp-Assert.spec
index 0005c54ef463cdd363b07b25b484dabb1e9ee735..1fc06dc3dd1054a692071a97c224ff8f1c966459 100644 (file)
@@ -1,53 +1,60 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Carp-Assert perl module
-Summary(pl):   Modu³ perla Carp-Assert
+%define        pdir    Carp
+%define        pnam    Assert
+Summary:       Carp::Assert - executable comments
+Summary(pl):   Carp::Assert - wykonywalne komentarze
 Name:          perl-Carp-Assert
-Version:       0.08
-Release:       1
-License:       GPL
+Version:       0.18
+Release:       4
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source:                ftp://ftp.perl.org/pub/CPAN/modules/by-module/Carp/Carp-Assert-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.005_03-14
-%requires_eq   perl
-Requires:      %{perl_sitearch}
+Source0:       http://www.cpan.org/modules/by-module/Carp/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 8137794654f5802730c05167327d496e
+BuildRequires: perl-devel >= 1:5.8.0
+%if %{with tests}
+BuildRequires: perl-Test-Inline >= 0.16-3
+BuildRequires: perl-Test-Simple >= 0.40
+%endif
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Carp-Assert perl module
+Carp::Assert is intended for a purpose like the ANSI C library
+assert.h. An assertion is used to prevent the impossible from being
+asked of your code, or at least tell you when it does.
 
 %description -l pl
-Modu³ perla Carp-Assert
+Modu³ Carp::Assert s³u¿y do tego, co assert.h z ANSI C. U¿ywa siê
+zapewnieñ (assertion), aby wykluczyæ wystêpowanie rzeczy niemo¿liwych,
+albo przynajmniej wiedzieæ, gdzie siê zdarzaj±.
 
 %prep
-%setup -q -n Carp-Assert-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
-make
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
-
-(
-  cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/Carp/Assert
-  sed -e "s#$RPM_BUILD_ROOT##" .packlist >.packlist.new
-  mv .packlist.new .packlist
-)
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
-        Changes README
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {Changes,README}.gz
-
-%{perl_sitelib}/Carp/Assert.pm
-%{perl_sitearch}/auto/Carp/Assert
-
+%doc Changes README
+%{perl_vendorlib}/Carp/Assert.pm
 %{_mandir}/man3/*
This page took 0.027088 seconds and 4 git commands to generate.