]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
- release 2 (by relup.sh)
[packages/opencv.git] / opencv.spec
index 4a6a8209be9d25b70c1cbf2beb196fd136d7eaac..ac5a298a302dca83f4d0a35c35eab5a53dcc52d5 100644 (file)
@@ -1,19 +1,21 @@
 #
 # TODO:
 # - CUDA support (on bcond)
-# - XIMEA? cmake file seems to be Win32-specific, but ximea.com has some Linux package
 #
 # Conditional build:
+# - general options:
+%bcond_with    tbb             # Threading Building Blocks support (everywhere)
+%bcond_with    sse             # use SSE instructions
+%bcond_with    sse2            # use SSE2 instructions
+# - highgui options:
 %bcond_without gstreamer       # GStreamer support in highgui
 %bcond_with    openni          # OpenNI (Natural Interaction) support in highgui
-%bcond_with    pvapi           # PvAPI (AVT GigE cameras) support in highgui
+%bcond_with    pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
 %bcond_with    qt              # Qt backend instead of GTK+ in highgui
-%bcond_with    tbb             # Threading Building Blocks support (everywhere)
 %bcond_with    unicap          # Unicap support in highgui (GPL)
-%bcond_with    v4l             # Video4Linux (even V4L2 support currently relies on V4L1 API)
+%bcond_with    v4l             # Video4Linux in highgui (even V4L2 support currently relies on V4L1 API)
+%bcond_with    ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
 %bcond_with    xine            # XINE support in highgui (GPL)
-%bcond_with    sse             # use SSE instructions
-%bcond_with    sse2            # use SSE2 instructions
 #
 %ifarch pentium3 pentium4 %{x8664}
 %define                with_sse        1
@@ -24,8 +26,8 @@
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
-Version:       2.3.1
-Release:       4
+Version:       2.4.2
+Release:       2
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -33,19 +35,19 @@ License:    GPL (enforced by used libraries), BSD (opencv itself)
 License:       BSD
 %endif
 Group:         Libraries
-Source0:       http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}a.tar.bz2
-# Source0-md5: 82e4b6bfa349777233eea09b075e931e
+Source0:       http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz2
+# Source0-md5: 059ef86fc1724d69b75832a0d2929ff5
 Patch0:                %{name}-cflags.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-unicap-c++.patch
 Patch3:                %{name}-c.patch
 Patch4:                %{name}-gcc.patch
-Patch5:                %{name}-multilib.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
 # as of OpenCV 2.3.1 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
 %{?with_openni:BuildRequires:  OpenNI-devel}
+%{?with_ximea:BuildRequires:   XIMEA-devel}
 BuildRequires: cmake >= 2.4
 BuildRequires: doxygen
 BuildRequires: eigen >= 2
@@ -156,7 +158,6 @@ Wiązania Pythona do OpenCV.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 
 %build
 install -d build
@@ -173,6 +174,7 @@ cd build
        %{?with_tbb:-DWITH_TBB=ON} \
        %{?with_unicap:-DWITH_UNICAP=ON} \
        %{!?with_v4l:-DWITH_V4L=OFF} \
+       %{?with_ximea:-DWITH_XIMEA=ON} \
        %{?with_xine:-DWITH_XINE=ON}
 
 %{__make}
@@ -200,7 +202,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/opencv_*
 %attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.3
+%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.4
 %dir %{_datadir}/OpenCV
 %doc %{_datadir}/OpenCV/doc
 %{_datadir}/OpenCV/haarcascades
This page took 0.0565 seconds and 4 git commands to generate.