]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- obsolete
[packages/ocaml.git] / ocaml.spec
index 7ba9c2a386620b68e78a6224091e899655e0781a..ad423371bdf5c5467b3867bb6d26305f3c559b02 100644 (file)
@@ -1,30 +1,31 @@
 #
 # Conditional build:
-
-%bcond_without emacs   # emacs subpackage
-%bcond_without x       # without X11 support 
-%bcond_without tk      # tk support
-%bcond_with db3                # use db3 instead of db 4.x
-
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # without Tcl/Tk support
+%bcond_with    db3     # use db3 instead of db 4.x
+#
 # --without x11 implies --without tk
 %{!?with_x:%undefine   with_tk}
 
-%define p4ver 3.06
+%define                p4ver   3.06
+%define                sver    3.08
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.07
-Release:       5
+Version:       3.08.2
+Release:       1
+Epoch:         1
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 2dd038055f5e1350078ad81270411b78
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
-# Source1-md5: 9ac1f7e9e381b95504f0e7868d9fbf52
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
-# Source2-md5: 09a9ac4bc1ec90ca4d16743ffbe76c78
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.gz
+# Source0-md5: b79358a09884f5e679433cce284de43e
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
+# Source1-md5: 0daee5643db6960682c1a7d84467885f
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
+# Source2-md5: 35a5d4318456c0982e72ee3f33364bf5
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -41,21 +42,19 @@ Patch0:             %{name}-build.patch
 Patch1:                %{name}-db3.patch
 Patch2:                %{name}-objinfo.patch
 Patch3:                %{name}-mano.patch
-Patch4:                %{name}-unused-var-warning.patch
-Patch5:                %{name}-3.07-patch2.diffs
-#Patch6:               %{name}-emacs_batch_mode.patch
+# needs update for ocaml 3.08
+#Patch4:               %{name}-unused-var-warning.patch
 URL:           http://caml.inria.fr/
-%{?with_x:BuildRequires:               XFree86-devel}
+%{?with_x:BuildRequires:       XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
-%{?with_tk:BuildRequires:              tk-devel}
+%{?with_tk:BuildRequires:      tk-devel}
 %if %{with emacs}
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
-
 %endif
-Requires:      ocaml-runtime = %{version}-%{release}
+Requires:      %{name}-runtime = %{epoch}:%{version}-%{release}
 Provides:      ocaml-ocamldoc
 Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -94,7 +93,7 @@ w g
 Summary:       Emacs mode for OCaml
 Summary(pl):   Tryb OCamla dla Emacsa
 Group:         Development/Tools
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description emacs
 Emacs mode files for Objective Caml language.
@@ -114,13 +113,13 @@ ocamlrun bytecode interpreter, and basic dynamic link libraries.
 %description runtime -l pl
 Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
 OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
-podstawowe bibliotki linkowane dynamicznie.
+podstawowe biblioteki linkowane dynamicznie.
 
 %package labltk-devel
 Summary:       LablTk library for OCaml
 Summary(pl):   Biblioteka LablTk dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-labltk = %{version}-%{release}
+Requires:      %{name}-labltk = %{epoch}:%{version}-%{release}
 
 %description labltk-devel
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -135,7 +134,7 @@ u
 Summary:       Runtime for LablTk library
 Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description labltk
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -150,7 +149,7 @@ u
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-x11graphics = %{version}-%{release}
+Requires:      %{name}-x11graphics = %{epoch}:%{version}-%{release}
 
 %description x11graphics-devel
 x11graphics module gives OCaml program access to drawing in X11
@@ -166,7 +165,7 @@ niezb
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description x11graphics
 x11graphics module gives OCaml program access to drawing in X11
@@ -182,8 +181,8 @@ potrzebne do uruchamiania program
 Summary:       Objective Caml Preprocessor
 Summary(pl):   Preprocesor OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
-Provides:      camlp4 = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      camlp4 = %{epoch}:%{version}-%{release}
 Obsoletes:     camlp4
 
 %description camlp4
@@ -219,22 +218,23 @@ sk
 Summary:       Compiled parts of OCaml compiler
 Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
 %description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
 compiler. They are needed to compile some programs.
 
 %description compiler-objects -l pl
-Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
+Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce czê¶ciami kompilatora
 OCamla. S± one wymagane do kompilacji niektórych programów.
 
 %package ocamldoc-devel
 Summary:       Files needed to develop programs using ocamldoc
 Summary(pl):   Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description ocamldoc-devel
 You need this package if you are going to write ocamldoc front end or
@@ -248,7 +248,7 @@ dla ocamldoc lub co
 Summary:       Sources of OCaml standard library
 Summary(pl):   ¬ród³a biblioteki standardowej OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description lib-source
 This sources come helpful during debugging of user programs with ocamldebug.
@@ -262,7 +262,7 @@ z u
 Summary:       Example source code for OCaml
 Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description examples
 This packages contains sources for Okasaki's Purely Functional
@@ -273,7 +273,7 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -a1 -a3 -a5
+%setup -q -a1 -a3 -a5  
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
@@ -290,11 +290,10 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
-#%patch6 -p1
+#%patch4 -p1
 
 %build
+cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
@@ -302,7 +301,8 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
        -mandir %{_mandir}/man1 \
        -host %{_host} \
        %{!?with_tk:-no-tk} \
-       -with-pthread
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
 %{__make} world bootstrap opt.opt
 %{__make} -C tools objinfo
@@ -448,7 +448,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{with x11}
+%if %{with x}
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
This page took 0.03781 seconds and 4 git commands to generate.