]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- obsolete
[packages/ocaml.git] / ocaml.spec
index 28b5158df366e5442faf0673e09e78407e3bf1e1..9a0732e6fcdd8c6f6d661f406e730744db7cea26 100644 (file)
@@ -1,31 +1,31 @@
 #
 # Conditional build:
 
-%bcond_without emacs   # emacs subpackage
-%bcond_without x11     # without X11 support 
-%bcond_without tk      # tk support
-%bcond_with db3                # use db3 instead of db 4.x
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # without Tcl/Tk support
+%bcond_with    db3     # use db3 instead of db 4.x
 
 # --without x11 implies --without tk
-%{!?with_x11:%undefine with_tk}
+%{!?with_x:%undefine   with_tk}
 
-%define beta beta2
-%define p4ver 3.06
+%define                p4ver   3.06
+%define                sver    3.08
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.07
-Release:       0.%{beta}.1
+Version:       3.08.0
+Release:       1       
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}.tar.gz
-# Source0-md5: ecc68d67871aeae91bd807f3a3e388cb
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.html.tar.gz
-# Source1-md5: 6f92dcb308c6e6923c39f7aac3749f2d
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.ps.gz
-# Source2-md5: 98b87b91c6ac5fd0ae1be7a732e49094
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.gz
+# Source0-md5: c6ef478362295c150101cdd2efcd38e0
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
+# Source1-md5: 0daee5643db6960682c1a7d84467885f
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
+# Source2-md5: 35a5d4318456c0982e72ee3f33364bf5
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -39,25 +39,26 @@ Source7:    http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
 Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
 # Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-manlinks.patch
-Patch2:                %{name}-db3.patch
-Patch3:                %{name}-objinfo.patch
-Patch4:                %{name}-opt-symbols.patch
-Patch5:                %{name}-mano.patch
-Patch6:                %{name}-tk8.4.patch
+Patch1:                %{name}-db3.patch
+Patch2:                %{name}-objinfo.patch
+Patch3:                %{name}-mano.patch
+#Patch4:               %{name}-unused-var-warning.patch
+#Patch5:               %{name}-3.07-patch2.diffs
+#Patch6:               %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
-Requires:      ocaml-runtime = %{version}-%{release}
-Obsoletes:     ocaml-ocamldoc
-Provides:      ocaml-ocamldoc
-%{?with_x11:BuildRequires:             XFree86-devel}
+%{?with_x:BuildRequires:       XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
-%{?with_tk:BuildRequires:              tk-devel >= 8.4.3}
+%{?with_tk:BuildRequires:      tk-devel}
 %if %{with emacs}
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
+
 %endif
+Requires:      ocaml-runtime = %{version}-%{release}
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -221,6 +222,7 @@ Summary(pl):        Skompilowane cz
 Group:         Development/Languages
 Requires:      %{name} = %{version}-%{release}
 Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
 %description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
@@ -273,7 +275,7 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -n %{name}-%{version}%{beta} -a1 -a3 -a5
+%setup -q -a1 -a3 -a5  
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
@@ -287,14 +289,15 @@ cp %{SOURCE4} docs/camlp4.ps.gz
 mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
-#%patch1 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 #%patch4 -p1
-%patch5 -p1
+#%patch5 -p1
 #%patch6 -p1
 
 %build
+cp /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
@@ -302,13 +305,15 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
        -mandir %{_mandir}/man1 \
        -host %{_host} \
        %{!?with_tk:-no-tk} \
-       -with-pthread
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
 %{__make} world bootstrap opt.opt
 %{__make} -C tools objinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -338,7 +343,6 @@ for f in ocamlc ocamlopt ocamldoc ocamllex; do
 done
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
@@ -351,13 +355,8 @@ done
 
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
@@ -390,6 +389,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/caml
 %{_libdir}/%{name}/caml
 %{_libdir}/%{name}/threads
+%dir %{_libdir}/%{name}/vmthreads
+%dir %{_libdir}/%{name}/vmthreads/*.cm*
+%dir %{_libdir}/%{name}/vmthreads/*.a
 %{_libdir}/%{name}/*.a
 %{_libdir}/%{name}/*.o
 %{_libdir}/%{name}/*.cm*
@@ -398,7 +400,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
 %dir %{_libdir}/%{name}/ocamldoc
-%{_libdir}/%{name}/ocamldoc/*.sty
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
 %attr(755,root,root) %{_libdir}/%{name}/extract_crc
@@ -409,6 +410,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/*.ml
 %{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/*/*.mli
 
 %files examples
 %defattr(644,root,root,755)
@@ -450,7 +452,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{with x11}
+%if %{with x}
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
This page took 0.039359 seconds and 4 git commands to generate.