]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - ocaml.spec
update pecl tests
[projects/template-specs.git] / ocaml.spec
index 0d91f8b0d3a789d3dc1711f6c2b6535d652591ae..41a410f91a47ab41ff7340b019e7d81ca4086cb3 100644 (file)
@@ -1,6 +1,11 @@
 #
 # Conditional build:
-%bcond_without opt             # build opt
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+
+# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
+%endif
 
 %define                module  %{module}
 Summary:       %{module} binding for OCaml
@@ -19,35 +24,40 @@ BuildRequires:      ocaml >= 3.04-7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                debug_package   %{nil}
+%if %{without ocaml_opt}
+%define                no_install_post_strip   1
+# no opt means no native binary, stripping bytecode breaks such programs
+%define                _enable_debug_packages  0
+%endif
 
 %description
 This package contains files needed to run bytecode executables using
-this library.
+TEMPLATE library.
 
 %description -l pl.UTF-8
 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
-używających tej biblioteki.
+używających biblioteki TEMPLATE.
 
 %package devel
-Summary:       %{module} binding for OCaml - development part
-Summary(pl.UTF-8):     Wiązania %{module} dla OCamla - cześć programistyczna
+Summary:       TEMPLATE binding for OCaml - development part
+Summary(pl.UTF-8):     Wiązania TEMPLATE dla OCamla - cześć programistyczna
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %requires_eq   ocaml
 
 %description devel
 This package contains files needed to develop OCaml programs using
-this library.
+TEMPLATE library.
 
 %description devel -l pl.UTF-8
 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
-tej biblioteki.
+biblioteki TEMPLATE.
 
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
-%{__make} -j1 all %{?with_opt:opt} \
+%{__make} -j1 all %{?with_ocaml_opt:opt} \
        CC="%{__cc} %{rpmcflags} -fPIC"
 
 %install
@@ -74,15 +84,21 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
+%dir %{_libdir}/ocaml/%{module}
+%{_libdir}/ocaml/%{module}/*.cma
+%if %{with ocaml_opt}
+%attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
+%endif
 
 %files devel
 %defattr(644,root,root,755)
 %doc LICENSE
-%{_libdir}/ocaml/%{module}/*.cm[xi]
+%{_libdir}/ocaml/%{module}/*.cmi
 %{_libdir}/ocaml/%{module}/*.cmo
 %{_libdir}/ocaml/%{module}/*.mli
-%if %{with opt}
+%if %{with ocaml_opt}
 %{_libdir}/ocaml/%{module}/*.[ao]
+%{_libdir}/ocaml/%{module}/*.cmx
 %{_libdir}/ocaml/%{module}/*.cmxa
 %endif
 %{_libdir}/ocaml/site-lib/%{module}
This page took 0.055615 seconds and 4 git commands to generate.