]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - ocaml.spec
modernize template
[projects/template-specs.git] / ocaml.spec
index 8a3090cf9104c0048aefa9c83c778c762c4d6688..0d91f8b0d3a789d3dc1711f6c2b6535d652591ae 100644 (file)
@@ -1,17 +1,25 @@
-Summary:       TEMPLATE binding for OCaml
-Summary(pl.UTF-8):     Wiązania TEMPLATE dla OCamla
-Name:          ocaml-template
+#
+# Conditional build:
+%bcond_without opt             # build opt
+
+%define                module  %{module}
+Summary:       %{module} binding for OCaml
+Summary(pl.UTF-8):     Wiązania %{module} dla OCamla
+Name:          ocaml-%{module}
 Version:       -
 Release:       1
 License:       - (enter GPL/LGPL/BSD/BSD-like/other license name here)
 Group:         Libraries
-Source0:       template-%{version}.tar.gz
+Source0:       %{module}-%{version}.tar.gz
+URL:           -
 # Source0-md5: -
-BuildRequires: -devel
+#BuildRequires:        -devel
 BuildRequires: ocaml >= 3.04-7
 %requires_eq   ocaml-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                debug_package   %{nil}
+
 %description
 This package contains files needed to run bytecode executables using
 this library.
@@ -21,8 +29,8 @@ Pakiet ten zawiera binaria potrzebne do uruchamiania programów
 używających tej biblioteki.
 
 %package devel
-Summary:       TEMPLATE binding for OCaml - development part
-Summary(pl.UTF-8):     Wiązania TEMPLATE dla OCamla - cześć programistyczna
+Summary:       %{module} binding for OCaml - development part
+Summary(pl.UTF-8):     Wiązania %{module} dla OCamla - cześć programistyczna
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %requires_eq   ocaml
@@ -36,29 +44,28 @@ Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
 tej biblioteki.
 
 %prep
-%setup -q -n template-%{version}
+%setup -q -n %{module}-%{version}
 
 %build
-%{__make} CC="%{__cc} %{rpmcflags} -fPIC" all opt
+%{__make} -j1 all %{?with_opt:opt} \
+       CC="%{__cc} %{rpmcflags} -fPIC"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
+install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{template,stublibs}
-install *.cm[ixa]* *.a dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/template
-install dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -r foo bar $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+#cp -r foo bar $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/template
-cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/template/META <<EOF
-requires = ""
-version = "%{version}"
-directory = "+template"
-archive(byte) = "template.cma"
-archive(native) = "template.cmxa"
-linkopts = ""
+# move to dir pld ocamlfind looks
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
+mv $OCAMLFIND_DESTDIR/%{module}/META \
+       $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
+cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}/META
+directory="+%{module}"
 EOF
 
 %clean
@@ -70,9 +77,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc LICENSE *.mli
-%dir %{_libdir}/ocaml/template
-%{_libdir}/ocaml/template/*.cm[ixa]*
-%{_libdir}/ocaml/template/*.a
+%doc LICENSE
+%{_libdir}/ocaml/%{module}/*.cm[xi]
+%{_libdir}/ocaml/%{module}/*.cmo
+%{_libdir}/ocaml/%{module}/*.mli
+%if %{with opt}
+%{_libdir}/ocaml/%{module}/*.[ao]
+%{_libdir}/ocaml/%{module}/*.cmxa
+%endif
+%{_libdir}/ocaml/site-lib/%{module}
 %{_examplesdir}/%{name}-%{version}
-%{_libdir}/ocaml/site-lib/template
This page took 0.056133 seconds and 4 git commands to generate.