]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - nodejs-package.spec
- LICENSE in base (+few other common doc files), dune post-install cleanup example
[projects/template-specs.git] / nodejs-package.spec
index 903574fd3e5d974d7df9d94f97a02b2499c4d9f7..4f19a1c1fb2c91c05deb1472b42c6732771ac9e2 100644 (file)
@@ -5,9 +5,9 @@ Version:        0.1
 Release:       0.1
 License:       MIT
 Group:         Development/Libraries
-URL:           https://github.com/.../node-PACKAGE_NAME
 Source0:       http://registry.npmjs.org/PACKAGE_NAME/-/%{pkg}-%{version}.tgz
 # Source0-md5: -
+URL:           https://github.com/.../node-PACKAGE_NAME
 BuildRequires: rpmbuild(macros) >= 1.634
 BuildRequires: sed >= 4.0
 Requires:      nodejs
@@ -27,16 +27,18 @@ chmod a+rx bin/*
 rm -rf $RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{nodejs_libdir}/%{pkg}}
 cp -p %{pkg}.js package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
 cp -pr lib package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
 cp -pr index.js package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
 cp -pr index.js package.json lib $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
+cp -pr index.js package.json package $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
 
 # bin scripts in $PATH should be symlinks, so relative resolving in scripts
 # themselves could work
 # REMOVE this comment when copying to real .spec!
 cp -a bin $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
-ln -s %{nodejs_libdir}/%{pkg}/bin/semver $RPM_BUILD_ROOT%{_bindir}
+ln -s %{nodejs_libdir}/%{pkg}/bin/%{pkg} $RPM_BUILD_ROOT%{_bindir}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
This page took 0.074412 seconds and 4 git commands to generate.