]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
Add njs packaging TODO
[packages/nginx.git] / nginx.spec
index f1beea8b7a229e902b755fb70586b98f4e7c8d4c..fc12741172f7d73455cd652694f831e3bc48a83a 100644 (file)
@@ -1,6 +1,7 @@
 # TODO
 # - /etc/sysconfig/nginx file
 # - missing perl build/install requires
+# - add njs: https://nginx.org/en/docs/njs/
 #
 # Conditional build for nginx:
 # Features
@@ -27,6 +28,7 @@
 %bcond_with    http_browser    # http browser module (header "User-agent" parser)
 %bcond_with    modsecurity     # modsecurity module
 %bcond_with    rtmp            # rtmp support
+%bcond_without vts             # virtual host traffic status module
 
 %ifarch x32
 %undefine      with_rtsig
 
 %define                ssl_version     1.0.2
 %define                rtmp_version    1.2.1
-%define                modsecurity_version     2.9.2
+%define                vts_version     0.1.18
+%define                modsecurity_version     2.9.3
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajnoĹ›ci
 # nginx lines:
 # - stable: production quality with stable API
 # - mainline: production quality but API can change
 Name:          nginx
-Version:       1.15.8
-Release:       4
+Version:       1.16.1
+Release:       3
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: 49eecc51a45bdcc8cc147f6747ef8a4c
+# Source0-md5: 45a80f75336c980d240987badc3dcf60
 Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
@@ -58,9 +61,11 @@ Source14:    %{name}.conf
 Source17:      %{name}-mime.types.sh
 Source18:      %{name}.service
 Source22:      http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
-# Source22-md5:        4d9454efb19269c4288ae408ea438b76
+# Source22-md5:        215a96d679a5b0fadcf13b5d09b35422
 Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
 # Source101-md5:       639ac2b78103adaccbcfe484a92acf44
+Source102:     https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
+# Source102-md5:       409a10dbd85e0b807cc77eecec29a3b5
 Patch0:                %{name}-no-Werror.patch
 Patch1:                %{name}-modsecurity-xheaders.patch
 URL:           http://nginx.org/
@@ -231,6 +236,14 @@ Requires:  %{name} = %{version}-%{release}
 %description mod_mail
 Nginx mail module.
 
+%package mod_vts
+Summary:       Nginx virtual host traffic status module
+Group:         Networking/Daemons/HTTP
+Requires:      %{name} = %{version}-%{release}
+
+%description mod_vts
+Nginx virtual host traffic status module.
+
 %package mod_stream
 Summary:       Nginx stream modules
 Group:         Daemons
@@ -253,7 +266,7 @@ monitrc file for monitoring nginx webserver.
 Plik monitrc do monitorowania serwera WWW nginx.
 
 %prep
-%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
+%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102}
 %patch0 -p0
 %{?with_modsecurity:%patch1 -p0}
 
@@ -261,6 +274,10 @@ Plik monitrc do monitorowania serwera WWW nginx.
 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
 %endif
 
+%if %{with vts}
+mv nginx-module-vts-%{vts_version} nginx-vts-module
+%endif
+
 # build mime.types.conf
 #sh %{SOURCE17} /etc/mime.types
 
@@ -313,6 +330,7 @@ cp -f configure auto/
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
+       %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
        %{?with_threads:--with-threads} \
        %{?with_http2:--with-http_v2_module} \
@@ -342,6 +360,7 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
        $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
        $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
        $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
        $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
        $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
 
@@ -389,6 +408,7 @@ load_module http_xslt_filter
 %if %{with mail}
 load_module mail
 %endif
+%{?with_vts:load_module http_vhost_traffic_status}
 %if %{with stream}
 load_module stream
 %endif
@@ -435,6 +455,7 @@ fi
 %module_scripts mod_http_perl
 %module_scripts mod_http_xslt_filter
 %module_scripts mod_mail
+%module_scripts mod_vts
 %module_scripts mod_stream
 %module_scripts mod_stream_geoip
 
@@ -447,6 +468,7 @@ fi
 %dir %attr(750,root,nginx) %{_sysconfdir}
 %dir %{_sysconfdir}/conf.d
 %dir %{_sysconfdir}/modules.d
+%dir %{_sysconfdir}/snippets
 %dir %{_sysconfdir}/vhosts.d
 %dir %{_sysconfdir}/webapps.d
 %attr(640,root,root) %{_sysconfdir}/mime.types
@@ -519,6 +541,13 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
 %endif
 
+%if %{with vts}
+%files mod_vts
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
+%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
+%endif
+
 %if %{with stream}
 %files mod_stream
 %defattr(644,root,root,755)
This page took 0.095345 seconds and 4 git commands to generate.