]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- fixed permissions and group for /etc/nginx
[packages/nginx.git] / nginx.spec
index 9075f5cdbff275b0d3244d5f60db998678cbb09d..2c9b563660193ea41edb3db78ffc01bcd0441669 100644 (file)
@@ -1,8 +1,6 @@
 # TODO
 # - /etc/sysconfig/nginx file
 # - missing perl build/install requires
-# - mod_spdy build http://mailman.nginx.org/pipermail/nginx-devel/2012-June/002343.html patch from http://nginx.org/patches/attic/spdy/
-#   http://nginx.org/en/docs/http/ngx_http_spdy_module.html
 #
 # Conditional build for nginx:
 %bcond_without light           # don't build light version
 %bcond_without realip          # real ip (behind proxy)
 %bcond_without rtsig           # rtsig
 %bcond_without select          # select
-%bcond_without status          # stats module
+%bcond_without spdy            # spdy module
+%bcond_without status          # status module
 %bcond_without ssl             # ssl support
 %bcond_with    http_browser    # header "User-agent" parser
 %bcond_with    rtmp            # rtmp support
+%bcond_with    threads         # thread pool support
+%bcond_with    debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
 %bcond_without auth_request    # auth_request module
 
-%define                rtmp_version    1.1.5
+%ifarch x32
+%undefine      with_rtsig
+%endif
+
+%define                rtmp_version    1.1.7
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajnoĹ›ci
 # nginx lines:
 # - stable: production quality with stable API
 # - mainline: production quality but API can change
 Name:          nginx
-Version:       1.7.9
-Release:       1
+Version:       1.8.0
+Release:       3
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: a4debbe0ce0dd12b9c8f520bc3b66355
+# Source0-md5: 3ca4a37931e9fa301964b8ce889da8cb
 Source1:       http://nginx.net/favicon.ico
 # Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source2:       proxy.conf
 Source3:       %{name}.logrotate
 Source4:       %{name}.mime
-Source5:       %{name}-light.conf
 Source6:       %{name}-light.monitrc
-Source7:       %{name}-light.init
+Source7:       %{name}.init
 Source8:       %{name}-mail.conf
 Source9:       %{name}-mail.monitrc
-Source10:      %{name}-mail.init
-Source11:      %{name}-perl.conf
 Source12:      %{name}-perl.monitrc
-Source13:      %{name}-perl.init
-Source14:      %{name}-standard.conf
+Source14:      %{name}.conf
 Source15:      %{name}-standard.monitrc
-Source16:      %{name}-standard.init
 Source17:      %{name}-mime.types.sh
 Source18:      %{name}-standard.service
 Source19:      %{name}-light.service
 Source20:      %{name}-perl.service
 Source21:      %{name}-mail.service
-# when updating rtmp version, use this url:
-#Source101:    https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
-Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}.tar.gz
-# Source101-md5:       a85f8201c01b7c229b01a5e0fc87b374
+Source101:     https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
+# Source101-md5:       8006de2560db3e55bb15d110220076ac
 Patch0:                %{name}-no-Werror.patch
-Patch1:                nginx-rtmp-module-build.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
-BuildRequires: openssl-devel
+%{?with_ssl:BuildRequires: openssl-devel >= 1.0.2}
 BuildRequires: pcre-devel
 %{?with_perl:BuildRequires: perl-CGI}
 %{?with_perl:BuildRequires: perl-devel}
@@ -107,11 +104,8 @@ Requires(pre):     /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      openssl
-Requires:      pcre
 Requires:      rc-scripts >= 0.2.0
 Requires:      systemd-units >= 38
-Requires:      zlib
 Provides:      group(http)
 Provides:      group(nginx)
 Provides:      user(nginx)
@@ -132,9 +126,7 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
-Requires:      pcre
-Requires:      zlib
+%{?with_ssl:Requires: openssl >= 1.0.2}
 Provides:      nginx-daemon
 Provides:      webserver
 
@@ -169,7 +161,7 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
+%{?with_ssl:Requires: openssl >= 1.0.2}
 Provides:      nginx-daemon
 Provides:      webserver
 
@@ -202,9 +194,6 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
-Requires:      pcre
-Requires:      zlib
 Provides:      nginx-daemon
 
 %description mail
@@ -236,7 +225,7 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
+%{?with_ssl:Requires: openssl >= 1.0.2}
 Provides:      nginx
 Provides:      nginx-daemon
 Conflicts:     logrotate < 3.7-4
@@ -292,9 +281,6 @@ Plik monitrc do monitorowania serwera WWW nginx.
 
 %if %{with rtmp}
 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
-cd nginx-rtmp-module
-%patch1 -p1
-cd ..
 %endif
 
 # build mime.types.conf
@@ -303,149 +289,103 @@ cd ..
 %build
 # NB: not autoconf generated configure
 cp -f configure auto/
-#
-%if %{with perl}
+
+install -d bin
+
+# build with default options
+build() {
+       local type=$1; shift
 ./configure \
        --prefix=%{_prefix} \
-       --sbin-path=%{_sbindir}/%{name}-perl \
-       --conf-path=%{_sysconfdir}/%{name}-perl.conf \
-       --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
-       --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
-       --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
-       --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
+       --sbin-path=%{_sbindir}/%{name}-$type \
+       --conf-path=%{_sysconfdir}/%{name}-$type.conf \
+       --error-log-path=%{_localstatedir}/log/%{name}/%{name}-${type}_error.log \
+       --http-log-path=%{_localstatedir}/log/%{name}/%{name}-${type}_access.log \
+       --pid-path=%{_localstatedir}/run/%{name}-$type.pid \
+       --lock-path=%{_localstatedir}/lock/subsys/%{name}-$type \
+       --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-$type/client_body_temp \
+       --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-$type/fastcgi_temp \
+       --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-$type/proxy_temp \
        --user=nginx \
        --group=nginx \
+       %{?with_ipv6:--with-ipv6} \
+       %{?with_select:--with-select_module} \
+       %{?with_poll:--with-poll_module} \
+       %{?with_rtsig:--with-rtsig_module} \
+       --with-cc="%{__cc}" \
+       --with-cc-opt="%{rpmcflags}" \
+       --with-ld-opt="%{rpmldflags}" \
+       %{?with_debug:--with-debug} \
+       "$@"
+%{__make}
+}
+
+%if %{with perl}
+build perl \
        --with-http_perl_module \
-       --without-mail_pop3_module \
-       --without-mail_imap_module \
-       --without-mail_smtp_module \
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
-       %{?with_ipv6:--with-ipv6} \
        %{?with_sub:--with-http_sub_module} \
-       %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
-       %{?with_rtsig:--with-rtsig_module} \
-       %{?with_select:--with-select_module} \
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
+       %{?with_threads:--with-threads} \
+       %{?with_spdy:--with-http_spdy_module} \
        --with-http_secure_link_module \
-       --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
-       --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
-       --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
-       --with-cc="%{__cc}" \
-       --with-cc-opt="%{rpmcflags}" \
-       --with-ld-opt="%{rpmldflags}"
-%{__make}
-mv -f objs/nginx contrib/nginx-perl
-mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
-mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
+       %{nil}
+
+mv -f objs/nginx bin/nginx-perl
+mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so bin/nginx.so
+mv -f objs/src/http/modules/perl/nginx.pm bin/nginx.pm
 %endif
 
 %if %{with mail}
-./configure \
-       --prefix=%{_prefix} \
-       --sbin-path=%{_sbindir}/%{name}-mail \
-       --conf-path=%{_sysconfdir}/%{name}-mail.conf \
-       --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
-       --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
-       --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
-       --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
-       --user=nginx \
-       --group=nginx \
+build mail \
+       --without-http \
        --with-imap \
        --with-mail \
        --with-mail_ssl_module \
-       --without-http \
-       %{?with_ipv6:--with-ipv6} \
-       %{?with_poll:--with-poll_module} \
-       %{?with_rtsig:--with-rtsig_module} \
-       %{?with_select:--with-select_module} \
-       --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
-       --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
-       --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
-       --with-cc="%{__cc}" \
-       --with-cc-opt="%{rpmcflags}" \
-       --with-ld-opt="%{rpmldflags}" \
-       %{?debug:--with-debug}
-%{__make}
-mv -f objs/nginx contrib/nginx-mail
+       %{nil}
+
+mv -f objs/nginx bin/nginx-mail
 %endif
 
 %if %{with light}
-./configure \
-       --prefix=%{_prefix} \
-       --sbin-path=%{_sbindir}/%{name}-light \
-       --conf-path=%{_sysconfdir}/%{name}-light.conf \
-       --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
-       --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
-       --pid-path=%{_localstatedir}/run/%{name}-light.pid \
-       --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
-       --user=nginx \
-       --group=nginx \
-       %{?with_ipv6:--with-ipv6} \
-       %{?with_poll:--with-poll_module} \
+build light \
        %{?with_realip:--with-http_realip_module} \
-       %{?with_rtsig:--with-rtsig_module} \
-       %{?with_select:--with-select_module} \
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
+       %{?with_threads:--with-threads} \
+       %{?with_spdy:--with-http_spdy_module} \
        --without-http_browser_module \
-       --without-mail_pop3_module \
-       --without-mail_imap_module \
-       --without-mail_smtp_module \
        --with-http_secure_link_module \
-       --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
-       --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
-       --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
-       --with-cc="%{__cc}" \
-       --with-cc-opt="%{rpmcflags}" \
-       --with-ld-opt="%{rpmldflags}" \
-       %{?debug:--with-debug}
-%{__make}
-mv -f objs/nginx contrib/nginx-light
+       %{nil}
+
+mv -f objs/nginx bin/nginx-light
 %endif
 
-./configure \
-       --prefix=%{_prefix} \
-       --sbin-path=%{_sbindir}/%{name}-standard \
-       --conf-path=%{_sysconfdir}/%{name}-standard.conf \
-       --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
-       --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
-       --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
-       --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
-       --user=nginx \
-       --group=nginx \
+build standard \
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
-       %{?with_ipv6:--with-ipv6} \
        %{?with_sub:--with-http_sub_module} \
-       %{?with_poll:--with-poll_module} \
        %{?with_realip:--with-http_realip_module} \
-       %{?with_rtsig:--with-rtsig_module} \
-       %{?with_select:--with-select_module} \
        %{?with_status:--with-http_stub_status_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{!?with_http_browser:--without-http_browser_module} \
        %{?with_rtmp:--add-module=./nginx-rtmp-module} \
        %{?with_auth_request:--with-http_auth_request_module} \
+       %{?with_threads:--with-threads} \
        --with-http_secure_link_module \
-       --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
-       --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
-       --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
-       --with-cc="%{__cc}" \
-       --with-cc-opt="%{rpmcflags}" \
-       --with-ld-opt="%{rpmldflags}" \
-       %{?debug:--with-debug}
-%{__make}
+       %{nil}
 
+mv -f objs/%{name} bin/%{name}-standard
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -458,9 +398,7 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
        $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
        $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
 
-cp -p conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
-cp -p conf/scgi_params $RPM_BUILD_ROOT%{_sysconfdir}/scgi.params
-cp -p conf/uwsgi_params $RPM_BUILD_ROOT%{_sysconfdir}/uwsgi.params
+cp -p conf/*_params $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
 cp -p conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
 cp -p conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
@@ -470,42 +408,41 @@ cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
-cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
-cp -p %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
-install -p %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
-cp -p %{SOURCE18} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-standard.service
-install -p objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
+
+install_build() {
+       local type=$1
+       %{__sed} -e 's/@type@/standard/g' %{_sourcedir}/%{name}.conf \
+               > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-$type.conf
+
+       install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-$type
+       %{__sed} -i -e 's/@type@/standard/g' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-$type
+
+       cp -p %{_sourcedir}/%{name}-$type.service $RPM_BUILD_ROOT%{systemdunitdir}
+       cp -p %{_sourcedir}/%{name}-$type.monitrc $RPM_BUILD_ROOT/etc/monit
+       install -p bin/%{name}-$type $RPM_BUILD_ROOT%{_sbindir}
+}
+
+install_build standard
 ln -sf %{systemdunitdir}/%{name}-standard.service $RPM_BUILD_ROOT/etc/systemd/system/nginx.service
 
 %if %{with light}
-cp -p  %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
-cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
-cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
-cp -p %{SOURCE19} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-light.service
-install -p contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
-%endif
-
-%if %{with mail}
-cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
-cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
-install -p contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
-install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
-cp -p %{SOURCE21} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-mail.service
+install_build light
 %endif
 
 %if %{with perl}
 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
-cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
-cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
-install -p %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
-cp -p %{SOURCE20} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-perl.service
-cp -p contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
-install -p contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
-install -p contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
+install_build perl
+cp -p bin/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
+install -p bin/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
+install -p bin/nginx-perl $RPM_BUILD_ROOT%{_sbindir}
 %endif
 
-rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
-rm -rf $RPM_BUILD_ROOT%{_prefix}/html
+%if %{with mail}
+install_build mail
+%endif
+
+# only touch these for ghost packaging
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -527,7 +464,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-standard
 %systemd_post %{name}-standard.service
-%service %{name}-standard restart
+%service %{name}-standard force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-standard.conf" as config.'
 if ! [ -L /etc/systemd/system/nginx.service ] ; then
        ln -s %{systemdunitdir}/%{name}-standard.service /etc/systemd/system/nginx.service || :
@@ -544,7 +481,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-light
 %systemd_post %{name}-light.service
-%service %{name}-light restart
+%service %{name}-light force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-light.conf" as config'
 
 %post perl
@@ -558,7 +495,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-perl
 %systemd_post %{name}-perl.service
-%service %{name}-perl restart
+%service %{name}-perl force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-perl.conf" as config'
 
 %post mail
@@ -572,7 +509,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-mail
 %systemd_post %{name}-mail.service
-%service %{name}-mail restart
+%service %{name}-mail force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-mail.conf" as config'
 
 %preun standard
@@ -633,11 +570,19 @@ fi
 %triggerpostun -- %{name}-mail < 1.4.1-4
 %systemd_trigger %{name}-mail.service
 
+%triggerpostun common -- %{name}-common < 1.8.0-2
+# skip *this* trigger on downgrade
+[ $1 -le 1 ] && exit 0
+ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
+ln -sf scgi_params %{_sysconfdir}/scgi.params
+ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
+exit 0
+
 %files common
 %defattr(644,root,root,755)
 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
 %doc %lang(ru) CHANGES.ru
-%dir %attr(754,root,root) %{_sysconfdir}
+%dir %attr(750,root,nginx) %{_sysconfdir}
 %dir %{_nginxdir}
 %dir %{_nginxdir}/cgi-bin
 %dir %{_nginxdir}/html
@@ -646,9 +591,12 @@ fi
 # XXX: duplicates, don't use such glob here
 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi.params
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi.params
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
+%ghost %{_sysconfdir}/fastcgi.params
+%ghost %{_sysconfdir}/scgi.params
+%ghost %{_sysconfdir}/uwsgi.params
 %attr(640,root,root) %{_sysconfdir}/mime.types
 %attr(640,root,root) %{_sysconfdir}/koi-utf
 %attr(640,root,root) %{_sysconfdir}/koi-win
This page took 0.042732 seconds and 4 git commands to generate.