]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- fixed permissions and group for /etc/nginx
[packages/nginx.git] / nginx.spec
index 84a1dba6b01554ba3c6ca346beb8e7e84d0aa8a1..2c9b563660193ea41edb3db78ffc01bcd0441669 100644 (file)
 %bcond_without rtsig           # rtsig
 %bcond_without select          # select
 %bcond_without spdy            # spdy module
-%bcond_without status          # stats module
+%bcond_without status          # status module
 %bcond_without ssl             # ssl support
 %bcond_with    http_browser    # header "User-agent" parser
 %bcond_with    rtmp            # rtmp support
 %bcond_with    threads         # thread pool support
-%bcond_with    debug           # build with debug enabled: http://nginx.org/en/docs/debugging_log.html
+%bcond_with    debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
 %bcond_without auth_request    # auth_request module
 
 %ifarch x32
@@ -36,7 +36,7 @@ Summary(pl.UTF-8):    Serwer HTTP i odwrotne proxy o wysokiej wydajnoĹ›ci
 # - mainline: production quality but API can change
 Name:          nginx
 Version:       1.8.0
-Release:       2
+Release:       3
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
@@ -46,14 +46,12 @@ Source1:    http://nginx.net/favicon.ico
 Source2:       proxy.conf
 Source3:       %{name}.logrotate
 Source4:       %{name}.mime
-Source5:       %{name}-light.conf
 Source6:       %{name}-light.monitrc
 Source7:       %{name}.init
 Source8:       %{name}-mail.conf
 Source9:       %{name}-mail.monitrc
-Source11:      %{name}-perl.conf
 Source12:      %{name}-perl.monitrc
-Source14:      %{name}-standard.conf
+Source14:      %{name}.conf
 Source15:      %{name}-standard.monitrc
 Source17:      %{name}-mime.types.sh
 Source18:      %{name}-standard.service
@@ -65,7 +63,7 @@ Source101:    https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/ng
 Patch0:                %{name}-no-Werror.patch
 URL:           http://nginx.net/
 BuildRequires: mailcap
-BuildRequires: openssl-devel
+%{?with_ssl:BuildRequires: openssl-devel >= 1.0.2}
 BuildRequires: pcre-devel
 %{?with_perl:BuildRequires: perl-CGI}
 %{?with_perl:BuildRequires: perl-devel}
@@ -106,11 +104,8 @@ Requires(pre):     /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      openssl
-Requires:      pcre
 Requires:      rc-scripts >= 0.2.0
 Requires:      systemd-units >= 38
-Requires:      zlib
 Provides:      group(http)
 Provides:      group(nginx)
 Provides:      user(nginx)
@@ -131,9 +126,7 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
-Requires:      pcre
-Requires:      zlib
+%{?with_ssl:Requires: openssl >= 1.0.2}
 Provides:      nginx-daemon
 Provides:      webserver
 
@@ -168,7 +161,7 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
+%{?with_ssl:Requires: openssl >= 1.0.2}
 Provides:      nginx-daemon
 Provides:      webserver
 
@@ -201,9 +194,6 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
-Requires:      pcre
-Requires:      zlib
 Provides:      nginx-daemon
 
 %description mail
@@ -235,7 +225,7 @@ Group:              Networking/Daemons/HTTP
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      openssl
+%{?with_ssl:Requires: openssl >= 1.0.2}
 Provides:      nginx
 Provides:      nginx-daemon
 Conflicts:     logrotate < 3.7-4
@@ -333,9 +323,6 @@ build() {
 %if %{with perl}
 build perl \
        --with-http_perl_module \
-       --without-mail_pop3_module \
-       --without-mail_imap_module \
-       --without-mail_smtp_module \
        %{?with_addition:--with-http_addition_module} \
        %{?with_dav:--with-http_dav_module} \
        %{?with_flv:--with-http_flv_module} \
@@ -358,10 +345,10 @@ mv -f objs/src/http/modules/perl/nginx.pm bin/nginx.pm
 
 %if %{with mail}
 build mail \
+       --without-http \
        --with-imap \
        --with-mail \
        --with-mail_ssl_module \
-       --without-http \
        %{nil}
 
 mv -f objs/nginx bin/nginx-mail
@@ -377,9 +364,6 @@ build light \
        %{?with_threads:--with-threads} \
        %{?with_spdy:--with-http_spdy_module} \
        --without-http_browser_module \
-       --without-mail_pop3_module \
-       --without-mail_imap_module \
-       --without-mail_smtp_module \
        --with-http_secure_link_module \
        %{nil}
 
@@ -424,46 +408,38 @@ cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
-cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
-cp -p %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
-install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
-%{__sed} -i -e 's/@flavor@/standard/g' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
-cp -p %{SOURCE18} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-standard.service
-install -p bin/nginx-standard $RPM_BUILD_ROOT%{_sbindir}
+
+install_build() {
+       local type=$1
+       %{__sed} -e 's/@type@/standard/g' %{_sourcedir}/%{name}.conf \
+               > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-$type.conf
+
+       install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-$type
+       %{__sed} -i -e 's/@type@/standard/g' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-$type
+
+       cp -p %{_sourcedir}/%{name}-$type.service $RPM_BUILD_ROOT%{systemdunitdir}
+       cp -p %{_sourcedir}/%{name}-$type.monitrc $RPM_BUILD_ROOT/etc/monit
+       install -p bin/%{name}-$type $RPM_BUILD_ROOT%{_sbindir}
+}
+
+install_build standard
 ln -sf %{systemdunitdir}/%{name}-standard.service $RPM_BUILD_ROOT/etc/systemd/system/nginx.service
 
 %if %{with light}
-cp -p  %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
-cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
-cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
-%{__sed} -i -e 's/@flavor@/light/g' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
-cp -p %{SOURCE19} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-light.service
-install -p bin/nginx-light $RPM_BUILD_ROOT%{_sbindir}
-%endif
-
-%if %{with mail}
-cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
-cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
-install -p bin/nginx-mail $RPM_BUILD_ROOT%{_sbindir}
-install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
-%{__sed} -i -e 's/@flavor@/mail/g' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
-cp -p %{SOURCE21} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-mail.service
+install_build light
 %endif
 
 %if %{with perl}
 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
-cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
-cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
-install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
-%{__sed} -i -e 's/@flavor@/perl/g' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
-cp -p %{SOURCE20} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-perl.service
+install_build perl
 cp -p bin/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
 install -p bin/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
 install -p bin/nginx-perl $RPM_BUILD_ROOT%{_sbindir}
 %endif
 
-rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
-rm -rf $RPM_BUILD_ROOT%{_prefix}/html
+%if %{with mail}
+install_build mail
+%endif
 
 # only touch these for ghost packaging
 touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
@@ -488,7 +464,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-standard
 %systemd_post %{name}-standard.service
-%service %{name}-standard restart
+%service %{name}-standard force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-standard.conf" as config.'
 if ! [ -L /etc/systemd/system/nginx.service ] ; then
        ln -s %{systemdunitdir}/%{name}-standard.service /etc/systemd/system/nginx.service || :
@@ -505,7 +481,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-light
 %systemd_post %{name}-light.service
-%service %{name}-light restart
+%service %{name}-light force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-light.conf" as config'
 
 %post perl
@@ -519,7 +495,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-perl
 %systemd_post %{name}-perl.service
-%service %{name}-perl restart
+%service %{name}-perl force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-perl.conf" as config'
 
 %post mail
@@ -533,7 +509,7 @@ for a in access.log error.log; do
 done
 /sbin/chkconfig --add %{name}-mail
 %systemd_post %{name}-mail.service
-%service %{name}-mail restart
+%service %{name}-mail force-reload
 echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-mail.conf" as config'
 
 %preun standard
@@ -606,7 +582,7 @@ exit 0
 %defattr(644,root,root,755)
 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
 %doc %lang(ru) CHANGES.ru
-%dir %attr(754,root,root) %{_sysconfdir}
+%dir %attr(750,root,nginx) %{_sysconfdir}
 %dir %{_nginxdir}
 %dir %{_nginxdir}/cgi-bin
 %dir %{_nginxdir}/html
This page took 0.03681 seconds and 4 git commands to generate.