]> git.pld-linux.org Git - packages/nginx.git/blobdiff - nginx.spec
- oops, it's 3.7-4 not 3.7.4
[packages/nginx.git] / nginx.spec
index 69f2069fe8e750cc6830293f823d94955e263d1b..22922632e5324f940523d027a8219806222fcc45 100644 (file)
@@ -1,20 +1,22 @@
 # TODO
 # - more bconds (??)
-# - subpackage with error pages
+# - /etc/sysconfig/nginx file
+# - prepare style like nginx.conf
+#
 # Conditional build for nginx:
-%bcond_with    stub_status             # stats module
-%bcond_with    rtsig
-%bcond_with    select
-%bcond_with    poll
-%bcond_with    ssl                     # ssl support
-%bcond_with    imap                    # imap proxy
-%bcond_without http_browser            # parse header "User-agent"
+%bcond_without stub_status             # stats module
+%bcond_without rtsig
+%bcond_without select
+%bcond_without poll
+%bcond_without ssl                     # ssl support
+%bcond_without imap                    # imap proxy
+%bcond_with    http_browser            # header "User-agent" parser
 #
 Summary:       High perfomance HTTP and reverse proxy server
 Summary(pl.UTF-8):     Serwer HTTP i odwrotne proxy o wysokiej wydajności
 Name:          nginx
 Version:       0.5.31
-Release:       3
+Release:       3.1
 License:       BSD-like
 Group:         Networking/Daemons
 Source0:       http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
@@ -25,9 +27,9 @@ Source3:      http://www.nginx.eu/favicon.ico
 # Source3-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
 Source4:       http://www.nginx.eu/download/proxy.conf
 # Source4-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
-Source5:       http://www.nginx.eu/download/nginx.monitrc
+Source5:       http://www.nginx.eu/download/%{name}.monitrc
 # Source5-md5: 1d3f5eedfd34fe95213f9e0fc19daa88
-Source6:       http://www.nginx.eu/download/nginx.conf
+Source6:       http://www.nginx.eu/download/%{name}.conf
 # Source6-md5: 1c112d6f03d0f365e4acc98c1d96261a
 Source7:       %{name}.logrotate
 Patch0:                %{name}-config.patch
@@ -44,20 +46,24 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      rc-scripts
+Requires:      rc-scripts >= 0.2.0
+Provides:      group(http)
+Provides:      group(nginx)
+Provides:      user(nginx)
+Conflicts:     logrotate < 3.7-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/%{name}
 %define                _nginxdir       /home/services/%{name}
 
 %description
-Nginx ("engine x") is a high-performance HTTP server and reverse proxy, 
-as well as an IMAP/POP3 proxy server. Nginx was written by Igor Sysoev 
-for Rambler.ru, Russia's second-most visited website, where it has been 
-running in production for over two and a half years. 
-Igor has released the source code under a BSD-like license. 
-Although still in beta, Nginx is known for its stability, rich feature set, 
-simple configuration, and low resource consumption.
+Nginx ("engine x") is a high-performance HTTP server and reverse
+proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
+Sysoev for Rambler.ru, Russia's second-most visited website, where it
+has been running in production for over two and a half years. Igor has
+released the source code under a BSD-like license. Although still in
+beta, Nginx is known for its stability, rich feature set, simple
+configuration, and low resource consumption.
 
 %description -l pl.UTF-8
 Serwer HTTP i odwrotne proxy o wysokiej wydajności.
@@ -74,7 +80,7 @@ Requires:     monit
 monitrc file for monitoring nginx webserver server.
 
 %description -n monit-rc-nginx -l pl.UTF-8
-Plik monitrc do monitorowania serwera www nging.
+Plik monitrc do monitorowania serwera www nginx.
 
 
 %prep
@@ -100,7 +106,7 @@ sh %{SOURCE2} /etc/mime.types
        %{?with_poll:--with-poll_module} \
        %{?with_ssl:--with-http_ssl_module} \
        %{?with_imap:--with-imap} \
-       %{?with_http_browser:--without-http_browser_module} \
+       %{!?with_http_browser:--without-http_browser_module} \
        --http-log-path=%{_localstatedir}/log/%{name}/access.log \
        --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
        --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
@@ -124,6 +130,8 @@ install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
 install mime.types $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 install %{SOURCE3} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
+install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
+install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
 install %{SOURCE5} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
@@ -183,8 +191,10 @@ fi
 %attr(640,root,root) %{_sysconfdir}/mime.types
 %attr(755,root,root) %{_sbindir}/%{name}
 %attr(770,root,%{name}) /var/cache/%{name}
+%attr(750,root,root) %dir /var/log/archive/%{name}
 %attr(750,%{name},logs) /var/log/%{name}
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
 
 %files -n monit-rc-nginx
 %defattr(644,root,root,755)
This page took 0.028781 seconds and 4 git commands to generate.