]> git.pld-linux.org Git - packages/net-snmp.git/blobdiff - net-snmp.spec
- upstream code style (spaces for indent)
[packages/net-snmp.git] / net-snmp.spec
index 8f7d77c9a1d157dc72dd75c7a4f5be31c143c0ef..780e60b1c98103ec00c73fb0d2b405321ce1e3ba 100644 (file)
@@ -1,14 +1,3 @@
-# TODO
-# - package or remove:
-#   %{py_sitedir}/netsnmp/__init__.py
-#   %{py_sitedir}/netsnmp/client.py
-#   %{py_sitedir}/netsnmp/tests/__init__.py
-#   %{py_sitedir}/netsnmp/tests/__init__.pyc
-#   %{py_sitedir}/netsnmp/tests/__init__.pyo
-#   %{py_sitedir}/netsnmp/tests/test.py
-#   %{py_sitedir}/netsnmp/tests/test.pyc
-#   %{py_sitedir}/netsnmp/tests/test.pyo
-#   %{_datadir}/snmp/snmp_perl.pl
 #
 # Conditional build:
 %bcond_without autodeps        # don't BR packages only for deps resolving
@@ -27,12 +16,12 @@ Summary(pt_BR.UTF-8):       Agente SNMP da UCD
 Summary(ru.UTF-8):     Набор утилит для протокола SNMP от UC-Davis
 Summary(uk.UTF-8):     Набір утиліт для протоколу SNMP від UC-Davis
 Name:          net-snmp
-Version:       5.4.1
-Release:       16
+Version:       5.4.2.1
+Release:       11
 License:       BSD-like
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
-# Source0-md5: 6c974df7a5a5b1579f72115e6b045bda
+# Source0-md5: 984932520143f0c8bf7b7ce1fc9e1da1
 Source1:       %{name}d.init
 Source2:       %{name}d.conf
 Source3:       %{name}d.sysconfig
@@ -54,13 +43,17 @@ Patch9:             %{name}-python.patch
 Patch10:       %{name}-lvalue.patch
 Patch11:       %{name}-defaultconfig.patch
 Patch12:       %{name}-use-rpm-hrmib.patch
-Patch13:       %{name}-duplicate-ip.patch
 Patch14:       %{name}-lm_sensors_3.patch
+Patch15:       %{name}-subcontainer.patch
+Patch16:       %{name}-netlink.patch
+Patch17:       %{name}-TCP_STATS_CACHE_TIMEOUT.patch
+Patch18:       %{name}-src-dst-confusion.patch
 URL:           http://www.net-snmp.org/
 BuildRequires: autoconf >= 2.61-3
 BuildRequires: automake
 BuildRequires: elfutils-devel
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
+BuildRequires: libnl-devel >= 1:1.1
 BuildRequires: libtool >= 1.4
 BuildRequires: libwrap-devel
 %{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 3.0.1}
@@ -68,8 +61,10 @@ BuildRequires:       openssl-devel >= 0.9.7d
 %{?with_autodeps:BuildRequires:        perl-Term-ReadKey}
 BuildRequires: perl-devel >= 1:5.8.0
 %if %{with python}
-BuildRequires: python-devel >= 1:2.5
+BuildRequires: python-devel
+BuildRequires: python-modules
 BuildRequires: python-setuptools
+BuildRequires: rpm-pythonprov
 %endif
 %if %{with rpm}
 BuildRequires: rpm
@@ -88,6 +83,9 @@ Obsoletes:    ucd-snmp
 Conflicts:     rpm < 4.4.9-43.11
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# linking libraries is ugly in this package
+%define                no_install_post_check_so        1
+
 %define                logfile         /var/log/snmpd.log
 
 %description
@@ -159,7 +157,7 @@ Summary(uk.UTF-8):  Середовище розробки для проекту U
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      elfutils-devel
-%{?with_kerberos5:Requires:    krb5-devel}
+%{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libwrap-devel
 %{?with_lm_sensors:Requires:   lm_sensors-devel >= 3.0.1}
 Requires:      openssl-devel >= 0.9.7c
@@ -421,8 +419,11 @@ SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p0
 %patch14 -p0
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p3
 
 %build
 %{__libtoolize}
@@ -447,6 +448,7 @@ cp -f /usr/share/automake/config.sub .
        --with-bzip2=%{_prefix} \
        --with%{!?with_perl:out}-perl-modules \
        --with%{!?with_python:out}-python-modules \
+       --enable-local-smux \
        --with-mib-modules="host agentx smux mibII/mta_sendmail \
 %ifarch %{ix86} %{x8664}
 %if %{with lm_sensors}
@@ -458,7 +460,7 @@ cp -f /usr/share/automake/config.sub .
        %{?with_kerberos5:--with-security-modules="ksm"} \
        --with-sys-contact="root@localhost" \
        --with-sys-location="Unknown" \
-       --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback " \
+       --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback" \
        --with-persistent-directory="/var/lib/net-snmp" \
        --enable-ucd-snmp-compatibility \
        --enable-ipv6 \
@@ -482,9 +484,9 @@ perl -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,snmp},/var/log}
+install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,snmp},/var/log,/var/lib/net-snmp,%{_libdir}/snmp/dlmod}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
@@ -504,7 +506,7 @@ install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
 #      $RPM_BUILD_ROOT%{_datadir}/snmp/mibs
 
 cd perl
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
@@ -535,6 +537,13 @@ done
 rm -f $RPM_BUILD_ROOT%{_libdir}/libsnmp.a
 %endif
 
+%if %{with python}
+%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/tests
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/*.py
+%endif
+
+touch $RPM_BUILD_ROOT%{_datadir}/snmp/mibs/.index
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -585,12 +594,17 @@ fi
 
 %attr(755,root,root) %{_sbindir}/snmpd
 
+%dir %{_libdir}/snmp
+%dir %{_libdir}/snmp/dlmod
+
 %{_mandir}/man5/snmpd.conf.5*
 %{_mandir}/man5/snmpd.examples.5*
 %{_mandir}/man5/snmpd.internal.5*
 %{_mandir}/man5/variables.5*
 %{_mandir}/man8/snmpd.8*
 
+%dir %attr(700,root,root) /var/lib/net-snmp
+
 %attr(640,root,root) %ghost %{logfile}
 
 %files libs
@@ -651,7 +665,8 @@ fi
 %files mibs
 %defattr(644,root,root,755)
 %dir %{_datadir}/snmp
-%{_datadir}/snmp/mibs
+%{_datadir}/snmp/mibs/*.txt
+%ghost %{_datadir}/snmp/mibs/.index
 
 %files snmptrapd
 %defattr(644,root,root,755)
This page took 0.044365 seconds and 4 git commands to generate.