]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- multiarch support
[packages/mplayer.git] / mplayer.spec
index 3c2146909c231d850ec4439e431d5e720ed80edc..497ad3f4dc377d056e5d137b7774c5c162548422 100644 (file)
 %bcond_without alsa            # without ALSA audio output
 %bcond_without arts            # without arts audio output
 %bcond_without caca            # without libcaca video output
+%bcond_without cdparanoia      # without cdparanoia support
 %bcond_without dshow           # disable DirectShow support
+%bcond_without enca            # disable using ENCA charset oracle library
+%bcond_without esd             # disable EsounD sound support
+%bcond_without faad            # disable FAAD2 (AAC) support
+%bcond_without gif             # disable GIF support
 %bcond_without gui             # without GTK+ GUI
 %bcond_without joystick        # disable joystick support
+%bcond_without libdts          # disable libdts support
 %bcond_without libdv           # disable libdv en/decoding support
 %bcond_without lirc            # without lirc support
 %bcond_without live            # without live.com libraries
 %bcond_without theora          # without theora support
 %bcond_without win32           # without win32 codecs support
 %bcond_without vorbis          # without Ogg-Vorbis audio support
+%bcond_without xvid            # disable XviD codec
 %bcond_without mencoder        # disable mencoder (a/v encoder) compilation
-%bcond_without libdts          # disable libdts support
 %bcond_without sdl             # disable SDL
 %bcond_without doc             # don't build docs (slow)
 %bcond_with    gtk2            # EXPERIMENTAL support for GTK+ version 2
-%bcond_with    shared  # experimental libmplayer.so support
+%bcond_with    shared          # experimental libmplayer.so support
 
 %ifnarch %{ix86}
 %undefine      with_win32
 %ifarch %{x8664}
 %undefine      with_runtime
 %endif
+
+%if %{_lib} == "lib64"
+%define        _suf    64
+%else
+%define        _suf    32
+%endif
+
 # set it to 0, or 1
 %define                snapshot        0
 
@@ -67,8 +80,9 @@ Summary(pl):  Odtwarzacz film
 Summary(pt_BR):        Reprodutor de filmes
 Name:          mplayer
 Version:       1.0
-%define                _rel    5.5
-Release:       2.%{pre}.%{_rel}
+%define                _rel    2.1
+#Release:      2.%{pre}.%{_rel}
+Release:       2.pre7try3.%{_rel}
 # DO NOT increase epoch unless it's really neccessary!
 # especially such changes like pre7->pre7try2, increase Release instead!
 # PS: $ rpmvercmp pre7try2 pre7
@@ -109,6 +123,8 @@ Patch14:    %{name}-shared.patch
 Patch15:       %{name}-xvmc.patch
 Patch16:       %{name}-kill-mabi_altivec.patch
 Patch17:       %{name}-gcc4.patch
+Patch18:       http://www.mplayerhq.hu/MPlayer/patches/demuxer_h_fix_20060212.diff
+Patch19:       %{name}-CVE-2005-4048.patch
 #http://www.openchrome.org/snapshots/mplayer/
 URL:           http://www.mplayerhq.hu/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
@@ -117,18 +133,18 @@ BuildRequires:    OpenGL-devel
 %{?with_aalib:BuildRequires:   aalib-devel}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: audiofile-devel
-BuildRequires: cdparanoia-III-devel
+%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
 %{?with_divx4linux:BuildRequires:      divx4linux-devel >= 1:5.01.20020418}
 %{?with_doc:BuildRequires:     docbook-style-xsl}
 %{?with_dxr3:BuildRequires:    em8300-devel}
-BuildRequires: enca-devel
-BuildRequires: esound-devel
-BuildRequires: faad2-devel >= 2.0
+%{?with_enca:BuildRequires:    enca-devel}
+%{?with_esd:BuildRequires:     esound-devel}
+%{?with_faad:BuildRequires:    faad2-devel >= 2.0}
 BuildRequires: freetype-devel
 %ifarch ppc
 %{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
 %endif
+%{?with_gif:BuildRequires:     giflib-devel}
 %if %{with gui}
 BuildRequires: gtk+%{?with_gtk2:2}-devel
 %endif
@@ -145,7 +161,6 @@ BuildRequires:      libpng-devel
 %{?with_dshow:BuildRequires:   libstdc++-devel}
 %{?with_theora:BuildRequires:  libtheora-devel}
 %{?with_vorbis:BuildRequires:  libvorbis-devel}
-BuildRequires: libungif-devel
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
 %{?with_live:BuildRequires:    live}
@@ -157,7 +172,13 @@ BuildRequires:     pkgconfig
 %{?with_svga:BuildRequires:    svgalib-devel}
 %{?with_xmms:BuildRequires:    xmms-libs}
 BuildRequires: xorg-lib-libXvMC-devel
-BuildRequires: xvid-devel >= 1:0.9.0
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXinerama-devel
+BuildRequires: xorg-lib-libXv-devel
+BuildRequires: xorg-lib-libXxf86dga-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
+%{?with_xvid:BuildRequires:    xvid-devel >= 1:0.9.0}
 BuildRequires: zlib-devel
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires(post,postun): /sbin/ldconfig
@@ -305,6 +326,8 @@ cp -f etc/codecs.conf etc/codecs.win32.conf
 %patch15 -p0
 %patch16 -p1
 %patch17 -p1
+%patch18 -p0
+%patch19 -p1
 
 # kill evil file, hackery not needed with llh
 echo > osdep/kerneltwosix.h
@@ -360,7 +383,12 @@ set -x
 %{?with_alsa:--enable-alsa --disable-select} \
 %{!?with_arts:--disable-arts} \
 %{!?with_caca:--disable-caca} \
+%{!?with_cdparanoia:--disable-cdparanoia} \
 %{!?with_dshow:--disable-dshow} \
+%{!?with_enca:--disable-enca} \
+%{!?with_esd:--disable-esd} \
+%{!?with_faad:--disable-external-faad --disable-internal-faad}%{?with_faad:--enable-external-faad} \
+%{!?with_gif:--disable-gif} \
 %{?with_joystick:--enable-joystick} \
 %{!?with_libdv:--disable-libdv} \
 %{!?with_libdts:--disable-libdts} \
@@ -377,8 +405,8 @@ set -x
 %{?with_osd:--enable-menu} \
 %{!?with_theora:--disable-theora} \
 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
+%{!?with_xvid:--disable-xvid} \
 %{!?with_mencoder:--disable-mencoder} \
-       --enable-external-faad \
        --enable-dga \
        --enable-fbdev \
        --enable-gl \
@@ -390,12 +418,11 @@ set -x
        --enable-xmga \
        --enable-xv \
        --enable-xvmc \
-       --with-xvmclib=XvMCW \
-       --enable-xvid \
+       --enable-dynamic-plugins \
        --enable-largefiles \
        --language=all \
        --with-codecsdir=%{_libdir}/codecs \
-       --enable-dynamic-plugins \
+       --with-xvmclib=XvMCW \
        "$@"
 
        %{__make}
@@ -429,11 +456,14 @@ install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysc
 
 # executables
 %if %{with mencoder}
-install mencoder $RPM_BUILD_ROOT%{_bindir}
+install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
+ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
 %endif
-install mplayer $RPM_BUILD_ROOT%{_bindir}
+install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
+ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
 %if %{with gui}
-install gmplayer $RPM_BUILD_ROOT%{_bindir}
+install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
+ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
 %endif
 
 # fonts
@@ -485,12 +515,12 @@ umask 022
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/mplayer
+%attr(755,root,root) %{_bindir}/mplayer*
 
 %if %{with gui}
 %files -n gmplayer
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/gmplayer
+%attr(755,root,root) %{_bindir}/gmplayer*
 %{_desktopdir}/gmplayer.desktop
 %dir %{_datadir}/%{name}/Skin
 %ghost %{_datadir}/%{name}/Skin/default
@@ -500,7 +530,7 @@ umask 022
 %defattr(644,root,root,755)
 %doc DOCS/tech/encoding-tips.txt DOCS/tech/swscaler_filters.txt
 %doc DOCS/tech/swscaler_methods.txt DOCS/tech/colorspaces.txt
-%attr(755,root,root) %{_bindir}/mencoder
+%attr(755,root,root) %{_bindir}/mencoder*
 
 %files common
 %defattr(644,root,root,755)
This page took 0.287815 seconds and 4 git commands to generate.