]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- BR: docbook-dtd412-xml
[packages/mplayer.git] / mplayer.spec
index be8619ef023895ce0a3ef2500dea6001c6e9545f..259f2b4c91e8fcac44a269d9e4626ff4311bfbfb 100644 (file)
@@ -1,20 +1,21 @@
-#
 # TODO:
+# - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
 # - update for lzo 2
-# - update for polypaudio 0.8
-# - use external lrmi and few other libs:
-#   http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
+# - try to use external lrmi and few other libs:
+#   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
+# - segfaults on amd64:
+#   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
+#   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
 #
 # Conditional build:
 %bcond_with    directfb        # with DirectFB video output
-%bcond_with    divx4linux      # with divx4linux a/v support (binaries, instead of included OpenDivx)
 %bcond_with    dxr3            # enable use of DXR3/H+ hardware MPEG decoder
 %bcond_with    ggi             # with ggi video output
 %bcond_with    nas             # with NAS audio output
 %bcond_with    svga            # with svgalib video output
-%bcond_with    osd             # with osd menu support
+%bcond_without osd             # with osd menu support
 %bcond_without altivec         # without altivec support
-%bcond_without x264            # without x264 support (needs newer libx264 snap)
+%bcond_without x264            # without x264 support
 %bcond_with    xmms            # with XMMS inputplugin support
 %bcond_without aalib           # without aalib video output
 %bcond_without jack            # without JACKD support
@@ -22,7 +23,6 @@
 %bcond_without arts            # without arts audio output
 %bcond_without caca            # without libcaca video output
 %bcond_without cdparanoia      # without cdparanoia support
-%bcond_without dshow           # disable DirectShow support
 %bcond_without enca            # disable using ENCA charset oracle library
 %bcond_without esd             # disable EsounD sound support
 %bcond_without faad            # disable FAAD2 (AAC) support
 %bcond_without libdts          # disable libdts support
 %bcond_without libdv           # disable libdv en/decoding support
 %bcond_without lirc            # without lirc support
-%bcond_without live            # without live.com libraries
-%bcond_with    lzo             # with LZO support (requires lzo 1.x)
+%bcond_with    live            # without LIVE555 libraries
+%bcond_without lzo             # with LZO support (requires lzo 2.x)
 %bcond_without mad             # without mad (audio MPEG) support
-%bcond_with    polyp           # with polyp audio output (requires polypaudio 0.6 or 0.7)
+%bcond_without pulseaudio      # without pulseaudio output
 %bcond_without quicktime       # without binary quicktime dll support
 %bcond_without real            # without Real* 8/9 codecs support
 %bcond_without runtime         # disable runtime cpu detection, just detect CPU
 %bcond_without smb             # disable Samba (SMB) input support
 %bcond_without theora          # without theora support
 %bcond_without win32           # without win32 codecs support
+%bcond_without vidix           # disable vidix
 %bcond_without vorbis          # without Ogg-Vorbis audio support
 %bcond_without xvid            # disable XviD codec
 %bcond_without mencoder        # disable mencoder (a/v encoder) compilation
 %bcond_without sdl             # disable SDL
 %bcond_without doc             # don't build docs (slow)
 %bcond_with    shared          # experimental libmplayer.so support
-%bcond_without amr             # don't build 3GPP Adaptive Multi Rate (AMR) speech codec
+%bcond_with    amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
+%bcond_without gnomess         # disable controling gnome screensaver
+%bcond_with    ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
+%bcond_with    system_ffmpeg   # use ffmpeg-devel, rather bundled sources (needs more work or mplayer snapshot)
 
 %ifnarch %{ix86}
 %undefine      with_win32
 %undefine      with_quicktime
+%undefine      with_vidix
 %endif
 
-%ifarch %{x8664}
+%ifnarch %{ix86} %{x8664} ppc ppc64
 %undefine      with_runtime
 %endif
 
 %if %{_lib} == "lib64"
-%define        _suf    64
+%define                _suf    64
 %else
-%define        _suf    32
+%define                _suf    32
 %endif
 
-# set it to 0, or 1
-%define                snapshot        0
-
-%define                sname           MPlayer
-%define                snap            %{nil}
-
-%define                pre             pre8
+%define                subver  rc2
+%define                rel     15
 
 Summary:       MPlayer - THE Movie Player for UN*X
-Summary(de):   MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
-Summary(es):   Otro reproductor de películas
-Summary(ko):   ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
-Summary(pl):   Odtwarzacz filmów dla systemów uniksowych
-Summary(pt_BR):        Reprodutor de filmes
+Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
+Summary(es.UTF-8):     Otro reproductor de películas
+Summary(ko.UTF-8):     리눅스용 미디어플레이어
+Summary(pl.UTF-8):     Odtwarzacz filmów dla systemów uniksowych
+Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer
 Version:       1.0
-%define                _rel    1
-Release:       3.%{pre}.%{_rel}
+Release:       5.%{subver}.%{rel}
 # DO NOT increase epoch unless it's really neccessary!
 # especially such changes like pre7->pre7try2, increase Release instead!
 # PS: $ rpmvercmp pre7try2 pre7
@@ -93,14 +92,8 @@ Release:     3.%{pre}.%{_rel}
 Epoch:         3
 License:       GPL
 Group:         Applications/Multimedia
-%if %{snapshot}
-#Source0:      ftp://ftp1.mplayerhq.hu/MPlayer/cvs/%{sname}-%{snap}.tar.bz2
-#Source0:      %{name}-%{snap}.tar.bz2
-#Source1:      libavcodec-%{snap}.tar.bz2
-%else
-Source0:       ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{pre}.tar.bz2
-# Source0-md5: f82bb2bc51b6cd5e5dd96f88f6f98582
-%endif
+Source0:       ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
+# Source0-md5: 7e27e535c2d267637df34898f1b91707
 Source3:       ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
 # Source3-md5: 7b47904a925cf58ea546ca15f3df160c
 Source5:       g%{name}.desktop
@@ -108,28 +101,34 @@ Source6:  ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.ta
 # Source6-md5: 1ecd31d17b51f16332b1fcc7da36b312
 Source7:       %{name}.png
 Source8:       %{name}.desktop
-# AMR WB FLOAT
-Source10:      http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26204-530.zip
-# Source10-md5:        988060bdb18b5d64b8bd82c3507d2420
-# AMR NB FLOAT
-Source11:      http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26104-540.zip
-# Source11-md5:        4dcbeb2bc28bf86e7131fe4cae3e0dec
-Patch0:                %{name}-no_libnsl.patch
+# http://www.on2.com/gpl/mplayer/
+Source9:       http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
+# Source9-md5: 2361e56b40f52dfc20131e458e2aed38
 Patch1:                %{name}-cp1250-fontdesc.patch
-Patch2:                %{name}-codec.patch
-Patch3:                %{name}-home_etc.patch
+#Patch2:               %{name}-codec.patch
+#Patch3:               %{name}-home_etc.patch
 Patch4:                %{name}-350.patch
 Patch5:                %{name}-configure.patch
+# outdated via ffmpeg?
+Patch6:                %{name}-system-amr.patch
 Patch8:                %{name}-altivec.patch
-Patch10:       %{name}-pcmsplit.patch
-Patch11:       %{name}-bio2jack.patch
-Patch12:       %{name}-x86_64-detection.patch
-Patch13:       %{name}-mythtv.patch
+#Patch10:      %{name}-pcmsplit.patch
+#Patch13:      %{name}-mythtv.patch
 Patch14:       %{name}-shared.patch
-Patch15:       %{name}-xvmc.patch
-Patch16:       %{name}-kill-mabi_altivec.patch
-Patch17:       %{name}-auto-expand.patch
 #http://www.openchrome.org/snapshots/mplayer/
+#Patch15:      %{name}-xvmc.patch
+Patch17:       %{name}-auto-expand.patch
+# update
+#Patch18:      %{name}-gnome-screensaver.patch
+Patch19:       %{name}-on2flix.patch
+Patch22:       %{name}-ffmpeg.patch
+Patch23:       %{name}-live.patch
+Patch24:       %{name}-fontconfig_sub.patch
+Patch25:       http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
+Patch26:       %{name}-check-byteswap.patch
+Patch27:       http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
+Patch28:       http://www.ocert.org/patches/2008-013/mplayer_demux_real.patch
+Patch29:       %{name}-x264.patch
 URL:           http://www.mplayerhq.hu/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: OpenAL-devel
@@ -137,15 +136,24 @@ BuildRequires:    OpenGL-devel
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.1.7}
 %{?with_aalib:BuildRequires:   aalib-devel}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
+%if %{with amr}
+BuildRequires: amrnb-devel
+BuildRequires: amrwb-devel >= 5.3.0
+%endif
 %{?with_arts:BuildRequires:    artsc-devel}
+%{?with_ssse3:BuildRequires:   binutils >= 3:2.16.92}
 %{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
-%{?with_divx4linux:BuildRequires:      divx4linux-devel >= 1:5.01.20020418}
 %{?with_doc:BuildRequires:     docbook-style-xsl}
+%{?with_doc:BuildRequires:     docbook-dtd412-xml}
 %{?with_dxr3:BuildRequires:    em8300-devel}
 %{?with_enca:BuildRequires:    enca-devel}
 %{?with_esd:BuildRequires:     esound-devel}
+BuildRequires: faac-devel
 %{?with_faad:BuildRequires:    faad2-devel >= 2.0}
+%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.4.9-3.20070626.1.1}
 BuildRequires: freetype-devel
+BuildRequires: fribidi-devel
+%{?with_vidix:BuildRequires:   vidix-devel}
 %ifarch ppc
 %{?with_altivec:BuildRequires: gcc >= 5:3.3.2-3}
 %endif
@@ -153,44 +161,45 @@ BuildRequires:    freetype-devel
 %if %{with gui}
 BuildRequires: gtk+2-devel
 %endif
+%{?with_gnomess:BuildRequires: dbus-glib-devel}
+%{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+%{?with_jack:%requires_eq      jack-audio-connection-kit-libs}
 BuildRequires: lame-libs-devel
-%{?with_jack:BuildRequires:    libbio2jack-devel >= 0.8-2}
 %{?with_caca:BuildRequires:    libcaca-devel}
 %{?with_libdts:BuildRequires:  libdts-devel}
 %{?with_libdv:BuildRequires:   libdv-devel}
+BuildRequires: libdvdnav-devel
 %{?with_ggi:BuildRequires:     libggi-devel}
 BuildRequires: libjpeg-devel
 %{?with_mad:BuildRequires:     libmad-devel}
+BuildRequires: libmpcdec-devel >= 1.2.1
 BuildRequires: libpng-devel
 %{?with_smb:BuildRequires:     libsmbclient-devel}
-%{?with_dshow:BuildRequires:   libstdc++-devel}
 %{?with_theora:BuildRequires:  libtheora-devel}
-%{?with_vorbis:BuildRequires:  libvorbis-devel}
-%{?with_x264:BuildRequires:    libx264-devel >= 0.1.2-1.20060430_2245.1}
+# tremor is used by default, internal as we don't have system one
+#%{?with_vorbis:BuildRequires: libvorbis-devel}
+%{?with_x264:BuildRequires:    libx264-devel >= 0.1.2-1.20081023_2245.1}
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
 %{?with_live:BuildRequires:    live}
-%{?with_lzo:BuildRequires:     lzo-devel < 2.0}
+%{?with_lzo:BuildRequires:     lzo-devel >= 2.0}
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 BuildRequires: pkgconfig
-%{?with_polyp:BuildRequires:   polypaudio-devel >= 0.6}
-%{?with_polyp:BuildRequires:   polypaudio-devel < 0.8}
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9}
 BuildRequires: speex-devel >= 1.1
 %{?with_svga:BuildRequires:    svgalib-devel}
 %{?with_xmms:BuildRequires:    xmms-libs}
-BuildRequires: xorg-lib-libXvMC-devel
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXv-devel
+BuildRequires: xorg-lib-libXvMC-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
 %{?with_xvid:BuildRequires:    xvid-devel >= 1:0.9.0}
 BuildRequires: zlib-devel
-%{?with_amr:BuildRequires:     unzip}
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires(post,postun): /sbin/ldconfig
 Requires:      OpenGL
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -212,87 +221,87 @@ Voodoo2/3 hardware, SDL v1.1.7 driver etc.
 
 If you want to use win32 codecs install w32codec package.
 
-%description -l de
+%description -l de.UTF-8
 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
 Kennzeichnend ist die herausragende Format- und
-Plattform-Kompatibilität.
+Plattform-Kompatibilität.
 
-Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
-plattformexklusive, wodurch etwa Windows Media auch außerhalb von
-Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
-Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
+Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
+plattformexklusive, wodurch etwa Windows Media auch außerhalb von
+Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
+Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
-Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
-installierte Codecs nicht mit MPlayer kollidieren können.
+Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
+installierte Codecs nicht mit MPlayer kollidieren können.
 
-%description -l es
+%description -l es.UTF-8
 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
-G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
-overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
+G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
+overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
 v1.1.7 etc.
 
 Si quiere usar codecs Win32, instale el paquete w32codec.
 
-%description -l ko
-MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
-ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
-MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
-Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
-(Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
-¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
-Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
-ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
-ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
-
-%description -l pl
-Odtwarzacz wideo. Wspierane formaty wejciowe: VCD (VideoCD), MPEG1/2,
+%description -l ko.UTF-8
+MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
+파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
+MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
+Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
+(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
+수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
+크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
+있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
+부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
+
+%description -l pl.UTF-8
+Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
-Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
+Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
-G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
+G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
 
-Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
+Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
 
-%description -l pt_BR
-MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
-áudio. Diferentes mecanismos de reprodução podem também ser
+%description -l pt_BR.UTF-8
+MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
+áudio. Diferentes mecanismos de reprodução podem também ser
 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
 
 %package -n gmplayer
 Summary:       MPlayer with GTK+ GUI interface
-Summary(pl):   MPlayer z graficznym interfejsem GTK+
+Summary(pl.UTF-8):     MPlayer z graficznym interfejsem GTK+
 Group:         X11/Applications/Multimedia
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-skin
-Provides:      %{name} = %{epoch}:%{version}-%{release}
 
 %description -n gmplayer
 MPlayer with GUI GTK+ interface.
 
-%description -n gmplayer -l pl
+%description -n gmplayer -l pl.UTF-8
 MPlayer z graficznym interfejsem GTK+.
 
 %package common
 Summary:       Configuration files and documentation for MPlayer
-Summary(pl):   Pliki konfiguracyjne i dokumentacja dla MPlayera
+Summary(pl.UTF-8):     Pliki konfiguracyjne i dokumentacja dla MPlayera
 Group:         Applications/Multimedia
+Obsoletes:     mplayer-vidix
 
 %description common
 Configuration files, man page and HTML documentation for MPlayer.
 
-%description common -l pl
+%description common -l pl.UTF-8
 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
 
 %package -n mencoder
 Summary:       MEncoder - a movie encoder for Linux
-Summary(pl):   MEncoder - koder filmów dla Linuksa
+Summary(pl.UTF-8):     MEncoder - koder filmów dla Linuksa
 Group:         Applications/Multimedia
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 
@@ -300,66 +309,67 @@ Requires: %{name}-common = %{epoch}:%{version}-%{release}
 MEncoder is a movie encoder for Linux and is a part of the MPlayer
 package.
 
-%description -n mencoder -l pl
-MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
+%description -n mencoder -l pl.UTF-8
+MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
 
 %prep
-%if %{snapshot}
-%setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
-%else
-%setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
-%endif
-
-%if %{with amr}
-cd libavcodec
-mkdir amrwb_float
-mkdir amr
-mkdir amr_float
-# put 26204-xxx.zip into libavcodec/amrwb_float
-cd amrwb_float
-unzip -j %{SOURCE10}
-unzip -j 26204-530_ANSI-C_source_code.zip
-# put 26104-xxx.zip into libavcodec/amr_float
-cd ../amr_float
-unzip -j %{SOURCE11}
-unzip -j 26104-540_ANSI_C_source_code.zip
-cd ../..
-%endif
-
+%setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
 cp -f etc/codecs.conf etc/codecs.win32.conf
-#%patch0 -p1
 %patch1 -p0
-##%patch2 -p1
-##%patch3 -p1  -- old home_etc behavior
+#%%patch2 -p1 -- still needed?
+##%%patch3 -p1 -- old home_etc behavior
 %patch4 -p1
 %patch5 -p1
+#%%patch6 -p1 # - try ffmpeg
 %patch8 -p1
 #%%patch10 -p1
-#%patch11 -p1  # maybe TODO, JACK audio output rewritten without bio2jack
-#%patch12 -p1  # seems obsolete
-#%patch13 -p1  # TODO
+#%%patch13 -p1 # TODO
 %if %{with shared}
 %patch14 -p1
 %endif
-#%patch15 -p0  # TODO
-%patch16 -p1
+#%%patch15 -p0 # TODO
 %patch17 -p1
+%if %{with gnomess}
+#%%patch18 -p1
+%endif
+
+# on2flix
+cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
+rm -f mencoder-on2flixenglinux/version.diff
+%patch19 -p1
+for a in mencoder-on2flixenglinux/*.diff; do
+       patch -p0 < $a
+done
+
+%{?with_system_ffmpeg:%patch22 -p1}
+%patch23 -p1
+%patch24 -p0
+%patch25 -p0
+%patch26 -p1
+%patch27 -p0
+%patch28 -p0
+%patch29 -p1
+
+# recent dvdnav-config doesn't support --minilibs.
+sed -i 's:--minilibs:--libs:g' configure
 
-# kill evil file, hackery not needed with llh
-echo > osdep/kerneltwosix.h
+sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
+rm -f font-*/runme
 
-find . -type d -name CVS -print | xargs rm -rf
+%if %{with system_ffmpeg}
+# using external ffmpeg, but mplayer adds these to includepath
+rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
+%endif
 
 %build
 %if %{with shared}
 CFLAGS="%{rpmcflags} -fPIC"
-LDFLAGS="%{rpmldflags} -wl,--as-needed"
 %else
 CFLAGS="%{rpmcflags}"
-LDFLAGS="%{rpmldflags}"
 %endif
 CC="%{__cc}"
-export CC CFLAGS
+LDFLAGS="%{rpmldflags}"
+export CC CFLAGS LDFLAGS
 
 build() {
 set -x
@@ -367,10 +377,18 @@ set -x
        %{?debug:--enable-debug=3} \
        --prefix=%{_prefix} \
        --confdir=%{_sysconfdir}/mplayer \
-       --with-x11incdir=%{_includedir} \
-       --with-x11libdir=%{_libdir} \
        --with-extraincdir=%{_includedir}/xvid \
-       --enable-menu \
+       --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
+%if %{with system_ffmpeg}
+       --disable-libavutil_a \
+       --disable-libavcodec_a \
+       --disable-libavformat_a \
+       --disable-libpostproc_a \
+       --enable-libavutil_so \
+       --enable-libavcodec_so \
+       --enable-libavformat_so \
+       --enable-libpostproc_so \
+%endif
 %ifnarch %{ix86} %{x8664}
        --disable-mmx \
        --disable-mmxext \
@@ -380,55 +398,62 @@ set -x
        --disable-sse2 \
        --disable-fastmemcpy \
 %endif
+       %{!?with_ssse3:--disable-ssse3} \
 %ifarch ppc
-%{!?with_altivec:--disable-altivec} \
+       %{!?with_altivec:--disable-altivec} \
 %endif
-%{?with_directfb:--enable-directfb} \
-%{!?with_directfb:--disable-directfb} \
-%{!?with_divx4linux:--disable-divx4linux} \
-%{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
-%{!?with_dxr3:--disable-dxr3} \
-%{!?with_ggi:--disable-ggi} \
-%{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
-%{!?with_live:--disable-live} \
-%{!?with_lzo:--disable-liblzo} \
-%{!?with_nas:--disable-nas} \
-%{!?with_svga:--disable-svga} \
-%{!?with_aalib:--disable-aa} \
-%{!?with_jack:--disable-jack} \
-%{!?with_alsa:--disable-alsa} \
-%{?with_alsa:--enable-alsa --disable-select} \
-%{!?with_arts:--disable-arts} \
-%{!?with_caca:--disable-caca} \
-%{!?with_cdparanoia:--disable-cdparanoia} \
-%{!?with_dshow:--disable-dshow} \
-%{!?with_enca:--disable-enca} \
-%{!?with_esd:--disable-esd} \
-%{!?with_faad:--disable-external-faad --disable-internal-faad}%{?with_faad:--enable-external-faad} \
-%{!?with_gif:--disable-gif} \
-%{?with_joystick:--enable-joystick} \
-%{!?with_libdv:--disable-libdv} \
-%{!?with_libdts:--disable-libdts} \
---%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
-%{!?with_mad:--disable-mad} \
-%{!?with_polyp:--disable-polyp} \
-%{!?with_quicktime:--disable-qtx} \
-%{!?with_real:--disable-real} \
---%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
-%{!?with_select:--disable-select} \
-%{!?with_smb:--disable-smb} \
-%{!?with_win32:--disable-win32} \
-%{!?with_vorbis:--disable-vorbis} \
-%{?with_osd:--enable-menu} \
-%{!?with_theora:--disable-theora} \
-%{!?with_x264:--disable-x264} \
-%{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
-%{!?with_xvid:--disable-xvid} \
-%{!?with_mencoder:--disable-mencoder} \
-       --enable-dga \
+       %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
+       %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
+       %{?with_directfb:--enable-directfb} \
+       %{!?with_directfb:--disable-directfb} \
+       %{!?with_dxr3:--disable-dxr3} \
+       %{!?with_ggi:--disable-ggi} \
+       %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
+       %{!?with_live:--disable-live} \
+       %{!?with_lzo:--disable-liblzo} \
+       %{!?with_nas:--disable-nas} \
+       %{!?with_svga:--disable-svga} \
+       %{!?with_aalib:--disable-aa} \
+       %{!?with_jack:--disable-jack} \
+       %{!?with_alsa:--disable-alsa} \
+       %{?with_alsa:--enable-alsa --disable-select} \
+       %{!?with_arts:--disable-arts} \
+       %{!?with_caca:--disable-caca} \
+       %{!?with_cdparanoia:--disable-cdparanoia} \
+       %{!?with_enca:--disable-enca} \
+       %{!?with_esd:--disable-esd} \
+       %{!?with_faad:--disable-faad-external --disable-faad-internal} \
+       %{?with_faad:--disable-faad-internal} \
+       %{!?with_gif:--disable-gif} \
+       %{?with_joystick:--enable-joystick} \
+       %{!?with_libdv:--disable-libdv} \
+       %{!?with_libdts:--disable-libdts} \
+       --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
+       %{!?with_mad:--disable-mad} \
+       %{!?with_pulseaudio:--disable-polyp} \
+       %{!?with_quicktime:--disable-qtx} \
+       %{!?with_real:--disable-real} \
+       --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
+       %{!?with_select:--disable-select} \
+       %{!?with_smb:--disable-smb} \
+       %{!?with_win32:--disable-win32dll} \
+       %{!?with_vorbis:--disable-vorbis} \
+       %{?with_osd:--enable-menu} \
+       %{!?with_theora:--disable-theora} \
+       %{!?with_x264:--disable-x264} \
+       %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
+       %{!?with_xvid:--disable-xvid} \
+       %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
+       %{?with_vidix:--disable-vidix-internal} \
+       %{!?with_mencoder:--disable-mencoder} \
+       --enable-dga1 \
+       --enable-dga2 \
+       --enable-dvdnav \
        --enable-fbdev \
        --enable-gl \
        --enable-mga \
+       --enable-radio \
+       --enable-radio-capture \
        --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
        --enable-tdfxfb \
        --enable-vm \
@@ -439,7 +464,7 @@ set -x
        --enable-dynamic-plugins \
        --enable-largefiles \
        --language=all \
-       --with-codecsdir=%{_libdir}/codecs \
+       --codecsdir=%{_libdir}/codecs \
        --with-xvmclib=XvMCW \
        "$@"
 
@@ -448,7 +473,7 @@ set -x
 
 %if %{with gui}
 # build GUI version
-build --enable-gui
+build --enable-gui --disable-mencoder
 mv -f mplayer gmplayer
 %{__make} distclean
 %endif
@@ -465,11 +490,10 @@ rm -rf $RPM_BUILD_ROOT
 install -d \
        $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
        $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
-       $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
+       $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
        $RPM_BUILD_ROOT%{_desktopdir}
 
 # default config files
-sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
 
 # executables
@@ -485,22 +509,11 @@ ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
 %endif
 
 # fonts
-rm -f font-*/runme
 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
 
-# libraries
-%ifarch %{ix86}
-install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
-install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
-%endif
-
-%if %{with gui}
-ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
-%endif
-
-# X-files
 %if %{with gui}
+touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
 %endif
 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
@@ -515,21 +528,19 @@ install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
-install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
+#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
+%post -n gmplayer
 umask 022
-/sbin/ldconfig
 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
 
-%postun
+%postun -n gmplayer
 umask 022
-/sbin/ldconfig
-[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
+[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
 
 %files
 %defattr(644,root,root,755)
@@ -540,39 +551,39 @@ umask 022
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gmplayer*
 %{_desktopdir}/gmplayer.desktop
-%dir %{_datadir}/%{name}/Skin
-%ghost %{_datadir}/%{name}/Skin/default
+%dir %{_datadir}/%{name}/skins
+%ghost %{_datadir}/%{name}/skins/default
 %endif
 
+%if %{with mencoder}
 %files -n mencoder
 %defattr(644,root,root,755)
 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
 %doc DOCS/tech/colorspaces.txt
 %attr(755,root,root) %{_bindir}/mencoder*
+%endif
 
 %files common
 %defattr(644,root,root,755)
-# HTML and XML-generated docs
-%doc DOCS/HTML/en
 %doc DOCS/tech
 %if %{with win32}
 %doc etc/codecs.win32.conf
 %endif
+%if %{with doc}
+# HTML and XML-generated docs
+%doc DOCS/HTML/en
+%lang(cs) %doc DOCS/HTML/cs
 %lang(de) %doc DOCS/HTML/de
 %lang(es) %doc DOCS/HTML/es
 %lang(fr) %doc DOCS/HTML/fr
 %lang(hu) %doc DOCS/HTML/hu
-%lang(it) %doc DOCS/it
 %lang(pl) %doc DOCS/HTML/pl
 %lang(ru) %doc DOCS/HTML/ru
-%lang(zh_CN) %doc DOCS/zh
-%doc AUTHORS ChangeLog README
-
-%ifarch %{ix86}
-%attr(755,root,root) %{_libdir}/libdha.so.*.*
-%attr(755,root,root) %{_libdir}/mplayer
+#%lang(zh_CN) %doc DOCS/zh
 %endif
+%doc AUTHORS README
+
 %dir %{_sysconfdir}/%{name}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
 %{_mandir}/man1/*
@@ -583,9 +594,9 @@ umask 022
 %lang(hu) %{_mandir}/hu/man1/*
 %lang(it) %{_mandir}/it/man1/*
 %lang(pl) %{_mandir}/pl/man1/*
-%lang(sv) %{_mandir}/sv/man1/*
+#%lang(sv) %{_mandir}/sv/man1/*
 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
 %{_desktopdir}/mplayer.desktop
-%{_pixmapsdir}/*
+%{_pixmapsdir}/mplayer.png
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/font*
This page took 0.126745 seconds and 4 git commands to generate.