]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- BR: docbook-dtd412-xml
[packages/mplayer.git] / mplayer.spec
index a71e4b7bd0dcd30e381e59fed48e4a1a141d4ddb..259f2b4c91e8fcac44a269d9e4626ff4311bfbfb 100644 (file)
@@ -13,7 +13,7 @@
 %bcond_with    ggi             # with ggi video output
 %bcond_with    nas             # with NAS audio output
 %bcond_with    svga            # with svgalib video output
-%bcond_with    osd             # with osd menu support
+%bcond_without osd             # with osd menu support
 %bcond_without altivec         # without altivec support
 %bcond_without x264            # without x264 support
 %bcond_with    xmms            # with XMMS inputplugin support
@@ -23,7 +23,6 @@
 %bcond_without arts            # without arts audio output
 %bcond_without caca            # without libcaca video output
 %bcond_without cdparanoia      # without cdparanoia support
-%bcond_without dshow           # disable DirectShow support
 %bcond_without enca            # disable using ENCA charset oracle library
 %bcond_without esd             # disable EsounD sound support
 %bcond_without faad            # disable FAAD2 (AAC) support
@@ -36,7 +35,7 @@
 %bcond_with    live            # without LIVE555 libraries
 %bcond_without lzo             # with LZO support (requires lzo 2.x)
 %bcond_without mad             # without mad (audio MPEG) support
-%bcond_without pulseaudio              # without pulseaudio output
+%bcond_without pulseaudio      # without pulseaudio output
 %bcond_without quicktime       # without binary quicktime dll support
 %bcond_without real            # without Real* 8/9 codecs support
 %bcond_without runtime         # disable runtime cpu detection, just detect CPU
@@ -55,7 +54,8 @@
 %bcond_with    shared          # experimental libmplayer.so support
 %bcond_with    amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
 %bcond_without gnomess         # disable controling gnome screensaver
-%bcond_with    ssse3   # sse3 optimizations (needs binutils >= 2.16.92)
+%bcond_with    ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
+%bcond_with    system_ffmpeg   # use ffmpeg-devel, rather bundled sources (needs more work or mplayer snapshot)
 
 %ifnarch %{ix86}
 %undefine      with_win32
 %undefine      with_vidix
 %endif
 
-%ifarch %{x8664} sparc sparc64
+%ifnarch %{ix86} %{x8664} ppc ppc64
 %undefine      with_runtime
 %endif
 
 %if %{_lib} == "lib64"
-%define        _suf    64
+%define                _suf    64
 %else
-%define        _suf    32
+%define                _suf    32
 %endif
 
 %define                subver  rc2
-%define                rel             3
+%define                rel     15
 
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
@@ -109,7 +109,8 @@ Patch1:             %{name}-cp1250-fontdesc.patch
 #Patch3:               %{name}-home_etc.patch
 Patch4:                %{name}-350.patch
 Patch5:                %{name}-configure.patch
-#Patch6:               %{name}-system-amr.patch # outdated via ffmpeg?
+# outdated via ffmpeg?
+Patch6:                %{name}-system-amr.patch
 Patch8:                %{name}-altivec.patch
 #Patch10:      %{name}-pcmsplit.patch
 #Patch13:      %{name}-mythtv.patch
@@ -117,12 +118,17 @@ Patch14:  %{name}-shared.patch
 #http://www.openchrome.org/snapshots/mplayer/
 #Patch15:      %{name}-xvmc.patch
 Patch17:       %{name}-auto-expand.patch
-#Patch18:      %{name}-gnome-screensaver.patch # update
+# update
+#Patch18:      %{name}-gnome-screensaver.patch
 Patch19:       %{name}-on2flix.patch
 Patch22:       %{name}-ffmpeg.patch
 Patch23:       %{name}-live.patch
 Patch24:       %{name}-fontconfig_sub.patch
 Patch25:       http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
+Patch26:       %{name}-check-byteswap.patch
+Patch27:       http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
+Patch28:       http://www.ocert.org/patches/2008-013/mplayer_demux_real.patch
+Patch29:       %{name}-x264.patch
 URL:           http://www.mplayerhq.hu/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: OpenAL-devel
@@ -138,12 +144,13 @@ BuildRequires:    amrwb-devel >= 5.3.0
 %{?with_ssse3:BuildRequires:   binutils >= 3:2.16.92}
 %{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
 %{?with_doc:BuildRequires:     docbook-style-xsl}
+%{?with_doc:BuildRequires:     docbook-dtd412-xml}
 %{?with_dxr3:BuildRequires:    em8300-devel}
 %{?with_enca:BuildRequires:    enca-devel}
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: faac-devel
 %{?with_faad:BuildRequires:    faad2-devel >= 2.0}
-BuildRequires: ffmpeg-devel >= 0.4.9-3.20070626.1.1
+%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.4.9-3.20070626.1.1}
 BuildRequires: freetype-devel
 BuildRequires: fribidi-devel
 %{?with_vidix:BuildRequires:   vidix-devel}
@@ -156,6 +163,7 @@ BuildRequires:      gtk+2-devel
 %endif
 %{?with_gnomess:BuildRequires: dbus-glib-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+%{?with_jack:%requires_eq      jack-audio-connection-kit-libs}
 BuildRequires: lame-libs-devel
 %{?with_caca:BuildRequires:    libcaca-devel}
 %{?with_libdts:BuildRequires:  libdts-devel}
@@ -167,11 +175,10 @@ BuildRequires:    libjpeg-devel
 BuildRequires: libmpcdec-devel >= 1.2.1
 BuildRequires: libpng-devel
 %{?with_smb:BuildRequires:     libsmbclient-devel}
-%{?with_dshow:BuildRequires:   libstdc++-devel}
 %{?with_theora:BuildRequires:  libtheora-devel}
 # tremor is used by default, internal as we don't have system one
 #%{?with_vorbis:BuildRequires: libvorbis-devel}
-%{?with_x264:BuildRequires:    libx264-devel >= 0.1.2-1.20060828_2245.1}
+%{?with_x264:BuildRequires:    libx264-devel >= 0.1.2-1.20081023_2245.1}
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
 %{?with_live:BuildRequires:    live}
@@ -273,7 +280,6 @@ Summary(pl.UTF-8):  MPlayer z graficznym interfejsem GTK+
 Group:         X11/Applications/Multimedia
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-skin
-Provides:      %{name} = %{epoch}:%{version}-%{release}
 
 %description -n gmplayer
 MPlayer with GUI GTK+ interface.
@@ -310,21 +316,21 @@ MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
 %setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
 cp -f etc/codecs.conf etc/codecs.win32.conf
 %patch1 -p0
-#%patch2 -p1
-##%patch3 -p1  -- old home_etc behavior
+#%%patch2 -p1 -- still needed?
+##%%patch3 -p1 -- old home_etc behavior
 %patch4 -p1
 %patch5 -p1
-#%patch6 -p1 # - try ffmpeg
+#%%patch6 -p1 # - try ffmpeg
 %patch8 -p1
 #%%patch10 -p1
-#%patch13 -p1  # TODO
+#%%patch13 -p1 # TODO
 %if %{with shared}
 %patch14 -p1
 %endif
-#%patch15 -p0  # TODO
+#%%patch15 -p0 # TODO
 %patch17 -p1
 %if %{with gnomess}
-#%patch18 -p1
+#%%patch18 -p1
 %endif
 
 # on2flix
@@ -335,12 +341,25 @@ for a in mencoder-on2flixenglinux/*.diff; do
        patch -p0 < $a
 done
 
-%patch22 -p1
+%{?with_system_ffmpeg:%patch22 -p1}
 %patch23 -p1
 %patch24 -p0
-cd stream
 %patch25 -p0
-cd -
+%patch26 -p1
+%patch27 -p0
+%patch28 -p0
+%patch29 -p1
+
+# recent dvdnav-config doesn't support --minilibs.
+sed -i 's:--minilibs:--libs:g' configure
+
+sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
+rm -f font-*/runme
+
+%if %{with system_ffmpeg}
+# using external ffmpeg, but mplayer adds these to includepath
+rm -rf libavcodec libavdevice libavformat libavutil libpostproc libswscale
+%endif
 
 %build
 %if %{with shared}
@@ -359,8 +378,8 @@ set -x
        --prefix=%{_prefix} \
        --confdir=%{_sysconfdir}/mplayer \
        --with-extraincdir=%{_includedir}/xvid \
-       --with-extralibdir=%{_x_libraries} \
-       --enable-menu \
+       --with-extralibdir=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
+%if %{with system_ffmpeg}
        --disable-libavutil_a \
        --disable-libavcodec_a \
        --disable-libavformat_a \
@@ -369,6 +388,7 @@ set -x
        --enable-libavcodec_so \
        --enable-libavformat_so \
        --enable-libpostproc_so \
+%endif
 %ifnarch %{ix86} %{x8664}
        --disable-mmx \
        --disable-mmxext \
@@ -380,55 +400,55 @@ set -x
 %endif
        %{!?with_ssse3:--disable-ssse3} \
 %ifarch ppc
-%{!?with_altivec:--disable-altivec} \
+       %{!?with_altivec:--disable-altivec} \
 %endif
-%{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
-%{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
-%{?with_directfb:--enable-directfb} \
-%{!?with_directfb:--disable-directfb} \
-%{!?with_dxr3:--disable-dxr3} \
-%{!?with_ggi:--disable-ggi} \
-%{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
-%{!?with_live:--disable-live} \
-%{!?with_lzo:--disable-liblzo} \
-%{!?with_nas:--disable-nas} \
-%{!?with_svga:--disable-svga} \
-%{!?with_aalib:--disable-aa} \
-%{!?with_jack:--disable-jack} \
-%{!?with_alsa:--disable-alsa} \
-%{?with_alsa:--enable-alsa --disable-select} \
-%{!?with_arts:--disable-arts} \
-%{!?with_caca:--disable-caca} \
-%{!?with_cdparanoia:--disable-cdparanoia} \
-%{!?with_dshow:--disable-dshow} \
-%{!?with_enca:--disable-enca} \
-%{!?with_esd:--disable-esd} \
-%{!?with_faad:--disable-faad-external --disable-faad-internal} \
-%{?with_faad:--disable-faad-internal} \
-%{!?with_gif:--disable-gif} \
-%{?with_joystick:--enable-joystick} \
-%{!?with_libdv:--disable-libdv} \
-%{!?with_libdts:--disable-libdts} \
---%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
-%{!?with_mad:--disable-mad} \
-%{!?with_pulseaudio:--disable-pulse} \
-%{!?with_quicktime:--disable-qtx} \
-%{!?with_real:--disable-real} \
---%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
-%{!?with_select:--disable-select} \
-%{!?with_smb:--disable-smb} \
-%{!?with_win32:--disable-win32dll} \
-%{!?with_vorbis:--disable-vorbis} \
-%{?with_osd:--enable-menu} \
-%{!?with_theora:--disable-theora} \
-%{!?with_x264:--disable-x264} \
-%{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
-%{!?with_xvid:--disable-xvid} \
-%{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
-%{?with_vidix:--disable-vidix-internal} \
-%{!?with_mencoder:--disable-mencoder} \
+       %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
+       %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
+       %{?with_directfb:--enable-directfb} \
+       %{!?with_directfb:--disable-directfb} \
+       %{!?with_dxr3:--disable-dxr3} \
+       %{!?with_ggi:--disable-ggi} \
+       %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
+       %{!?with_live:--disable-live} \
+       %{!?with_lzo:--disable-liblzo} \
+       %{!?with_nas:--disable-nas} \
+       %{!?with_svga:--disable-svga} \
+       %{!?with_aalib:--disable-aa} \
+       %{!?with_jack:--disable-jack} \
+       %{!?with_alsa:--disable-alsa} \
+       %{?with_alsa:--enable-alsa --disable-select} \
+       %{!?with_arts:--disable-arts} \
+       %{!?with_caca:--disable-caca} \
+       %{!?with_cdparanoia:--disable-cdparanoia} \
+       %{!?with_enca:--disable-enca} \
+       %{!?with_esd:--disable-esd} \
+       %{!?with_faad:--disable-faad-external --disable-faad-internal} \
+       %{?with_faad:--disable-faad-internal} \
+       %{!?with_gif:--disable-gif} \
+       %{?with_joystick:--enable-joystick} \
+       %{!?with_libdv:--disable-libdv} \
+       %{!?with_libdts:--disable-libdts} \
+       --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
+       %{!?with_mad:--disable-mad} \
+       %{!?with_pulseaudio:--disable-polyp} \
+       %{!?with_quicktime:--disable-qtx} \
+       %{!?with_real:--disable-real} \
+       --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
+       %{!?with_select:--disable-select} \
+       %{!?with_smb:--disable-smb} \
+       %{!?with_win32:--disable-win32dll} \
+       %{!?with_vorbis:--disable-vorbis} \
+       %{?with_osd:--enable-menu} \
+       %{!?with_theora:--disable-theora} \
+       %{!?with_x264:--disable-x264} \
+       %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
+       %{!?with_xvid:--disable-xvid} \
+       %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
+       %{?with_vidix:--disable-vidix-internal} \
+       %{!?with_mencoder:--disable-mencoder} \
        --enable-dga1 \
        --enable-dga2 \
+       --enable-dvdnav \
        --enable-fbdev \
        --enable-gl \
        --enable-mga \
@@ -474,7 +494,6 @@ install -d \
        $RPM_BUILD_ROOT%{_desktopdir}
 
 # default config files
-sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
 
 # executables
@@ -490,12 +509,11 @@ ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
 %endif
 
 # fonts
-rm -f font-*/runme
 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
 
 %if %{with gui}
-ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
+touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
 %endif
 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
@@ -534,7 +552,7 @@ umask 022
 %attr(755,root,root) %{_bindir}/gmplayer*
 %{_desktopdir}/gmplayer.desktop
 %dir %{_datadir}/%{name}/skins
-#%ghost %{_datadir}/%{name}/skins/default
+%ghost %{_datadir}/%{name}/skins/default
 %endif
 
 %if %{with mencoder}
This page took 0.05127 seconds and 4 git commands to generate.