]> git.pld-linux.org Git - packages/metakit.git/blobdiff - metakit.spec
- tabs in preamble
[packages/metakit.git] / metakit.spec
index fc096ab4f0e225e7eae5fb5a4ffa6cf148a32cec..44e80fce11b5f8886c7eda25f6f21ac22e8f806d 100644 (file)
@@ -1,19 +1,18 @@
 Summary:       Embeddable database
-Summary(pl):   Baza danych
+Summary(pl.UTF-8):     Baza danych
 Name:          metakit
-Version:       2.4.5
-Release:       1
+Version:       2.4.9.5
+Release:       0.1
 License:       GPL
 Group:         Libraries
-Source0:       http://www.equi4.com/pub/mk/%{name}-%{version}/%{name}-%{version}-35.tar.gz
-Patch0:                %{name}-opt.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-debian.patch
-URL:           http://www.equi4.com/metakit/
-BuildRequires: libtool
+Source0:       http://www.equi4.com/pub/mk/%{name}-%{version}.tar.gz
+# Source0-md5: 37ba351462dad0d7f01394e04c173ce3
+URL:           http://www.equi4.com/metakit.html
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
+BuildRequires: python-devel
 BuildRequires: tcl-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -25,61 +24,79 @@ need a complex runtime installation. In terms of the data model,
 MetaKit takes the middle ground between RDBMS, OODBMS, and flat-file
 databases - yet it is quite different from each of them.
 
-%description -l pl
-MetaKit to baza danych pracuj±ca na platformach Unix, Windows,
-Macintosh oraz innych. Pozwala ona na tworzenie aplikacji, które
-zapisuj± dane efektywnie w sposób ³atwy do przenoszenia miêdzy
-platformami i które nie wymagaj± skomplikowanej instalacji. MetaKit
-u¿ywaj±c okre¶leñ z dziedziny baz danych znajduje siê pomiêdzy RDBMS,
-OODBMS i bazami opartymi na p³askich-plikach.
+%description -l pl.UTF-8
+MetaKit to baza danych pracująca na platformach Unix, Windows,
+Macintosh oraz innych. Pozwala ona na tworzenie aplikacji, które
+zapisują dane efektywnie w sposób łatwy do przenoszenia między
+platformami i które nie wymagają skomplikowanej instalacji. MetaKit
+używając określeń z dziedziny baz danych znajduje się pomiędzy RDBMS,
+OODBMS i bazami opartymi na płaskich-plikach.
 
 %package devel
 Summary:       Header files and development documentation for %{name}
-Summary(pl):   Pliki nag³ówkowe i dokumentacja do %{name}
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do %{name}
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     metakit-static
 
 %description devel
 Header files and development documentation for %{name}.
 
-%description devel -l pl
-Pliki nag³ówkowe i dokumentacja do %{name}.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i dokumentacja do %{name}.
 
-%package static
-Summary:       %{name} static library
-Summary(pl):   Statyczna biblioteka %{name}
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+%package -n python-metakit
+Summary:       Python modules for metakit
+Summary(pl.UTF-8):     Moduły Pythona dla pakietu metakit
+Group:         Libraries/Python
+Requires:      %{name} = %{version}-%{release}
+%pyrequires_eq python-libs
+
+%description -n python-metakit
+Python modules for metakit.
+
+%description -n python-metakit -l pl.UTF-8
+Moduły Pythona dla pakietu metakit.
 
-%description static
-%{name} static library.
+%package -n tcl-metakit
+Summary:       Tcl modules for metakit
+Summary(pl.UTF-8):     Moduły Tcl-a dla pakietu metakit
+Group:         Development/Languages/Tcl
+Requires:      %{name} = %{version}-%{release}
 
-%description static -l pl
-Biblioteka statyczna %{name}.
+%description -n tcl-metakit
+Tcl modules for metakit.
+
+%description -n tcl-metakit -l pl.UTF-8
+Moduły Tcl-a dla pakietu metakit.
 
 %prep
 %setup -q
-#%patch0 -p1
-%patch1 -p1
-#%patch2 -p1
+
+# remove CVS control files
+find -name CVS -print0 | xargs -0 rm -rf
 
 %build
 cd unix
-libtoolize --copy --force
-aclocal
+%{__libtoolize}
+%{__aclocal}
 %{__autoconf}
-%configure
+%configure \
+       --with-tcl \
+       --with-python \
+       --enable-shared
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}
-cd unix
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{py_sitedir}} \
+       $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
+       -C unix \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd .. && gzip -9nf README CHAN*
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -89,17 +106,23 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc READ*.gz
+%doc README
 %attr(755,root,root) %{_libdir}/*.so
 
 %files devel
 %defattr(644,root,root,755)
-%doc CHA*.gz
-%attr(755,root,root) %{_libdir}/*.la
-#%attr(755,root,root) %{_libdir}/*.so
+%doc CHANGES Metakit.html doc
 %{_includedir}/*.h
 %{_includedir}/*.inl
+%{_examplesdir}/%{name}-%{version}
+
+%files -n python-metakit
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/Mk4py.so
+%{py_sitedir}/metakit.py
 
-%files static
+%files -n tcl-metakit
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%dir %{_libdir}/tcl8.4/Mk4tcl
+%attr(755,root,root) %{_libdir}/tcl8.4/Mk4tcl/Mk4tcl.so
+%{_libdir}/tcl8.4/Mk4tcl/pkgIndex.tcl
This page took 0.073046 seconds and 4 git commands to generate.