]> git.pld-linux.org Git - packages/memcached.git/blobdiff - memcached.spec
- repcached patch (default off)
[packages/memcached.git] / memcached.spec
index d06420bec1bd5e6a3f8d02a441484b0593309291..9c87a23d64d29e9400386ed0813929fbd48f38db 100644 (file)
@@ -1,55 +1,70 @@
-# TODO
-# - memcached has -P option for pid, but root privs are dropped before
-#   pid is written, so either run memcached as new uid or hack code to
-#   write pidfile before changing uid, as rc-script removes pid on
-#   shutdown anyway.
+#
+# Conditional build:
+%bcond_with            repcached               # repcached support, http://repcached.lab.klab.org/
+
 Summary:       A high-performance, distributed memory object caching system
-Summary(pl):   Rozproszony, wysokiej wydajno¶ci system cache'owania obiektów
+Summary(pl.UTF-8):     Rozproszony, wysokiej wydajności system cache'owania obiektów
 Name:          memcached
-Version:       1.1.12
-Release:       4
+Version:       1.4.5
+Release:       2
 License:       BSD
 Group:         Networking/Daemons
-Source0:       http://www.danga.com/memcached/dist/%{name}-%{version}.tar.gz
-# Source0-md5: a1236dad33e9ac6c36d53faa8da61780
+Source0:       http://memcached.googlecode.com/files/%{name}-%{version}.tar.gz
+# Source0-md5: 583441a25f937360624024f2881e5ea8
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
-URL:           http://www.danga.com/memcached/
+URL:           http://memcached.org/
+Patch0:                repcached.patch
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libevent-devel >= 1.1
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires(post,preun):  /sbin/chkconfig
-Requires:      rc-scripts
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires:      rc-scripts >= 0.4.1.23
+Provides:      group(memcached)
+Provides:      user(memcached)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 A high-performance, distributed memory object caching system.
 
-%description -l pl
-Rozproszony, wysokiej wydajno¶ci system cache'owania obiektów.
+%description -l pl.UTF-8
+Rozproszony, wysokiej wydajności system cache'owania obiektów.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       %{?with_repcached:--enable-replication} \
+       --disable-coverage
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
+install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},/var/run/memcached}
 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1}
 
-install memcached $RPM_BUILD_ROOT%{_sbindir}
-install doc/memcached.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install -p memcached $RPM_BUILD_ROOT%{_sbindir}
+cp -a doc/memcached.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
+install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
+%pre
+%groupadd -g 209 %{name}
+%useradd -u 209 -d /usr/share/empty -g %{name} -c "Memcached User" %{name}
 
 %post
 /sbin/chkconfig --add %{name}
@@ -61,13 +76,20 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del %{name}
 fi
 
+%postun
+if [ "$1" = "0" ]; then
+       %userremove %{name}
+       %groupremove %{name}
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS README TODO doc/*.txt
-%attr(755,root,root) %{_sbindir}/*
-%{_mandir}/man1/*
-%attr(754,root,root) /etc/rc.d/init.d/%{name}
+%doc AUTHORS README doc/*.txt
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
+%attr(754,root,root) /etc/rc.d/init.d/%{name}
+%attr(755,root,root) %{_sbindir}/%{name}
+%{_mandir}/man1/memcached.1*
+%dir %attr(770,root,memcached) /var/run/memcached
This page took 0.115731 seconds and 4 git commands to generate.