]> git.pld-linux.org Git - packages/lxc.git/blobdiff - lxc.spec
- release 2 (by relup.sh)
[packages/lxc.git] / lxc.spec
index 6a2de21e8d8319aa21ceb286d8ae11d617132867..dec77c2950cfd9f025cf382de19754e44c90d033 100644 (file)
--- a/lxc.spec
+++ b/lxc.spec
@@ -1,5 +1,4 @@
 # TODO
-# - bash-completion: /etc/bash_completion.d/lxc
 # - package apparmor stuff
 
 # Conditional build:
 %bcond_with    selinux # SELinux
 %bcond_with    cgmanager       # Enable cgmanager (BR: libcgmanager, libnih >= 1.0.2, libnih-dbus >= 1.0.0, dbus-1 >= 1.2.16)
 
-%define                subver  beta3
-%define                rel             0.1
 Summary:       Linux Containers userspace tools
 Summary(pl.UTF-8):     Narzędzia do kontenerów linuksowych (LXC)
 Name:          lxc
-Version:       1.0.0
-Release:       0.%{subver}.%{rel}
+Version:       1.0.5
+Release:       2
 License:       LGPL v2.1+
 Group:         Applications/System
-Source0:       https://github.com/lxc/lxc/archive/%{name}-%{version}.%{subver}.tar.gz
-# Source0-md5: b2ea21f87fa79e89990e41557d675d19
+Source0:       https://www.linuxcontainers.org/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: 9d9af9e9e69a831cd50b58d91c786013
 Source1:       %{name}-pld.in.sh
+Source2:       %{name}.init
 Patch1:                %{name}-pld.patch
-Patch4:                checkconfig-vserver-config.patch
-URL:           http://linuxcontainers.org/
+URL:           https://www.linuxcontainers.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: docbook-dtd30-sgml
@@ -34,14 +31,20 @@ BuildRequires:      gnutls-devel
 %{?with_apparmor:BuildRequires:        libapparmor-devel}
 BuildRequires: libcap-devel
 %{?with_seccomp:BuildRequires: libseccomp-devel}
+BuildRequires: libxslt-progs
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
 BuildRequires: pkgconfig
 %{?with_python:BuildRequires:  python3-devel >= 3.2}
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.612
 BuildRequires: sed >= 4.0
 Requires:      rc-scripts >= 0.4.6
 Requires:      which
+Suggests:      gnupg
+Suggests:      gnupg-plugin-keys_curl
+Suggests:      gnupg-plugin-keys_hkp
 Suggests:      net-tools
+Suggests:      python3-lxc
 Suggests:      rsync
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -106,10 +109,22 @@ Python (3.x) binding for LXC.
 %description -n python3-lxc -l pl.UTF-8
 Wiązanie Pythona (3.x) do LXC.
 
+%package -n bash-completion-%{name}
+Summary:       bash-completion for LXC
+Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla LXC
+Group:         Applications/Shells
+Requires:      %{name}
+Requires:      bash-completion
+
+%description -n bash-completion-%{name}
+bash-completion for LXC.
+
+%description -n bash-completion-%{name} -l pl.UTF-8
+bashowe uzupełnianie nazw dla LXC.
+
 %prep
-%setup -q -n %{name}-%{name}-%{version}%{?subver:.%{subver}}
+%setup -q
 %patch1 -p1
-%patch4 -p1
 
 cp -p %{SOURCE1} templates/lxc-pld.in
 
@@ -131,6 +146,7 @@ cp -p %{SOURCE1} templates/lxc-pld.in
        %{__enable_disable selinux} \
        --with-config-path=%{configpath} \
        --with-init-script=sysvinit,systemd \
+       --with-runtime-path=/var/run \
        --with-distro=pld
 
 %{__make}
@@ -138,7 +154,10 @@ cp -p %{SOURCE1} templates/lxc-pld.in
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{configpath},/var/{cache,log}/lxc}
+install -d $RPM_BUILD_ROOT{%{configpath},%{configpath}snap,/var/{cache,log}/lxc}  \
+        -d $RPM_BUILD_ROOT/etc/rc.d/init.d
+
+
 %{__make} install \
        SYSTEMD_UNIT_DIR=%{systemdunitdir} \
        pcdatadir=%{_pkgconfigdir} \
@@ -149,6 +168,14 @@ install -d $RPM_BUILD_ROOT{%{configpath},/var/{cache,log}/lxc}
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
 
+# apparmor profiles are not packaged, remove to avoid packagers confusion
+%{__rm} -r $RPM_BUILD_ROOT/etc/apparmor.d
+
+# yum plugin, no idea where to package this
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/lxc-patch.py
+
+install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc
+
 %if %{with python}
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
@@ -165,7 +192,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
+%doc AUTHORS CONTRIBUTING MAINTAINERS README  doc/FAQ.txt doc/examples/*.conf
 %attr(755,root,root) %{_bindir}/lxc-attach
 %attr(755,root,root) %{_bindir}/lxc-autostart
 %attr(755,root,root) %{_bindir}/lxc-cgroup
@@ -186,6 +213,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lxc-unshare
 %attr(755,root,root) %{_bindir}/lxc-usernsexec
 %attr(755,root,root) %{_bindir}/lxc-wait
+%attr(755,root,root) %{_sbindir}/init.lxc
 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.1
 %attr(754,root,root) /etc/rc.d/init.d/lxc
@@ -194,17 +222,19 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/rootfs
 %{_libdir}/%{name}/rootfs/README
 %attr(755,root,root) %{_libdir}/%{name}/lxc-devsetup
-%attr(755,root,root) %{_libdir}/%{name}/lxc-init
 %attr(755,root,root) %{_libdir}/%{name}/lxc-monitord
 %attr(755,root,root) %{_libdir}/%{name}/lxc-user-nic
+%attr(755,root,root) %{_libdir}/%{name}/lxc-autostart-helper
 %dir %{_sysconfdir}/lxc
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/lxc.functions
 %dir %{_datadir}/%{name}/config
 %{_datadir}/%{name}/config/centos.*.conf
+%{_datadir}/%{name}/config/common.seccomp
 %{_datadir}/%{name}/config/debian.*.conf
 %{_datadir}/%{name}/config/fedora.*.conf
+%{_datadir}/%{name}/config/gentoo.*.conf
 %{_datadir}/%{name}/config/oracle.*.conf
 %{_datadir}/%{name}/config/plamo.*.conf
 %{_datadir}/%{name}/config/ubuntu-cloud.*.conf
@@ -253,6 +283,7 @@ rm -rf $RPM_BUILD_ROOT
 %exclude %{_mandir}/ja/man1/lxc-start-ephemeral.1*
 %exclude %{_mandir}/ja/man1/lxc-top.1*
 
+
 %if %{without python}
 # legacy version
 %attr(755,root,root) %{_bindir}/lxc-ls
@@ -260,6 +291,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %dir %{configpath}
+%dir %{configpath}snap
 %dir %attr(750,root,root) /var/log/lxc
 %dir %attr(750,root,root) /var/cache/lxc
 
@@ -296,3 +328,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
 %lang(ja) %{_mandir}/ja/man1/lxc-start-ephemeral.1*
 %endif
+
+%files -n bash-completion-%{name}
+%defattr(644,root,root,755)
+/etc/bash_completion.d/lxc
This page took 0.046237 seconds and 4 git commands to generate.