]> git.pld-linux.org Git - packages/libx264.git/blobdiff - libx264.spec
Rebuild with gpac 0.5.0
[packages/libx264.git] / libx264.spec
index 63d86714b3e92dc3bad7562bab6859e34570a231..1ab79a4f11c4266a4ea845b6abdb88a0124cdc6c 100644 (file)
@@ -1,29 +1,38 @@
+#
+# Conditional build:
+%bcond_with    bootstrap       # no ffmpeg/gpac support in x264 utility
+#
+%define                snap    20120302
+%define                snaph   2245
+%define                rel     4
 Summary:       H264 encoder library
-Summary(pl):   Biblioteka koduj±ca H264
+Summary(pl.UTF-8):     Biblioteka kodująca H264
 Name:          libx264
-Version:       0.1.2
-%define        snap    20060430
-%define        snaph   2245
-Release:       1.%{snap}_%{snaph}.1
-License:       GPL v2
+Version:       0.1.3
+Release:       1.%{snap}_%{snaph}.%{rel}
+License:       GPL v2+
 Group:         Libraries
-# unofficial, debianized/libtoolized packaging:
-#Source0:      http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
-# but it's too old, so use snapshots...
+# still no releases, use snapshots
 Source0:       ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
-# Source0-md5: 667c760dda91e9a3f50186d4676b5d5a
-#Patch0:               %{name}-acam.patch
-Patch1:                %{name}-liblink.patch
-URL:           http://developers.videolan.org/x264.html
-BuildRequires: autoconf >= 2.53
-BuildRequires: automake
-BuildRequires: libtool
-%ifarch %{ix86}
-BuildRequires: nasm
+# Source0-md5: 0d8c9c3ab208a444de137e2983637f14
+Patch0:                %{name}-alpha.patch
+Patch1:                altivec-no-vand.patch
+Patch2:                %{name}-gpac.patch
+URL:           http://www.videolan.org/developers/x264.html
+BuildRequires: pkgconfig
+%ifarch %{ix86} %{x8664}
+BuildRequires: yasm >= 0.6.0
 %endif
-BuildRequires: sed >= 4.0
-%ifarch %{x8664}
-BuildRequires: yasm
+%if %{without bootstrap}
+# which version exactly???
+# for full x264 CLI utility functionality it wants:
+# libswscale >= 0.9.0 (in pkgconfig file)
+# libav{format,codec,util} from ffmpeg >= r21854
+BuildRequires: ffmpeg-devel >= 0.7.1
+BuildRequires: ffmpegsource-devel >= 2.16
+# gpac >= 2007-06-21
+BuildRequires: gpac-devel >= 0.4.5-2
+Requires:      gpac >= 0.4.5-2
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -33,40 +42,55 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 libx264 library for encoding H264 video format.
 
-%description -l pl
+%description -l pl.UTF-8
 Biblioteka libx264 do kodowania w formacie obrazu H264.
 
 %package devel
 Summary:       Header files for x264 library
-Summary(pl):   Pliki nag³ówkowe biblioteki x264
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki x264
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for x264 library.
 
-%description devel -l pl
-Pliki nag³ówkowe biblioteki x264.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki x264.
 
 %package static
 Summary:       Static x264 library
-Summary(pl):   Statyczna biblioteka x264
+Summary(pl.UTF-8):     Statyczna biblioteka x264
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static x264 library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka x264.
 
+%package -n x264
+Summary:       x264 CLI decoder
+Summary(pl.UTF-8):     Dekoder x264 działający z linii poleceń
+Group:         Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+
+%description -n x264
+x264 CLI decoder.
+
+%description -n x264 -l pl.UTF-8
+Dekoder x264 działający z linii poleceń.
+
 %prep
 %setup -q -n x264-snapshot-%{snap}-%{snaph}
-#%patch0 -p1
-%patch1 -p0
-sed -i 's:-O4::g' configure
+%patch0 -p1
+%if "%{pld_release}" == "ac"
+%patch1 -p1
+%endif
+%patch2 -p1
 
 %build
+CC="%{__cc}" \
 ./configure \
        --prefix=%{_prefix} \
        --exec-prefix=%{_prefix} \
@@ -74,7 +98,9 @@ sed -i 's:-O4::g' configure
        --includedir=%{_includedir} \
        --libdir=%{_libdir} \
        --extra-cflags="%{rpmcflags}" \
-       --enable-shared
+       --enable-pic \
+       --enable-shared \
+       --enable-static
 
 %{__make}
 
@@ -93,15 +119,19 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS
-%attr(755,root,root) %{_bindir}/x264
-%attr(755,root,root) %{_libdir}/libx264.so.*
+%attr(755,root,root) %{_libdir}/libx264.so.120
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libx264.so
 %{_includedir}/x264.h
+%{_includedir}/x264_config.h
 %{_pkgconfigdir}/x264.pc
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libx264.a
+
+%files -n x264
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/x264
This page took 0.0342 seconds and 4 git commands to generate.