]> git.pld-linux.org Git - packages/libx264.git/blobdiff - libx264.spec
Rebuild with gpac 0.5.0
[packages/libx264.git] / libx264.spec
index 5ad9589b012c94522998c284157b16bef1cf63e8..1ab79a4f11c4266a4ea845b6abdb88a0124cdc6c 100644 (file)
@@ -1,26 +1,39 @@
-%define                snap    20080816
+#
+# Conditional build:
+%bcond_with    bootstrap       # no ffmpeg/gpac support in x264 utility
+#
+%define                snap    20120302
 %define                snaph   2245
-%define                rel     3
+%define                rel     4
 Summary:       H264 encoder library
 Summary(pl.UTF-8):     Biblioteka kodująca H264
 Name:          libx264
-Version:       0.1.2
+Version:       0.1.3
 Release:       1.%{snap}_%{snaph}.%{rel}
 License:       GPL v2+
 Group:         Libraries
-# unofficial, debianized/libtoolized packaging:
-#Source0:      http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
-# but it's too old, so use snapshots...
+# still no releases, use snapshots
 Source0:       ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
-# Source0-md5: 0a188b8e13c62f6a97eba1c5d4ab3a3f
+# Source0-md5: 0d8c9c3ab208a444de137e2983637f14
 Patch0:                %{name}-alpha.patch
+Patch1:                altivec-no-vand.patch
+Patch2:                %{name}-gpac.patch
 URL:           http://www.videolan.org/developers/x264.html
-BuildRequires: gettext-devel
-BuildRequires: gtk+2-devel
 BuildRequires: pkgconfig
 %ifarch %{ix86} %{x8664}
 BuildRequires: yasm >= 0.6.0
 %endif
+%if %{without bootstrap}
+# which version exactly???
+# for full x264 CLI utility functionality it wants:
+# libswscale >= 0.9.0 (in pkgconfig file)
+# libav{format,codec,util} from ffmpeg >= r21854
+BuildRequires: ffmpeg-devel >= 0.7.1
+BuildRequires: ffmpegsource-devel >= 2.16
+# gpac >= 2007-06-21
+BuildRequires: gpac-devel >= 0.4.5-2
+Requires:      gpac >= 0.4.5-2
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # encoder/macroblock.c breaks strict-aliasing rules
@@ -56,60 +69,25 @@ Static x264 library.
 %description static -l pl.UTF-8
 Statyczna biblioteka x264.
 
-%package gtk
-Summary:       x264 GTK+ configuration interface library
-Summary(pl.UTF-8):     Biblioteka interfejsu konfiguracyjnego GTK+ dla x264
-Group:         X11/Libraries
+%package -n x264
+Summary:       x264 CLI decoder
+Summary(pl.UTF-8):     Dekoder x264 działający z linii poleceń
+Group:         Applications/Multimedia
 Requires:      %{name} = %{version}-%{release}
-Conflicts:     libx264-gui < 0.1.2-1.20080816_2245.2
-
-%description gtk
-x264 GTK+ configuration interface library.
-
-%description gtk -l pl.UTF-8
-Biblioteka interfejsu konfiguracyjnego GTK+ dla x264.
-
-%package gtk-devel
-Summary:       Header files for x264gtk library
-Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki x264gtk
-Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-Requires:      %{name}-gtk = %{version}-%{release}
-
-%description gtk-devel
-Header files for x264gtk library.
-
-%description gtk-devel -l pl.UTF-8
-Pliki nagłówkowe biblioteki x264gtk.
-
-%package gtk-static
-Summary:       Static x264gtk library
-Summary(pl.UTF-8):     Statyczna biblioteka x264gtk
-Group:         X11/Development/Libraries
-Requires:      %{name}-gtk-devel = %{version}-%{release}
-
-%description gtk-static
-Static x264gtk library.
-
-%description gtk-static -l pl.UTF-8
-Statyczna biblioteka x264gtk.
-
-%package gui
-Summary:       Encoding GUI for x264
-Summary(pl.UTF-8):     Graficzny interfejs użytkownika do kodera x264
-Group:         X11/Applications/Multimedia
-Requires:      %{name}-gtk = %{version}-%{release}
 
-%description gui
-Encoding GUI for x264.
+%description -n x264
+x264 CLI decoder.
 
-%description gui -l pl.UTF-8
-Graficzny interfejs użytkownika do kodera x264.
+%description -n x264 -l pl.UTF-8
+Dekoder x264 działający z linii poleceń.
 
 %prep
 %setup -q -n x264-snapshot-%{snap}-%{snaph}
 %patch0 -p1
-sed -i 's:-O4::g' configure
+%if "%{pld_release}" == "ac"
+%patch1 -p1
+%endif
+%patch2 -p1
 
 %build
 CC="%{__cc}" \
@@ -120,9 +98,9 @@ CC="%{__cc}" \
        --includedir=%{_includedir} \
        --libdir=%{_libdir} \
        --extra-cflags="%{rpmcflags}" \
-       --enable-gtk \
        --enable-pic \
-       --enable-shared
+       --enable-shared \
+       --enable-static
 
 %{__make}
 
@@ -132,8 +110,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%find_lang x264_gtk
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -143,34 +119,19 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS
-%attr(755,root,root) %{_bindir}/x264
-%attr(755,root,root) %{_libdir}/libx264.so.60
+%attr(755,root,root) %{_libdir}/libx264.so.120
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libx264.so
 %{_includedir}/x264.h
+%{_includedir}/x264_config.h
 %{_pkgconfigdir}/x264.pc
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libx264.a
 
-%files gtk -f x264_gtk.lang
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libx264gtk.so.60
-%{_datadir}/x264
-
-%files gtk-devel
+%files -n x264
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libx264gtk.so
-%{_includedir}/x264_gtk*.h
-%{_pkgconfigdir}/x264gtk.pc
-
-%files gtk-static
-%defattr(644,root,root,755)
-%{_libdir}/libx264gtk.a
-
-%files gui
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/x264_gtk_encode
+%attr(755,root,root) %{_bindir}/x264
This page took 0.070739 seconds and 4 git commands to generate.