]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- rel 3; x86_64 asm optimized now; nicer way of linking shared lib; export only requi...
[packages/libvpx.git] / libvpx.spec
index fa34dc4a5f5c6572ff7fc971c8df82f08559cec3..c9e70e51e514868b47c5fb98aedf1ab7acfc3913 100644 (file)
@@ -2,24 +2,22 @@
 # Conditional build:
 %bcond_without asm
 
-%ifarch %{x8664}
-# buggy, non PIC asm code
-%undefine with_asm
-%endif
-
 Summary:       VP8, a high-quality video codec
 Name:          libvpx
 Version:       0.9.0
-Release:       2
+Release:       3
 License:       BSD
 Group:         Libraries
 Source0:       http://webm.googlecode.com/files/%{name}-%{version}.tar.bz2
 # Source0-md5: 9eb8e818d2f3263623c258fe66924082
+Source1:       %{name}.ver
 Patch0:                %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
 URL:           http://www.webmproject.org/
+BuildRequires: /usr/bin/php
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: doxygen
+BuildRequires: php-pcre
 %{?with_asm:BuildRequires:     yasm}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -74,13 +72,15 @@ sed -i "s|STRIP=.*|STRIP=|g" {libs,examples,docs}-*.mk
 %{__make} verbose=true target=libs \
        CC="%{__cc}"
 
-%{__cc} %{rpmldflags} -fPIC -o libvpx.so.0.0.0 -shared -Wl,-soname,libvpx.so.0 vpx_codec/src/*.o vpx_mem/*.o \
-       vpx_scale/generic/*.o vp8/common/*.o vp8/common/generic/*.o vp8/*.o vp8/encoder/*.o \
-       vp8/encoder/generic/*.o vp8/decoder/*.o vp8/decoder/generic/*.o vpx_config.c.o \
-%if %{with asm}
-       vp8/common/x*/*.o vp8/encoder/x*/*.o vp8/decoder/x*/*.o vpx_ports/*.o \
-%endif
-       -lm -lpthread
+mkdir tmp
+cd tmp
+ar x ../libvpx_g.a
+cd ..
+%{__cc} %{rpmldflags} -fPIC -shared \
+       -Wl,--no-undefined -Wl,-soname,libvpx.so.0 -Wl,--version-script,%{SOURCE1} -Wl,-z,noexecstack \
+       -o libvpx.so.0.0.0 tmp/*.o \
+       -pthread -lm
+rm -rf tmp
 
 # Temporarily dance the static libs out of the way
 mv libvpx.a libNOTvpx.a
This page took 0.097126 seconds and 4 git commands to generate.