]> git.pld-linux.org Git - packages/libvpx.git/blobdiff - libvpx.spec
- fixed build
[packages/libvpx.git] / libvpx.spec
index 63a274b1ae86c441cc34ea3db58681cc3b28748d..b1ddb49959e85ea39460411b61f9725f7c7b913a 100644 (file)
@@ -4,7 +4,6 @@
 %bcond_without doc     # don't build doc
 %bcond_with    tests   # build tests (not useful, creates libgtest.a)
 %bcond_without ssse3   # use SSSE3 instructions (Intel since Core2, Via Nano)
-%bcond_without vp9_encoder     # vp9 encoder
 
 %ifnarch %{ix86} %{x8664}
 %undefine      with_asm
 %undefine      with_ssse3
 %endif
 
-# old gcc gets stuck on ac
-%ifarch sparc
-%undefine      with_vp9_encoder
-%endif
-
 Summary:       VP8, a high-quality video codec
 Summary(pl.UTF-8):     VP8 - kodek obrazu wysokiej jakoĊ›ci
 Name:          libvpx
-Version:       1.3.0
-Release:       2
+Version:       1.4.0
+Release:       0.1
 License:       BSD
 Group:         Libraries
-#Source0Download: http://code.google.com/p/webm/downloads/list
-#Source0:      https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
-# source, but regenerated on each fetch
+# Source in git web, but regenerated on each fetch, so use gentoo tarball instead
 #Source0:      https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
+Source0:       http://distfiles.gentoo.org/distfiles/%{name}-%{version}.tar.bz2
+# Source0-md5: 63b1d7f59636a42eeeee9225cc14e7de
 URL:           http://www.webmproject.org/
 BuildRequires: doxygen
 %{?with_tests:BuildRequires:   libstdc++-devel}
@@ -92,13 +84,14 @@ Static libvpx library.
 Statyczna biblioteka libvpx.
 
 %prep
-#%setup -q -n %{name}-v%{version}
-%setup -qc
+%setup -q
 
 %build
 install -d obj
 cd obj
 # not autoconf configure
+CC="%{__cc}" \
+CXX="%{__cxx}" \
 CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
 ../configure \
 %if %{with asm}
@@ -112,19 +105,15 @@ CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
        --%{!?with_doc:dis}%{?with_doc:en}able-docs \
        --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
        --enable-vp8 \
-       %{!?with_vp9_encoder:--disable-vp9-encoder} \
+       --enable-vp8 \
        --enable-postproc \
        --enable-runtime-cpu-detect
 
 %{__make} verbose=true target=libs \
        HAVE_GNU_STRIP=no \
-       CC="%{__cc}" \
-       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags}"
 
 %{__make} verbose=true target=examples \
-       CC="%{__cc}" \
-       LD="%{__cc}" \
        LDFLAGS="%{rpmldflags} -L."
 
 %if %{with doc}
@@ -139,7 +128,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
        LIBSUBDIR=%{_lib} \
        DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.2.0
 
 # adjust prefix and libdir
 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
@@ -153,12 +142,10 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGELOG LICENSE PATENTS README
-%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
-%{?with_vp9_encoder:%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder}
 %attr(755,root,root) %{_bindir}/vpxdec
 %attr(755,root,root) %{_bindir}/vpxenc
 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
+%attr(755,root,root) %ghost %{_libdir}/libvpx.so.2
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.372539 seconds and 4 git commands to generate.