]> git.pld-linux.org Git - packages/libuv.git/blobdiff - libuv.spec
up to 1.41.0
[packages/libuv.git] / libuv.spec
index fc01e534746607f5e481a64fc1a175c2e0e6aa0c..6f3cb706df180262387b169aa54f31bff113596e 100644 (file)
@@ -1,36 +1,60 @@
 #
 # Conditional build:
+%bcond_without static_libs     # static library
 %bcond_with    tests           # build with tests (require network access)
 
-Summary:       Platform layer for node.js
+Summary:       Multi-platform support library with a focus on asynchronous I/O
+Summary(pl.UTF-8):     Wieloplatformowa biblioteka wspierająca skupiająca się na asynchronicznym we/wy
 Name:          libuv
-Version:       1.0.2
+Version:       1.41.0
 Release:       1
 # the licensing breakdown is described in detail in the LICENSE file
 License:       MIT and BSD and ISC
-Group:         Development/Tools
-Source0:       http://dist.libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz
-# Source0-md5: 3507961d2f06f1e35906a83ffe7f9f4c
+Group:         Libraries
+Source0:       https://dist.libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz
+# Source0-md5: d990b0770dd2b15f7a8399580d55d32c
 URL:           http://libuv.org/
+BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1:1.12
-BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:2
 BuildRequires: pkgconfig
-BuildRequires: python-gyp
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-libuv is a new platform layer for Node. Its purpose is to abstract
-IOCP on Windows and libev on Unix systems. We intend to eventually
-contain all platform differences in this library.
+libuv is a multi-platform support library with a focus on asynchronous
+I/O. It was primarily developed for use by Node.js, but it's also used
+by Luvit, Julia, pyuv and others.
+
+%description -l pl.UTF-8
+libuv to wieloplatformowa biblioteka wspierająca, skupiająca się na
+asynchronicznych operacjach wejścia-wyjścia. Była rozwijana głównie z
+myślą o wykorzystaniu w Node.js, ale obecnie jest używana także przez
+projekty takie jak Luvit, Julia, pyuv i inne.
 
 %package devel
-Summary:       Development libraries for libuv
-Group:         Development/Tools
+Summary:       Header files for libuv library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libuv
+Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Development libraries for libuv.
 
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki libuv.
+
+%package static
+Summary:       Static libuv library
+Summary(pl.UTF-8):     Statyczna biblioteka libuv
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static libuv library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka libuv.
+
 %prep
 %setup -q -n %{name}-v%{version}
 
@@ -43,8 +67,9 @@ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" > m4/libuv-extra-aut
 %{__autoconf}
 %{__automake}
 %configure \
+       ac_cv_lib_nsl_gethostbyname=no \
        --disable-silent-rules \
-       --disable-static
+       %{!?with_static_libs:--disable-static}
 %{__make}
 
 %if %{with tests}
@@ -68,17 +93,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS LICENSE
+%doc AUTHORS ChangeLog LICENSE README.md
 %attr(755,root,root) %{_libdir}/libuv.so.*.*.*
-%ghost %{_libdir}/libuv.so.1
+%attr(755,root,root) %ghost %{_libdir}/libuv.so.1
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/libuv.so
-%{_pkgconfigdir}/libuv.pc
+%attr(755,root,root) %{_libdir}/libuv.so
 %{_includedir}/uv.h
-%{_includedir}/uv-errno.h
-%{_includedir}/uv-linux.h
-%{_includedir}/uv-threadpool.h
-%{_includedir}/uv-unix.h
-%{_includedir}/uv-version.h
+%{_includedir}/uv
+%{_pkgconfigdir}/libuv.pc
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libuv.a
+%endif
This page took 0.111272 seconds and 4 git commands to generate.