]> git.pld-linux.org Git - packages/libraw.git/blobdiff - libraw.spec
- up to 0.21.2
[packages/libraw.git] / libraw.spec
index 34b6f2c8978eb8eda03a714c53488bb78619aa89..f3877dabd6a8e1082ebee74aff97182c173c17c8 100644 (file)
@@ -1,42 +1,32 @@
 #
 # Conditional build:
-%bcond_without gomp    # OpenMP support
-%bcond_without gpl2    # GPL v2+ demosaic pack
-%bcond_without gpl3    # GPL v3+ demosaic pack
+%bcond_without openmp  # OpenMP support
+%bcond_without zlib    # ZLIB for deflated DNG format support
 #
-%if %{without gpl2}
-%undefine      gpl3
-%endif
 Summary:       LibRaw - a library for reading RAW files
 Summary(pl.UTF-8):     LibRaw - biblioteka do odczytu plików RAW
 Name:          libraw
-Version:       0.14.7
-Release:       2
-%if %{with gpl3}
-License:       GPL v3+
-%else
-%if %{with gpl2}
-License:       GPL v2+
-%else
-License:       LGPL v2.1 or CDDL v1.0 or LibRaw Software License
-%endif
-%endif
+Version:       0.21.2
+Release:       1
+License:       LGPL v2.1 or CDDL v1.0
 Group:         Libraries
 #Source0Download: http://www.libraw.org/download#stable
-Source0:       http://www.libraw.org/data/LibRaw-%{version}.tar.gz
-# Source0-md5: 8b622d82c927d8975c22ee4316584ebd
-Source1:       http://www.libraw.org/data/LibRaw-demosaic-pack-GPL2-%{version}.tar.gz
-# Source1-md5: a45c73d6bf9b4c112d5df9818e0a33f9
-Source2:       http://www.libraw.org/data/LibRaw-demosaic-pack-GPL3-%{version}.tar.gz
-# Source2-md5: 5fc14ee1fd66562cff3ee6895ca541a9
-URL:           http://www.libraw.org/
-%{?with_gomp:BuildRequires:    gcc >= 6:4.2}
+Source0:       https://www.libraw.org/data/LibRaw-%{version}.tar.gz
+# Source0-md5: 0533724bad17c0fde22e642e4594e45d
+Patch0:                int64.patch
+URL:           https://www.libraw.org/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
+%{?with_openmp:BuildRequires:  gcc >= 6:4.2}
 BuildRequires: jasper-devel
-BuildRequires: lcms2-devel
-%{?with_gomp:BuildRequires:    libgomp-devel}
-BuildRequires: libjpeg-devel
+BuildRequires: lcms2-devel >= 2
+%{?with_openmp:BuildRequires:  libgomp-devel}
+BuildRequires: libjpeg-devel >= 8
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: pkgconfig
+# zlib with pkgconfig support
+%{?with_zlib:BuildRequires:    zlib-devel >= 1.2.3.3}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -72,10 +62,11 @@ Summary(pl.UTF-8):  Pliki nagłówkowe biblioteki LibRaw
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      jasper-devel
-Requires:      lcms2-devel
-%{?with_gomp:Requires: libgomp-devel}
-Requires:      libjpeg-devel
+Requires:      lcms2-devel >= 2
+%{?with_openmp:Requires: libgomp-devel}
+Requires:      libjpeg-devel >= 8
 Requires:      libstdc++-devel
+%{?with_zlib:Requires: zlib-devel >= 1.2.3.3}
 
 %description devel
 Header files for LibRaw.
@@ -96,25 +87,19 @@ Static LibRaw library.
 Statyczna biblioteka LibRaw.
 
 %prep
-%setup -q -n LibRaw-%{version} %{?with_gpl2:-a1} %{?with_gpl3:-a2}
-
-%if %{with gpl2}
-for f in LibRaw-demosaic-pack-GPL2-%{version}/{COPYRIGHT,Changelog,README} ; do
-       cp -p $f $(basename $f).demosaic-pack-GPL2
-done
-%endif
-%if %{with gpl3}
-for f in LibRaw-demosaic-pack-GPL3-%{version}/{COPYRIGHT,Changelog,README} ; do
-       cp -p $f $(basename $f).demosaic-pack-GPL3
-done
-%endif
+%setup -q -n LibRaw-%{version}
+%patch0 -p1
 
 %build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
 %configure \
-       %{!?with_gomp:--disable-openmp}
+       %{!?with_openmp:--disable-openmp} \
+       %{?with_zlib:--enable-zlib}
 
-%{__make} \
-       %{?with_gomp:lib_libraw_la_LIBADD=-lgomp lib_libraw_r_la_LIBADD=-lgomp}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -122,6 +107,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libraw*.la
+
 # packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 
@@ -133,12 +121,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT Changelog.txt LICENSE.LibRaw.pdf README README.demosaic-packs %{?with_gpl2:*.demosaic-pack-GPL2} %{?with_gpl3:*.demosaic-pack-GPL3}
-%lang(ru) %doc Changelog.rus README.demosaic-packs.rus
-%ghost %attr(755,root,root) %{_libdir}/libraw.so.5
-%attr(755,root,root) %{_libdir}/libraw.so.5.*
-%ghost %attr(755,root,root) %{_libdir}/libraw_r.so.5
-%attr(755,root,root) %{_libdir}/libraw_r.so.5.*
+%doc COPYRIGHT Changelog.txt README.md LICENSE.CDDL LICENSE.LGPL
+%attr(755,root,root) %{_libdir}/libraw.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libraw.so.23
+%attr(755,root,root) %{_libdir}/libraw_r.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libraw_r.so.23
 
 %files samples
 %defattr(644,root,root,755)
@@ -150,17 +137,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/multirender_test
 %attr(755,root,root) %{_bindir}/postprocessing_benchmark
 %attr(755,root,root) %{_bindir}/raw-identify
+%attr(755,root,root) %{_bindir}/rawtextdump
 %attr(755,root,root) %{_bindir}/simple_dcraw
 %attr(755,root,root) %{_bindir}/unprocessed_raw
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/{index.html,*-eng.html}
-%lang(ru) %doc doc/*-rus.html
+%doc doc/*.html
 %attr(755,root,root) %{_libdir}/libraw.so
 %attr(755,root,root) %{_libdir}/libraw_r.so
-%{_libdir}/libraw.la
-%{_libdir}/libraw_r.la
 %{_includedir}/libraw
 %{_pkgconfigdir}/libraw.pc
 %{_pkgconfigdir}/libraw_r.pc
This page took 0.037783 seconds and 4 git commands to generate.