]> git.pld-linux.org Git - packages/libprelude.git/blobdiff - libprelude.spec
- removed patching of autogenerated file
[packages/libprelude.git] / libprelude.spec
index eed2de28d20605cc63dca31650ae20ca459e80db..1331e2212bbeea903a86b676235f48ab97f6f915 100644 (file)
@@ -10,7 +10,7 @@ Summary:      The Prelude library
 Summary(pl.UTF-8):     Biblioteka Prelude
 Name:          libprelude
 Version:       1.0.1
-Release:       1
+Release:       6
 License:       GPL v2 or commercial
 Group:         Libraries
 # https://www.prelude-ids.org/projects/prelude/files
@@ -229,6 +229,10 @@ PreludeEasy - dowiązania języka Ruby do libprelude.
 %{__rm} bindings/ruby/PreludeEasy.cxx
 %patch1 -p1
 %endif
+%if %{with perl}
+# regenerate with fresh swig for perl 5.20
+%{__rm} bindings/low-level/perl/Prelude.c
+%endif
 
 %patch2 -p1
 %patch3 -p1
@@ -243,6 +247,7 @@ sed -i -e 's/lua >= 5.1/lua51 >= 5.1/' configure.in
 %{__autoheader}
 %{__automake}
 %configure \
+       am_cv_ruby_rbexecdir=%{ruby_vendorarchdir} \
        --enable-gtk-doc \
        --enable-static \
        --with%{!?with_lua:out}-lua \
@@ -253,12 +258,21 @@ sed -i -e 's/lua >= 5.1/lua51 >= 5.1/' configure.in
 
 %{__make}
 
+cd bindings/perl
+%{__make} clean
+%{__perl} Makefile.PL \
+        INSTALLDIRS=vendor \
+%{__make}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__make} -C bindings/perl install \
+       DESTDIR=$RPM_BUILD_ROOT
+
 %if %{with lua}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/PreludeEasy.{la,a}
 %endif
@@ -268,7 +282,7 @@ rm -rf $RPM_BUILD_ROOT
 %py_postclean
 %endif
 %if %{with ruby}
-%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/PreludeEasy.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/PreludeEasy.{la,a}
 %endif
 
 %clean
@@ -341,14 +355,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{perl_vendorarch}/Prelude.pm
 %dir %{perl_vendorarch}/auto/Prelude
-%{perl_vendorarch}/auto/Prelude/Prelude.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/Prelude.so
 
 %files -n perl-PreludeEasy
 %defattr(644,root,root,755)
 %{perl_vendorarch}/PreludeEasy.pm
 %dir %{perl_vendorarch}/auto/PreludeEasy
-%{perl_vendorarch}/auto/PreludeEasy/PreludeEasy.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/PreludeEasy/PreludeEasy.so
 %endif
 
@@ -369,5 +381,5 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ruby}
 %files -n ruby-prelude
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_sitearchdir}/PreludeEasy.so
+%attr(755,root,root) %{ruby_vendorarchdir}/PreludeEasy.so
 %endif
This page took 0.066615 seconds and 4 git commands to generate.