]> git.pld-linux.org Git - packages/libcroco.git/blobdiff - libcroco.spec
- updated to 0.6.13
[packages/libcroco.git] / libcroco.spec
index 10e8828e6838abc54e10bf895705aab68c959b16..e5db6034963000f34f1f58e6d90bdf620edddd60 100644 (file)
@@ -1,60 +1,67 @@
+#
+# Conditional build:
+%bcond_without static_libs     # don't build static library
+
+%define                mver    0.6
 Summary:       A CSS2 parsing library
-Summary(pl):   Biblioteka analizuj±ca CSS2
+Summary(pl.UTF-8):     Biblioteka analizująca CSS2
 Name:          libcroco
-Version:       0.5.0
+Version:       0.6.13
 Release:       1
-License:       LGPL
+License:       LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/gnome/sources/libcroco/0.5/%{name}-%{version}.tar.bz2
-# Source0-md5: 2b152b07e87d448f6678ccb066afdc58
-Patch0:                %{name}-link.patch
-BuildRequires: autoconf >= 2.5
-BuildRequires: automake
-BuildRequires: glib2-devel >= 2.0
-BuildRequires: libtool
-BuildRequires: libxml2-devel >= 2.4.23
-BuildRequires: pkgconfig >= 0.8
-Requires:      glib2 >= 2.0
-Requires:      libxml2 >= 2.4.23
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/libcroco/0.6/%{name}-%{version}.tar.xz
+# Source0-md5: c80c5a8385011a0260dce6bd0da93dce
+BuildRequires: autoconf >= 2.64
+BuildRequires: automake >= 1:1.13
+BuildRequires: glib2-devel >= 1:2.12.0
+BuildRequires: gtk-doc >= 1.0
+BuildRequires: gtk-doc-automake >= 1.0
+BuildRequires: libtool >= 2:2.0
+BuildRequires: libxml2-devel >= 1:2.6.26
+BuildRequires: pkgconfig >= 1:0.8
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+Requires:      glib2 >= 1:2.12.0
+Requires:      libxml2 >= 1:2.6.26
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 CSS2 parsing and manipulation library for GNOME.
 
-%description -l pl
-Biblioteka analizuj±ca i obrabiaj±ca CSS2 dla GNOME.
+%description -l pl.UTF-8
+Biblioteka analizująca i obrabiająca CSS2 dla GNOME.
 
 %package devel
 Summary:       Header files for developing with libcroco
-Summary(pl):   Pliki nag³ówkowe do tworzenia programów u¿ywaj±cych libcroco
+Summary(pl.UTF-8):     Pliki nagłówkowe do tworzenia programów używających libcroco
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      glib2-devel >= 2.0
-Requires:      libxml2-devel >= 2.4.23
+Requires:      glib2-devel >= 1:2.12.0
+Requires:      libxml2-devel >= 1:2.6.26
 
 %description devel
-This package provides the necessary header files files to allow you
-to develop with libcroco.
+This package provides the necessary header files files to allow you to
+develop with libcroco.
 
-%description devel -l pl
-Ten pakiet dostarcza pliki nag³ówkowe potrzebne do tworzenia
-oprogramowania korzystaj±cego z libcroco.
+%description devel -l pl.UTF-8
+Ten pakiet dostarcza pliki nagłówkowe potrzebne do tworzenia
+oprogramowania korzystającego z libcroco.
 
 %package static
 Summary:       Static version of libcroco library
-Summary(pl):   Statyczna wersja biblioteki libcroco
+Summary(pl.UTF-8):     Statyczna wersja biblioteki libcroco
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of libcroco library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna wersja biblioteki libcroco.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -62,19 +69,23 @@ Statyczna wersja biblioteki libcroco.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
-
+%configure \
+       --disable-silent-rules \
+       %{!?with_static_libs:--disable-static} \
+       --with-html-dir=%{_gtkdocdir}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install docs/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcroco*.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -84,21 +95,22 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TODO
-%attr(755,root,root) %{_bindir}/csslint
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
-%{_mandir}/man1/csslint.1*
+%attr(755,root,root) %{_bindir}/csslint-%{mver}
+%attr(755,root,root) %{_libdir}/libcroco-%{mver}.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcroco-%{mver}.so.3
 
 %files devel
 %defattr(644,root,root,755)
 %doc docs/usage.txt
-%attr(755,root,root) %{_bindir}/croco-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/libcroco
-%{_pkgconfigdir}/libcroco.pc
-%{_mandir}/man1/croco-config.1*
+%attr(755,root,root) %{_bindir}/croco-%{mver}-config
+%attr(755,root,root) %{_libdir}/libcroco-%{mver}.so
+%{_includedir}/libcroco-%{mver}
+%{_pkgconfigdir}/libcroco-%{mver}.pc
 %{_examplesdir}/%{name}-%{version}
+%{_gtkdocdir}/libcroco
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcroco-%{mver}.a
+%endif
This page took 0.059813 seconds and 4 git commands to generate.