]> git.pld-linux.org Git - packages/lapack.git/blobdiff - lapack.spec
- strict internal deps, dropped libtool < 1.5 support
[packages/lapack.git] / lapack.spec
index 10bffe743fadd053ad7d9ac57581acbfdde9d460..7ec7f73e5ee3a2d4ff23d0a2d0a1d29b234f9147 100644 (file)
@@ -2,21 +2,22 @@ Summary:      The LAPACK libraries for numerical linear algebra
 Summary(pl):   Biblioteki numeryczne LAPACK do algebry liniowej
 Name:          lapack
 Version:       3.0
-Release:       13
-License:       Freely distributable
+Release:       18
+License:       freely distributable
 Group:         Development/Libraries
 Source0:       http://www.netlib.org/lapack/%{name}.tgz
+# Source0-md5: a24f59304f87b78cdc7da2ae59c98664
 Source1:       http://www.netlib.org/lapack/manpages.tgz
+# Source1-md5: 50efab6cd73a9429584f7f1537f1727f
 Patch0:                %{name}-automake_support.patch
 Patch1:                %{name}-20010525.patch
 URL:           http://www.netlib.org/lapack/
 BuildRequires: gcc-g77
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: libtool
-BuildRequires: ed
+BuildRequires: libtool >= 2:1.5
+Requires:      blas = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-Requires:      blas
 
 %description
 LAPACK (Linear Algebra PACKage) is a standard library for numerical
@@ -47,7 +48,8 @@ napisany w Fortranie 77.
 Summary:       LAPACK header files
 Summary(pl):   Pliki nag³ówkowe LAPACK
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      blas-devel = %{version}-%{release}
 Obsoletes:     lapack-man
 
 %description devel
@@ -60,7 +62,7 @@ Pliki nag
 Summary:       Static LAPACK libraries
 Summary(pl):   Biblioteki statyczne LAPACK
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static LAPACK libraries.
@@ -80,17 +82,24 @@ numerical algebra. BLAS provides a number of basic algorithms for
 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
 77.
 
+Warning: this is a reference implementation from Netlib. If possible,
+use version optimized for your architecture instead.
+
 %description -n blas -l pl
 BLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
 w Fortranie 77.
 
+Ostrze¿enie: to jest implementacja przyk³adowa z repozytorium Netlib.
+Je¿eli to mo¿liwe, nale¿y u¿ywaæ zamiast niej wersji zoptymalizowanej
+pod dan± architekturê.
+
 %package -n blas-devel
 Summary:       BLAS header files
 Summary(pl):   Pliki nag³ówkowe BLAS
 Group:         Development/Libraries
-Requires:      blas = %{version}
+Requires:      blas = %{version}-%{release}
 Obsoletes:     blas-man
 
 %description -n blas-devel
@@ -103,7 +112,7 @@ Pliki nag
 Summary:       Static BLAS libraries
 Summary(pl):   Biblioteki statyczne BLAS
 Group:         Development/Libraries
-Requires:      blas-devel = %{version}
+Requires:      blas-devel = %{version}-%{release}
 
 %description -n blas-static
 Static BLAS libraries.
@@ -117,32 +126,26 @@ Biblioteki statyczne BLAS.
 %patch1 -p1
 # directory INSTALL conflicts with file INSTALL needed by automake
 mv -f INSTALL install
->INSTALL
->AUTHORS
->ChangeLog
->NEWS
->COPYING
-#>config.h.in
 
 %build
-rm -f ltmain.sh
-libtoolize --copy --force
-aclocal
-autoheader
-automake --add-missing
-autoconf
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
+%{__automake}
 %configure
-%{__make}
+
+%{__make} \
+       LTTAG="--tag=F77"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-#workaround libtool
-ed SRC/liblapack.la <<EOF
-s/relink_command=.*/relink_command=''/
-w
-q
-EOF
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# present both in blas and lapack
+rm -f man/manl/{lsame,xerbla}.l
 
 install -d $RPM_BUILD_ROOT%{_mandir}/man3
 for d in man/manl/*.l blas/man/manl/*.l ; do
@@ -154,25 +157,24 @@ find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/
 echo "%defattr(644, root, root, 755)" > mans.list
 find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
 
-gzip -9nf README
-
 %clean
 rm -fr $RPM_BUILD_ROOT
 
-%post           -p /sbin/ldconfig
-%postun         -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %post   -n blas -p /sbin/ldconfig
 %postun -n blas -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc README*
+%doc README
 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
 
 %files devel -f mans.list
 %defattr(644,root,root,755)
-%{_libdir}/liblapack.so
+%attr(755,root,root) %{_libdir}/liblapack.so
+%{_libdir}/liblapack.la
 
 %files static
 %defattr(644,root,root,755)
@@ -184,7 +186,8 @@ rm -fr $RPM_BUILD_ROOT
 
 %files -n blas-devel -f blasmans.list
 %defattr(644,root,root,755)
-%{_libdir}/libblas.so
+%attr(755,root,root) %{_libdir}/libblas.so
+%{_libdir}/libblas.la
 
 %files -n blas-static
 %defattr(644,root,root,755)
This page took 0.099598 seconds and 4 git commands to generate.