]> git.pld-linux.org Git - packages/ktorrent.git/blobdiff - ktorrent.spec
- up to 4.3.1. KIO magnet dropped upstream.
[packages/ktorrent.git] / ktorrent.spec
index 2d0c6b97e6ebdd1ef70637d98866b74711892db2..cf05c19363049bb1faaa29acc146915b1bf14af4 100644 (file)
@@ -1,34 +1,39 @@
 #
-%define         qtver   4.5.3
+%define         qtver   4.6.3
+%define                kdever  4.5.0
 
 Summary:       Native KDE BitTorrent client
 Summary(de.UTF-8):     Ein nativer KDE BitTorrent Klient
 Summary(pl.UTF-8):     Natywny klient BitTorrenta dla KDE
 Name:          ktorrent
-Version:       3.3.1
+Version:       4.3.1
 Release:       1
 License:       GPL
 Group:         Applications/Networking
 Source0:       http://ktorrent.org/downloads/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 6a76e0b3a7ed14966c8096f63fde6e29
+# Source0-md5: 696852076315d3aa8ccc8745482872dd
+# Patch0:              plasma_applet_remove_taskmanager.diff
+Patch0:                Fix-compilation-of-ipblocklisttest-target.patch
 URL:           http://ktorrent.org/
 BuildRequires: Qt3Support-devel >= %{qtver}
 BuildRequires: QtCore-devel >= %{qtver}
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtScript-devel >= %{qtver}
 BuildRequires: QtSvg-devel >= %{qtver}
-BuildRequires: automoc4
+BuildRequires: automoc4 >= 0.9.88
 BuildRequires: boost-devel
-BuildRequires: cmake
-BuildRequires: gettext-devel
+BuildRequires: cmake >= 2.8.0
+BuildRequires: gettext-tools
 BuildRequires: gmp-devel
-BuildRequires: kde4-kdebase-workspace-devel
-BuildRequires: kde4-kdelibs-devel
-BuildRequires: kde4-kdepimlibs-devel
+BuildRequires: kde4-kdebase-workspace-devel >= %{kdever}
+BuildRequires: kde4-kdelibs-devel >= %{kdever}
+BuildRequires: kde4-kdepimlibs-devel >= %{kdever}
+BuildRequires: libktorrent-devel >= 1.3
 BuildRequires: qca-devel >= 2.0.0
-BuildRequires: qt4-build
+BuildRequires: qt4-build >= %{qtver}
+BuildRequires: qt4-qmake >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.129
-BuildRequires: strigi-devel >= 0.5.5
+BuildRequires: strigi-devel >= 0.7.2
 BuildRequires: taglib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -65,27 +70,20 @@ Główne cechy to:
   nawet dodać własną
 - trackery UDP
 
-%package devel
-Summary:       Header files for ktorrent
-Summary(pl.UTF-8):     Pliki nagłówkowe ktorrent
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description devel
-Header files for ktorrent.
-
-%description devel -l pl.UTF-8
-Pliki nagłówkowe ktorrent.
-
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 install -d build
 cd build
-%cmake \
+%cmake .. \
+       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       ../
+%if "%{_lib}" == "lib64"
+       -DLIB_SUFFIX=64
+%endif
+
 %{__make}
 
 %install
@@ -93,6 +91,15 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# remove lib symlinks - devel subpackage is not needed anyway
+rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
+
+# remove unsupported langs
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ar
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/eu
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/se
+
 %find_lang %{name} --with-kde
 
 %clean
@@ -104,6 +111,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ktorrent
+%attr(755,root,root) %{_bindir}/ktmagnetdownloader
 %attr(755,root,root) %{_bindir}/ktupnptest
 %attr(755,root,root) %{_libdir}/kde4/ktbwschedulerplugin.so
 %attr(755,root,root) %{_libdir}/kde4/ktinfowidgetplugin.so
@@ -114,6 +122,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/ktstatsplugin.so
 %attr(755,root,root) %{_libdir}/kde4/ktupnpplugin.so
 %attr(755,root,root) %{_libdir}/kde4/ktwebinterfaceplugin.so
+%attr(755,root,root) %{_libdir}/kde4/ktmagnetgeneratorplugin.so
 %attr(755,root,root) %{_libdir}/kde4/ktmediaplayerplugin.so
 %attr(755,root,root) %{_libdir}/kde4/ktzeroconfplugin.so
 %attr(755,root,root) %{_libdir}/kde4/ktdownloadorderplugin.so
@@ -122,12 +131,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/ktsyndicationplugin.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_ktorrent.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_ktorrent.so
-%attr(755,root,root) %ghost %{_libdir}/libbtcore.so.??
-%attr(755,root,root) %{_libdir}/libbtcore.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libktcore.so.??
 %attr(755,root,root) %{_libdir}/libktcore.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libktupnp.so.?
-%attr(755,root,root) %{_libdir}/libktupnp.so.*.*.*
 %{_desktopdir}/kde4/ktorrent.desktop
 %{_datadir}/apps/ktorrent
 %{_datadir}/kde4/services/ktbwschedulerplugin.desktop
@@ -140,21 +145,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/ktupnpplugin.desktop
 %{_datadir}/kde4/services/ktwebinterfaceplugin.desktop
 %{_datadir}/kde4/servicetypes/ktorrentplugin.desktop
+%{_datadir}/kde4/services/ktmagnetgeneratorplugin.desktop
 %{_datadir}/kde4/services/ktmediaplayerplugin.desktop
 %{_datadir}/kde4/services/ktzeroconfplugin.desktop
 %{_datadir}/kde4/services/ktdownloadorderplugin.desktop
 %{_datadir}/kde4/services/ktscriptingplugin.desktop
 %{_datadir}/kde4/services/ktshutdownplugin.desktop
 %{_datadir}/kde4/services/ktsyndicationplugin.desktop
+%{_datadir}/kde4/services/magnet.protocol
 %{_datadir}/kde4/services/plasma-dataengine-ktorrent.desktop
 %{_datadir}/kde4/services/plasma-applet-ktorrent.desktop
 %{_iconsdir}/*/*/actions/kt-*.png
 %{_iconsdir}/*/*/apps/ktorrent.png
-
-%files devel
-%defattr(644,root,root,755)
-%{_datadir}/apps/cmake/modules/FindBTCore.cmake
-%{_includedir}/libbtcore
-%{_libdir}/libbtcore.so
-%{_libdir}/libktcore.so
-%{_libdir}/libktupnp.so
+%{_iconsdir}/*/*/actions/kt-*.svgz
This page took 0.064057 seconds and 4 git commands to generate.