]> git.pld-linux.org Git - packages/kf5-plasma-framework.git/blobdiff - kf5-plasma-framework.spec
relup
[packages/kf5-plasma-framework.git] / kf5-plasma-framework.spec
index 739b424a2d731dab1c57a9b436523afe48997600..a5eb66a669a1e8fc9d25a71edc4a3e5eea444dc0 100644 (file)
@@ -1,16 +1,18 @@
-%define                kdeframever     5.83
-%define                qtver           5.9.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeframever     5.99
+%define                qtver           5.15.2
 %define                kfname          plasma-framework
 
 Summary:       The foundations that can be used to build a primary user interface
 Name:          kf5-%{kfname}
-Version:       5.83.0
-Release:       1
+Version:       5.99.0
+Release:       2
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
-# Source0-md5: b3e9a64c110fdc3a27bc17cd80b6d164
-Patch0:                egl.patch
+Source0:       https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: efb64e3e3f44677125f5597da13206b0
 URL:           http://www.kde.org/
 BuildRequires: EGL-devel
 BuildRequires: OpenGL-devel
@@ -101,16 +103,21 @@ Pliki nagłówkowe dla programistów używających %{kfname}.
 
 %prep
 %setup -q -n %{kfname}-%{version}
-%patch0 -p1
 
 %build
 install -d build
 cd build
 %cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ../
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -218,7 +225,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/qt5/qml/org/kde/plasma/platformcomponents
 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/platformcomponents/libplatformcomponentsplugin.so
 %{_libdir}/qt5/qml/org/kde/plasma/platformcomponents/qmldir
-%{_datadir}/kservices5/plasma-scriptengine-applet-declarative.desktop
 %{_datadir}/kservicetypes5/plasma-applet.desktop
 %{_datadir}/kservicetypes5/plasma-containment.desktop
 %{_datadir}/kservicetypes5/plasma-containmentactions.desktop
@@ -244,11 +250,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/plasma/services/plasmoidservice.operations
 %{_datadir}/plasma/services/storage.operations
 
-%{_libdir}/qt5/plugins/kpackage/packagestructure/containmentactions_packagestructure.so
-%{_libdir}/qt5/plugins/kpackage/packagestructure/dataengine_packagestructure.so
-%{_libdir}/qt5/plugins/kpackage/packagestructure/plasmageneric_packagestructure.so
-%{_libdir}/qt5/plugins/kpackage/packagestructure/plasmatheme_packagestructure.so
-%{_libdir}/qt5/plugins/kpackage/packagestructure/plasmoid_packagestructure.so
 %dir %{_libdir}/qt5/qml/QtQuick/Controls.2
 %dir %{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma
 %dir %{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma/private
@@ -363,12 +364,18 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma/RoundButton.qml
 %{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma/ScrollView.qml
 %{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma/qmldir
+
+%{_libdir}/qt5/plugins/kf5/kirigami/KirigamiPlasmaStyle.so
+%dir %{_libdir}/qt5/plugins/kpackage/packagestructure
+%{_libdir}/qt5/plugins/kpackage/packagestructure/plasma_applet.so
+%{_libdir}/qt5/plugins/kpackage/packagestructure/plasma_containmentactions.so
+%{_libdir}/qt5/plugins/kpackage/packagestructure/plasma_dataengine.so
+%{_libdir}/qt5/plugins/kpackage/packagestructure/plasma_generic.so
+%{_libdir}/qt5/plugins/kpackage/packagestructure/plasma_theme.so
 %dir %{_libdir}/qt5/qml/org/kde/kirigami.2/styles/Plasma
 %{_libdir}/qt5/qml/org/kde/kirigami.2/styles/Plasma/Icon.qml
 %{_libdir}/qt5/qml/org/kde/kirigami.2/styles/Plasma/Theme.qml
-%{_libdir}/qt5/qml/org/kde/kirigami.2/styles/Plasma/Units.qml
-%dir %{_libdir}/qt5/qml/org/kde/kirigami.2/styles/org.kde.desktop.plasma
-%{_libdir}/qt5/qml/org/kde/kirigami.2/styles/org.kde.desktop.plasma/Units.qml
+
 %{_libdir}/qt5/qml/org/kde/plasma/components.3/Switch.qml
 %{_libdir}/qt5/qml/org/kde/plasma/components.3/SwitchDelegate.qml
 %{_libdir}/qt5/qml/org/kde/plasma/components.3/SwitchIndicator.qml
@@ -422,6 +429,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/qt5/qml/org/kde/plasma/extras/private/qmldir
 %{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma/SwipeView.qml
 %{_libdir}/qt5/qml/org/kde/plasma/components.3/SwipeView.qml
+%{_libdir}/qt5/qml/QtQuick/Controls.2/Plasma/private/IconLabel.qml
+%{_libdir}/qt5/qml/org/kde/plasma/components.3/private/IconLabel.qml
+
+%{_libdir}/qt5/qml/org/kde/plasma/extras/ActionTextField.qml
+%{_libdir}/qt5/qml/org/kde/plasma/extras/Highlight.qml
+%{_libdir}/qt5/qml/org/kde/plasma/extras/PasswordField.qml
+%{_libdir}/qt5/qml/org/kde/plasma/extras/SearchField.qml
 
 %files devel
 %defattr(644,root,root,755)
@@ -429,7 +443,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/KF5/plasma
 %{_includedir}/KF5/PlasmaQuick
 %{_includedir}/KF5/plasmaquick
-%{_includedir}/KF5/plasma_version.h
 %{_libdir}/cmake/KF5Plasma
 %{_libdir}/cmake/KF5PlasmaQuick
 %{_libdir}/libKF5Plasma.so
This page took 0.076512 seconds and 4 git commands to generate.