]> git.pld-linux.org Git - packages/kf5-kcrash.git/blobdiff - kf5-kcrash.spec
- updated to 5.115.0
[packages/kf5-kcrash.git] / kf5-kcrash.spec
index 6487cd0db64d51d015b9aacd441e786fc75f4d1e..7cf84a3c3391e972d7fba8dd06d8a020ddcac029 100644 (file)
@@ -1,40 +1,40 @@
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
 # TODO:
-# - proper place for *.pri,
-# - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
-# - _IMPORT_PREFIX also must be set somewhere
 # - runtime Requires if any
-# - these dirs are not own by any package
-#  /usr/include/KF5
-#  /usr/lib/libexec
-#  /usr/lib/plugins
-#  /usr/share/kf5
-%define         _state          stable
-%define                orgname         kcrash
+%define                kdeframever     5.115
+%define                qtver           5.15.2
+%define                kfname          kcrash
 
 Summary:       Graceful handling of application crashes
-Name:          kf5-%{orgname}
-Version:       5.0.0
-Release:       0.1
+Name:          kf5-%{kfname}
+Version:       5.115.0
+Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
-# Source0-md5: 3017ca4b16626bd707d9c74b191a58ab
+Source0:       https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: e4d7458f0df9c5adbe4e01dc2c917839
 URL:           http://www.kde.org/
-BuildRequires: Qt5Core-devel >= 5.2.0
-BuildRequires: Qt5DBus-devel
-BuildRequires: Qt5Gui-devel >= 5.3.1
-BuildRequires: Qt5Test-devel
-BuildRequires: Qt5Widgets-devel
-BuildRequires: Qt5X11Extras-devel
-BuildRequires: cmake >= 2.8.12
-BuildRequires: kf5-extra-cmake-modules >= 1.0.0
+BuildRequires: Qt5Core-devel >= %{qtver}
+BuildRequires: Qt5Test-devel >= %{qtver}
+BuildRequires: Qt5Widgets-devel >= %{qtver}
+BuildRequires: Qt5X11Extras-devel >= %{qtver}
+BuildRequires: cmake >= 3.16
+BuildRequires: kf5-extra-cmake-modules >= %{version}
 BuildRequires: kf5-kcoreaddons-devel >= %{version}
 BuildRequires: kf5-kwindowsystem-devel >= %{version}
-BuildRequires: polkit-qt-1-devel
-BuildRequires: qt5-linguist
-BuildRequires: rpmbuild(macros) >= 1.164
+BuildRequires: ninja
+BuildRequires: qt5-linguist >= %{qtver}
+BuildRequires: rpmbuild(macros) >= 1.736
 BuildRequires: tar >= 1:1.22
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xz
+Requires:      Qt5Core >= %{qtver}
+Requires:      Qt5X11Extras >= %{qtver}
+Requires:      kf5-dirs
+Requires:      kf5-kcoreaddons >= %{version}
+Requires:      kf5-kwindowsystem >= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                qt5dir          %{_libdir}/qt5
@@ -44,44 +44,38 @@ KCrash provides support for intercepting and handling application
 crashes.
 
 %package devel
-Summary:       Header files for %{orgname} development
-Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{orgname}
+Summary:       Header files for %{kfname} development
+Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kfname}
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      Qt5Core-devel >= %{qtver}
+Requires:      cmake >= 3.16
 
 %description devel
-Header files for %{orgname} development.
+Header files for %{kfname} development.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla programistów używających %{orgname}.
+Pliki nagłówkowe dla programistów używających %{kfname}.
 
 %prep
-%setup -q -n %{orgname}-%{version}
+%setup -q -n %{kfname}-%{version}
 
 %build
-install -d build
-cd build
-%cmake \
-       -DBIN_INSTALL_DIR=%{_bindir} \
-       -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
-       -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQML_INSTALL_DIR=%{qt5dir}/qml \
-       -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
-       -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
-       -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
-       -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
-       -D_IMPORT_PREFIX=%{_prefix} \
-       ../
-%{__make}
+%cmake -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
+       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+
+%ninja_build -C build
+
+%if %{with tests}
+%ninja_build -C build test
+%endif
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -92,13 +86,14 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md
-%attr(755,root,root) %ghost %{_libdir}/libKF5Crash.so.5
-%attr(755,root,root) %{_libdir}/libKF5Crash.so.5.0.0
+%ghost %{_libdir}/libKF5Crash.so.5
+%attr(755,root,root) %{_libdir}/libKF5Crash.so.*.*
+%{_datadir}/qlogging-categories5/kcrash.categories
+%{_datadir}/qlogging-categories5/kcrash.renamecategories
 
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/KF5/KCrash
-%{_includedir}/KF5/kcrash_version.h
 %{_libdir}/cmake/KF5Crash
-%attr(755,root,root) %{_libdir}/libKF5Crash.so
+%{_libdir}/libKF5Crash.so
 %{qt5dir}/mkspecs/modules/qt_KCrash.pri
This page took 0.046449 seconds and 4 git commands to generate.