]> git.pld-linux.org Git - packages/kf5-kapidox.git/blobdiff - kf5-kapidox.spec
rebuild against QT 5.15.9
[packages/kf5-kapidox.git] / kf5-kapidox.spec
index 9c2757c4d7ba01d6d035660bcfe9edcd4c9590b7..854a5f3025719a705a4b9690b75b9e1f4318bfe6 100644 (file)
@@ -1,18 +1,21 @@
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
 # TODO:
 # - runtime Requires if any
 # - python3 version
 # - .pyo etc
-%define         kdeframever     5.23
-%define         qtver           5.3.2
-%define         kfname          kapidox
+%define                kdeframever     5.104
+%define                qtver           5.15.2
+%define                kfname          kapidox
 Summary:       Kapidox
 Name:          kf5-%{kfname}
-Version:       5.23.0
-Release:       1
+Version:       5.104.0
+Release:       2
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
-# Source0-md5: 3ed25b2b4393a107da6981cee61ddc14
+Source0:       https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: 2bec17db148bc7b90ac25a6021e7ae1f
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= 5.2.0
 BuildRequires: Qt5DBus-devel >= 5.2.0
@@ -21,7 +24,8 @@ BuildRequires:        Qt5Test-devel
 BuildRequires: Qt5Widgets-devel >= 5.2.0
 BuildRequires: Qt5X11Extras-devel >= 5.2.0
 BuildRequires: cmake >= 2.8.12
-BuildRequires: kf5-extra-cmake-modules >= 1.0.0
+BuildRequires: kf5-extra-cmake-modules >= %{version}
+BuildRequires: ninja
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: sphinx-pdg
@@ -29,6 +33,7 @@ BuildRequires:        tar >= 1:1.22
 BuildRequires: xz
 Requires:      graphviz
 Requires:      kf5-dirs
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                qt5dir          %{_libdir}/qt5
@@ -47,34 +52,20 @@ template for the generated documentation.
 %setup -q -n %{kfname}-%{version}
 
 %build
-install -d build
-cd build
-%cmake \
-       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       ..
-%{__make}
+%py3_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%py3_install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/depdiagram-generate
-%attr(755,root,root) %{_bindir}/depdiagram-generate-all
-%attr(755,root,root) %{_bindir}/depdiagram-prepare
-%attr(755,root,root) %{_bindir}/kapidox_generate
-#%%attr(755,root,root) %{_bindir}/kgenapidox
-#%%attr(755,root,root) %{_bindir}/kgenframeworksapidox
-%{py_sitedir}/kapidox
-%{py_sitedir}/kapidox-*.egg-info
-%{_mandir}/man1/depdiagram-generate-all.1*
-%{_mandir}/man1/depdiagram-generate.1*
-%{_mandir}/man1/depdiagram-prepare.1*
-%{_mandir}/man1/kgenapidox.1*
-%{_mandir}/man1/kgenframeworksapidox.1*
+%attr(755,root,root) %{_bindir}/depdiagram_generate_all
+%attr(755,root,root) %{_bindir}/kapidox-depdiagram-generate
+%attr(755,root,root) %{_bindir}/kapidox-depdiagram-prepare
+%attr(755,root,root) %{_bindir}/kapidox-generate
+%{py3_sitescriptdir}/kapidox/
+%{py3_sitescriptdir}/kapidox-*.egg-info
This page took 0.041192 seconds and 4 git commands to generate.