]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- unconditional noarch packages
[packages/kernel.git] / kernel.spec
index e7abc85cc6ef8cca181d512db385d6e3559439ce..f78f42ff9f7abd53d95511d984aed21c9fcee06f 100644 (file)
@@ -68,9 +68,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         4.14
-%define                postver         .81
+%define                postver         .222
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -122,7 +122,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: bacdb9ffdcd922aa069a5e1520160e24
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  4f69ee0ebe6f61d0bc7ebe39a6c2a7e8
+# Patch0-md5:  fc6eacf51360504b802cbfb7b4d094d6
 %endif
 Source1:       kernel.sysconfig
 
@@ -150,6 +150,9 @@ Source55:   kernel-imq.config
 
 Source58:      kernel-inittmpfs.config
 
+# https://bugs.freedesktop.org/show_bug.cgi?id=104773
+Patch2:                i915_crash.patch
+
 # http://dev.gentoo.org/~spock/projects/fbcondecor/archive/fbcondecor-0.9.4-2.6.25-rc6.patch
 Patch3:                kernel-fbcondecor.patch
 Patch6:                linux-wistron-nx.patch
@@ -209,7 +212,7 @@ Patch146:   kernel-aufs4+vserver.patch
 Patch250:      kernel-fix_256colors_menuconfig.patch
 
 # https://rt.wiki.kernel.org/
-# https://www.kernel.org/pub/linux/kernel/projects/rt/4.14/patch-4.14.71-rt44.patch.xz with small updates
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.14/patch-4.14.78-rt47.patch.xz
 Patch500:      kernel-rt.patch
 
 Patch2000:     kernel-small_fixes.patch
@@ -238,8 +241,10 @@ BuildRequires:     elftoaout
 %endif
 BuildRequires: elfutils-devel
 BuildRequires: gcc >= 6:7.2.0-6
+BuildRequires: gcc-c++
 BuildRequires: gcc-plugin-devel
 BuildRequires: hostname
+BuildRequires: libstdc++-devel
 BuildRequires: kmod >= 12-2
 BuildRequires: openssl-devel
 BuildRequires: perl-base
@@ -563,9 +568,7 @@ Summary(pl.UTF-8):  Kod źródłowy jądra Linuksa
 Group:         Development/Building
 Requires:      %{name}-module-build = %{epoch}:%{version}-%{release}
 AutoReqProv:   no
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description source
 This is the source code for the Linux kernel. You can build a custom
@@ -596,9 +599,7 @@ Summary(de.UTF-8):  Kernel Dokumentation
 Summary(pl.UTF-8):     Dokumentacja do jądra Linuksa
 Group:         Documentation
 AutoReqProv:   no
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description doc
 This is the documentation for the Linux kernel, as found in
@@ -624,6 +625,8 @@ cd linux-%{basever}
 
 %if %{without vanilla}
 
+%patch2 -p1
+
 %if %{with fbcondecor}
 %patch3 -p1
 %endif
@@ -708,6 +711,31 @@ sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makef
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -f
 
+find -name '*.py' -print0 | \
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
+                            -e '1s,/usr/bin/env python,%{__python},' \
+                            -e '1s,/usr/bin/env python3,%{__python3},'
+
+%{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
+           -e '1s,/usr/bin/env python,%{__python},' \
+           -e '1s,/usr/bin/env python3,%{__python3},' \
+       drivers/staging/greybus/tools/lbtest \
+       scripts/bloat-o-meter \
+       scripts/diffconfig \
+       scripts/show_delta \
+       tools/kvm/kvm_stat/kvm_stat
+
+find -name '*.pl' -print0 | \
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
+
+%{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
+       scripts/dtc/dt_to_config \
+       scripts/cleanfile \
+       scripts/cleanpatch \
+       scripts/get_dvb_firmware \
+       scripts/kernel-doc \
+       scripts/stackdelta
+
 %build
 install -d %{objdir}
 cat > %{targetobj}.mk <<'EOF'
@@ -990,8 +1018,8 @@ touch $RPM_BUILD_ROOT%{initrd_dir}/initramfs-%{kernel_release}.img
 touch $RPM_BUILD_ROOT/lib/modules/%{kernel_release}/modules.dep
 %endif
 
-# /etc/modrobe.d
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/%{kernel_release}
+# /etc/depmod.d /etc/modrobe.d
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/{depmod.d,modprobe.d}/%{kernel_release}
 
 install -d $RPM_BUILD_ROOT/etc/sysconfig
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/kernel
@@ -1282,6 +1310,7 @@ fi
 /lib/modules/%{kernel_release}/kernel/security
 /lib/modules/%{kernel_release}/kernel/virt
 
+%dir %{_sysconfdir}/depmod.d/%{kernel_release}
 %dir %{_sysconfdir}/modprobe.d/%{kernel_release}
 
 # provided by build
This page took 0.037302 seconds and 4 git commands to generate.