]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- unconditional noarch packages
[packages/kernel.git] / kernel.spec
index 0ff5017d0c83b76e629e139392b4d7aa18def011..f78f42ff9f7abd53d95511d984aed21c9fcee06f 100644 (file)
@@ -68,9 +68,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         4.14
-%define                postver         .153
+%define                postver         .222
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -122,7 +122,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: bacdb9ffdcd922aa069a5e1520160e24
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  5109749e665ffaa5a1ece3b3ea96f78d
+# Patch0-md5:  fc6eacf51360504b802cbfb7b4d094d6
 %endif
 Source1:       kernel.sysconfig
 
@@ -568,9 +568,7 @@ Summary(pl.UTF-8):  Kod źródłowy jądra Linuksa
 Group:         Development/Building
 Requires:      %{name}-module-build = %{epoch}:%{version}-%{release}
 AutoReqProv:   no
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description source
 This is the source code for the Linux kernel. You can build a custom
@@ -601,9 +599,7 @@ Summary(de.UTF-8):  Kernel Dokumentation
 Summary(pl.UTF-8):     Dokumentacja do jądra Linuksa
 Group:         Documentation
 AutoReqProv:   no
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description doc
 This is the documentation for the Linux kernel, as found in
@@ -715,6 +711,31 @@ sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makef
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -f
 
+find -name '*.py' -print0 | \
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
+                            -e '1s,/usr/bin/env python,%{__python},' \
+                            -e '1s,/usr/bin/env python3,%{__python3},'
+
+%{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
+           -e '1s,/usr/bin/env python,%{__python},' \
+           -e '1s,/usr/bin/env python3,%{__python3},' \
+       drivers/staging/greybus/tools/lbtest \
+       scripts/bloat-o-meter \
+       scripts/diffconfig \
+       scripts/show_delta \
+       tools/kvm/kvm_stat/kvm_stat
+
+find -name '*.pl' -print0 | \
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
+
+%{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
+       scripts/dtc/dt_to_config \
+       scripts/cleanfile \
+       scripts/cleanpatch \
+       scripts/get_dvb_firmware \
+       scripts/kernel-doc \
+       scripts/stackdelta
+
 %build
 install -d %{objdir}
 cat > %{targetobj}.mk <<'EOF'
This page took 0.043209 seconds and 4 git commands to generate.