]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- Provides s/i2c-devel/kernel-i2c-devel/, added Obsoletes too
[packages/kernel.git] / kernel.spec
index 2cb3443c8f5003e3b4470f45eaa475939e4ff20c..a6cce28e441cd723e6e519e831518d035ba5a40a 100644 (file)
@@ -1,22 +1,21 @@
 #
-# If you define the following as 1, only kernel, -headers and -source
-# packages will be built
-#
-# _without_smp         - don't build SMP kernel
-# _without_up          - don't build UP kernel
-# _without_boot                - don't build BOOT kernel
-# _without_source      - don't build source
-# _without_doc         - don't build documentation package
-# _without_grsec       - don't apply grsecurity patch
-# _without_kheaders    - build without support for glibc-kernel-headers
+# Conditional build:
+%bcond_without smp             # don't build SMP kernel
+%bcond_without up              # don't build UP kernel
+%bcond_without boot            # don't build BOOT kernel
+%bcond_without source          # don't build source
+%bcond_without doc             # don't build documentation package
+%bcond_without grsec           # don't apply grsecurity patch
+%bcond_without kheaders        # build without support for glibc-kernel-headers
+%bcond_with    win4lin         # apply the Win4lin patches
 #
 %define                base_arch %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/amd64/x86_64/')
 %define                no_install_post_strip   1
 %define                no_install_post_compress_modules        1
 #
-%define                pre_version             rc3
-%define                netfilter_snap          20031121
-%define                i2c_version             2.8.0
+%define                pre_version             %{nil}
+%define                netfilter_snap          20031209
+%define                i2c_version             2.8.1
 Summary:       The Linux kernel (the core of the Linux operating system)
 Summary(de):   Der Linux-Kernel (Kern des Linux-Betriebssystems)
 Summary(es):   Núcleo (Kernel) linux genérico
@@ -25,17 +24,15 @@ Summary(pl):        J
 Summary(pt_BR):        Kernel Linux (a parte central do sistema operacional Linux)
 Name:          kernel
 Version:       2.4.23
-Release:       0.1
-License:       GPL
+Release:       0.9
+License:       GPL v2
 Group:         Base/Kernel
-Source0:       ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-2.4.22.tar.bz2
-# Source0-md5: 75dc85149b06ac9432106b8941eb9f7b
+Source0:       ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-%{version}.tar.bz2
+# Source0-md5: 642af5ab5e1fc63685fde85e9ae601e4
 Source1:       %{name}-autoconf.h
 Source2:       %{name}-BuildASM.sh
 Source3:       http://www.garloff.de/kurt/linux/dc395/dc395-141.tar.gz
 # Source3-md5: 8ed492197244b6a772270417c66214d3
-Source5:       linux-2.4.19-netfilter-IMQ.patch.tar.bz2
-# Source5-md5: b8f2f7a268a5cb75fabcaec3b5d45fcd
 Source7:       http://www10.software.ibm.com/developer/opensource/jfs/project/pub/jfs-2.4-1.1.4.tar.gz
 # Source7-md5: ea33c28ca1d3afa448b20f337b615b48
 Source20:      %{name}-ia32.config
@@ -53,41 +50,36 @@ Source1001: %{name}-netfilter.config
 Source1002:    %{name}-grsec.config
 Source2000:    %{name}-win4lin.config
 
-# Interesting URLs, patches:
-# http://www.hardrock.org/kernel/current-updates/
-
 # New features/updates/backports
 
 # Essential stuff
 
 Patch0:                %{name}-pldfblogo.patch
 
-# http://www.kernel.org/pub/linux/kernel/v2.4/testing/
-Patch1:                patch-%{version}-%{pre_version}.bz2
-
 # from ftp://ftp.kernel.org/pub/linux/kernel/people/hvr/testing/
 Patch10:       patch-cryptoloop-jari-2.4.22-rc2.0
 # from ftp://ftp.xs4all.nl/pub/crypto/freeswan/freeswan-*
-Patch12:       linux-2.4.21-freeswan-2.00.patch.gz
+Patch12:       linux-2.4.23-freeswan-2.04.patch.gz
 Patch15:       linux-2.4.23-sched-O1.patch
 # http://dl.sourceforge.net/user-mode-linux/uml-patch-2.4.20-6.bz2
 Patch20:       uml-patch-2.4.20-6-21.bz2
 Patch21:       linux-2.4.21-uml-o1.patch
 # http://dl.sourceforge.net/user-mode-linux/host-skas3.patch
 Patch22:       linux-2.4.20-uml-host-skas3.patch
-Patch23:       linux-bigger-printk-buffer.patch
+# http://www.kernel.org/pub/linux/kernel/people/jgarzik/libata/
+Patch23:       2.4.23-libata1.patch.bz2
+# missing <linux/mm.h> include in libata-core.c (needed on alpha)
+Patch24:       linux-2.4.23-libata1-include.patch
 
 # New filesystems
 
 # http://linux-xfs.sgi.com/projects/xfs/
-#Patch25:      linux-2.4.21-core-xfs-1.3.0.patch.gz
-#Patch26:      linux-xfs-1.3.0pre5.patch.gz
-Patch25:       linux-2.4.23-xfs-2003-11-11.patch.gz
+Patch25:       linux-2.4.23-xfs-2003-12-01.patch.gz
 # http://acl.bestbits.at/
 Patch31:       linux-2.4.21-jfs-acl.patch
 Patch32:       linux-2.4.22-ea+acl+nfsacl-0.8.60.diff.gz
 # http://dl.sourceforge.net/linux-ntfs/
-Patch40:       linux-2.4.22-ntfs-2.1.4c.patch.gz
+Patch40:       linux-2.4.23-ntfs-2.1.5a.patch.bz2
 # FC01_davfs_0.2.4.patch
 Patch50:       linux-2.4.20-davfs-0.2.4.patch.bz2
 # FC02_davfs__FUNCTION__.patch
@@ -102,12 +94,18 @@ Patch80:   linux-2.4.22-intermezzo-acl.patch
 
 # Networking
 
-# new version of netfilter.
-Patch100:      linux-2.4.23-netfilter-%{netfilter_snap}.patch.gz
+# ALWAYS use released patchomatic tarball (don't use CVS)
+# DO NOT include patches from patch-o-matic/userspace since they cause iptables incompatibilities
+Patch100:       linux-2.4.23-netfilter-pom-%{netfilter_snap}.patch.gz
+Patch101:      linux-2.4.23-netfilter-IMQ-target.patch
+# http://rnvs.informatik.uni-leipzig.de/ipp2p/index_en.html
+# http://rnvs.informatik.uni-leipzig.de/ipp2p/downloads/ipp2p-0.5a_vs_2.4.22.diff.gz
+Patch102:      ipp2p-0.5a_vs_2.4.22.diff.gz
+
 # http://ebtables.sourceforge.net/
-Patch110:      ebtables-brnf-2_vs_2.4.22.diff.gz
+Patch110:      ebtables-brnf-3_vs_2.4.22.diff.gz
 # http://trash.net/~kaber/imq/
-Patch120:      imq-2.4.18.diff-10
+Patch120:      linux-2.4.21-imq-1.diff
 # ftp://ftp.samba.org/pub/unpacked/ppp/linux/mppe/
 Patch125:      linux-2.4.18-mppe.patch
 Patch130:      linux-2.4.22-tun-new-style.patch
@@ -127,8 +125,7 @@ Patch152:   linux-2.4.22-fore200e-0.2f.patch
 # http://people.sistina.com/~thornber/patches/2.4-stable/
 Patch200:      linux-2.4.23-dm-3.patch
 
-# EVMS support (http://www.sourceforge.net/projects/evms/)
-# Disabled due to conflicts with LVM2 and device mapper tools
+# EVMS additional patches (http://www.sourceforge.net/projects/evms/)
 Patch205:      linux-2.4.22-evms-2.1.1.patch
 
 #from http://dl.sourceforge.net/i810fb/linux-2.4.20-i810fb.diff.bz2
@@ -145,8 +142,8 @@ Patch227:   layer7-kernel2.4patch-v0.4.1a.patch.gz
 Patch231:      linux-2.4.21-aic7xxx-mmapio.patch
 Patch235:      linux-2.4.20-audigy.patch.bz2
 Patch240:      linux-2.4.20-ecc.patch
-# i2c - version 2.8.0
-Patch255:      linux-2.4.22-i2c-%{i2c_version}.patch
+# i2c - http://secure.netroedge.com/~lm78/
+Patch255:      linux-2.4.23-i2c-%{i2c_version}.patch
 Patch256:      linux-2.4.21-i2c-headers.patch
 Patch257:      linux-2.4.21-i2c-sparc64.patch
 Patch265:      linux-2.4.20-e820.patch
@@ -156,16 +153,23 @@ Patch270: dc395-tab.patch
 Patch275:      linux-2.4.20-qla2x00-v6.04.00-fo.patch.gz
 
 # TV stuff from http://bytesex.org/
-Patch301:      20_v4l2-2.4.22.diff.gz
-Patch302:      30_bt832-2.4.22.diff
-Patch303:      30_btaudio-2.4.22.diff
+Patch301:      20_v4l2-2.4.23-pre7.diff.gz
+Patch302:      30_bt832-2.4.23-pre7.diff
+Patch303:      30_btaudio-2.4.23-pre7.diff
+
+# I18N stuff
+# Adds a sysctl for controlling the default iocharset
+Patch400:      %{name}-nls_default.patch
 
 # The following go last as they touch a lot of code
 # and/or are on bcond and/or are ifarch
 
 # Win4Lin
 Patch900:      linux-2.4.20-Win4Lin.PLD.patch.bz2
-Patch991:      linux-2.4.20-Win4Lin-mki-adapter.patch.bz2
+Patch901:      linux-2.4.20-Win4Lin-mki-adapter.patch.bz2
+
+# http://openipmi.sourceforge.net/
+Patch950:      linux-2.4.23-ipmi-v27.patch
 
 # Assorted bugfixes
 
@@ -238,13 +242,11 @@ Patch1413:        linux-2.4.22-andrea-9980_fix-pausing-6.patch
 Patch1414:     linux-2.4.21-oopsmeharder.patch
 Patch1415:     linux-mtd-missing-include-fix-2.4.7-pre6.patch
 Patch1416:     linux-2.4.21-no-FPU.patch
-Patch1417:     linux-2.4.22-ac4-ide+sata.patch
 Patch1418:     linux-2.4.21-hpt372-chicken-egg-hack.patch
 Patch1419:     linux-2.4.21-agp-num_of_masks.patch
 # fix spare disk counting for raid 5
 Patch1420:     linux-raid5-spare-counting.patch
 Patch1421:     linux-2.4.21-bttv-typo.patch
-Patch1422:     linux-2.4.21-ipt_TRACE-typo.patch
 
 Patch2000:     linux-PPC-SMP.patch
 Patch2001:     linux-2.4-ppc-procesor.patch
@@ -260,9 +262,16 @@ Patch3008: linux-drm-4.2.0-force-cmpxchg.patch
 Patch3010:     linux-2.4.21-ipsec-sparc64.patch
 Patch3011:     linux-2.4.22-gcc33-inline.patch
 Patch3012:     linux-2.4.22-gcc-ext3.patch
+Patch3013:     linux-2.4.23-ppc-symbols.patch
 
 # Security patches/fixes
 
+# modified http://www.hardrock.org/kernel/current-updates/linux-2.4.23-updates.patch
+# since we already have some of these fixes applied
+Patch3500:     http://www.hardrock.org/kernel/current-updates/linux-2.4.23-updates.patch
+# ftp://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.4.24/acpi-20031203-2.4.24.diff.bz2
+Patch3510:      acpi-20031203-2.4.24.diff.bz2
+Patch3600:     linux-2.4-sysctl-empty.patch
 Patch4000:     grsecurity-2.0-rc3-2.4.22-O1.patch
 
 ExclusiveOS:   Linux
@@ -274,21 +283,21 @@ BuildRequires:    bin86
 BuildRequires: modutils
 BuildRequires: ed
 PreReq:                modutils
-PreReq:                geninitrd >= 2.40
+PreReq:                geninitrd >= 1354
 Requires(post,postun): fileutils
 Requires(postun):      awk
 Provides:      %{name}-up = %{version}-%{release}
 Provides:      module-info
 Provides:      i2c = %{i2c_version}
 Provides:      bttv = 0.7.83
-Provides:      %{name}(netfilter) = 1.2.9rc1-%{netfilter_snap}
+Provides:      %{name}(netfilter) = 1.2.9-%{netfilter_snap}
 Provides:      %{name}(reiserfs) = %{version}
 Provides:      %{name}(agpgart) = %{version}
 #Provides:     %{name}(cdrw)
 #Provides:     %{name}(cdmrw)
 AutoReqProv:   no
 Obsoletes:     kernel-modules
-Conflicts:     iptables < 1.2.9rc1
+Conflicts:     iptables < 1.2.9
 Conflicts:     lvm < 1.0.4
 Conflicts:     xfsprogs < 2.1.0
 Conflicts:     reiserfsprogs < 3.6.3
@@ -352,13 +361,13 @@ Provides: %{name}-smp = %{version}-%{release}
 Provides:      module-info
 Provides:      i2c = %{i2c_version}
 Provides:      bttv = 0.7.83
-Provides:      %{name}(netfilter) = 1.2.9rc1-%{netfilter_snap}
+Provides:      %{name}(netfilter) = 1.2.9-%{netfilter_snap}
 Provides:      %{name}(reiserfs) = %{version}
 Provides:      %{name}(agpgart) = %{version}
 #Provides:     %{name}(cdrw)
 #Provides:     %{name}(cdmrw)
 AutoReqProv:   no
-Conflicts:     iptables < 1.2.9rc1
+Conflicts:     iptables < 1.2.9
 Conflicts:     lvm < 1.0.4
 Conflicts:     xfsprogs < 2.1.0
 Conflicts:     reiserfsprogs < 3.6.3
@@ -507,8 +516,9 @@ Requires(postun):   awk
 Provides:      %{name}-headers(agpgart) = %{version}
 Provides:      %{name}-headers(reiserfs) = %{version}
 Provides:      %{name}-headers(bridging) = %{version}
-Provides:      i2c-devel = %{i2c_version}
-Provides:      %{name}-headers(netfilter) = 1.2.9rc1-%{netfilter_snap}
+Provides:      kernel-i2c-devel = %{i2c_version}
+Provides:      %{name}-headers(netfilter) = 1.2.9-%{netfilter_snap}
+Obsoletes:     kernel-i2c-devel
 AutoReqProv:   no
 
 %description headers
@@ -606,8 +616,7 @@ Pakiet zawiera dokumentacj
 Este pacote contém documentação para o kernel Linux.
 
 %prep
-%setup -q -a3 -n linux-2.4.22
-%patch1 -p1
+%setup -q -a3 -n linux-%{version}
 # new JFS
 rm -fr fs/jfs
 gzip -dc %{SOURCE7} | tar -xf -
@@ -619,13 +628,13 @@ gzip -dc %{SOURCE7} | tar -xf -
 %patch21 -p1
 %patch22 -p1
 %patch23 -p1
+%patch24 -p1
 %patch25 -p1
 #%patch26 -p1
 %patch32 -p1
 # XXX: TODO - update patch
 #%patch31 -p1
-# XXX: TODO - update patch
-#%patch40 -p1
+%patch40 -p1
 %patch50 -p1
 %patch55 -p1
 %patch60 -p1
@@ -634,6 +643,8 @@ gzip -dc %{SOURCE7} | tar -xf -
 %patch70 -p1
 %patch80 -p1
 %patch100 -p1
+%patch101 -p1
+%patch102 -p1
 %patch110 -p1
 %patch120 -p1
 %patch125 -p1
@@ -660,6 +671,8 @@ gzip -dc %{SOURCE7} | tar -xf -
 %patch301 -p1
 %patch302 -p1
 %patch303 -p1
+%patch400 -p1
+%patch950 -p1
 %patch1000 -p1
 %patch1002 -p1
 %patch1003 -p1
@@ -707,14 +720,10 @@ gzip -dc %{SOURCE7} | tar -xf -
 %patch1414 -p1
 %patch1415 -p0
 %patch1416 -p1
-# XXX: is there updated one?
-#%patch1417 -p1
 %patch1418 -p1
 %patch1419 -p1
 %patch1420 -p1
 %patch1421 -p1
-# XXX: OBSOLETE?
-#%patch1422 -p1
 
 %patch2000 -p0
 %patch2001 -p1
@@ -724,15 +733,12 @@ gzip -dc %{SOURCE7} | tar -xf -
 %patch2004 -p1
 %endif
 
-# XXX: UPDATE
-#%patch3000 -p1
+%patch3000 -p1
 %patch3002 -p1
-# XXX: UPDATE (after adding netfilter)
-#%patch3003 -p1
+%patch3003 -p1
 %patch3004 -p1
 cd drivers/char/drm
-# XXX: UPDATE
-#%patch3008 -p1
+%patch3008 -p1
 cd ../../..
 
 %ifarch sparc64
@@ -741,15 +747,18 @@ cd ../../..
 
 %patch3011 -p1
 %patch3012 -p1
+%patch3013 -p1
 
-# XXX: UPDATE
-%{!?_without_grsec:%patch4000 -p1}
+%patch3500 -p1
+%patch3510 -p1
+%patch3600 -p1
+%{?with_grsec:%patch4000 -p1}
 
 mv -f drivers/scsi/sym53c8xx.c drivers/scsi/sym53c8xx_old.c
 
 # Tekram DC395/315 U/UW SCSI host driver
 echo Adding Tekram DC395/315 driver
-patch -p1 -s <dc395/dc395-integ24.diff
+patch -p1 -s < dc395/dc395-integ24.diff
 install dc395/dc395x_trm.? dc395/README.dc395x drivers/scsi/
 %patch270 -p1
 
@@ -757,13 +766,14 @@ install dc395/dc395x_trm.? dc395/README.dc395x drivers/scsi/
 # and/or are on bcond and/or are ifarch
 
 %ifarch %{ix86}
-%{?_with_win4lin:echo Win4Lin patch ...}
-%{?_with_win4lin:%patch900 -p1}
-%{?_with_win4lin:%patch991 -p1}
+%if %{with win4lin}
+echo Win4Lin patch ...
+%patch900 -p1
+%patch901 -p1
+%endif
 %endif
 
 # Remove -g from drivers/atm/Makefile and net/ipsec/Makefile
-echo -e ',s/EXTRA_CFLAGS.*//g\n,w' | ed drivers/atm/Makefile
 echo -e ',s/EXTRA_CFLAGS.*-g//g\n,w' | ed net/ipsec/Makefile
 
 # Fix EXTRAVERSION and CC in main Makefile
@@ -827,7 +837,7 @@ BuildKernel() {
                echo "# CONFIG_GRKERNSEC is not set" >> arch/%{base_arch}/defconfig
        else
                :;
-%if %{?_without_grsec:0}%{!?_without_grsec:1}
+%if %{with grsec}
                echo -e ',s/CONFIG_CRYPTO_SHA256=m/CONFIG_CRYPTO_SHA256=y/g\n,w' | \
                        ed arch/%{base_arch}/defconfig
                cat %{SOURCE1002} >> arch/%{base_arch}/defconfig
@@ -901,6 +911,8 @@ BuildKernel() {
        KERNELRELEASE=$KernelVer
        echo KERNEL RELEASE $KernelVer
 %endif
+       echo "CHECKING DEPENDENCIES FOR KERNEL MODULES"
+       depmod --basedir $KERNEL_INSTALL_DIR -ae -F $KERNEL_INSTALL_DIR/boot/System.map-$KernelVer $KernelVer || echo
 }
 
 KERNEL_BUILD_DIR=`pwd`
@@ -912,16 +924,21 @@ install -d $KERNEL_INSTALL_DIR
 #      (cd drivers/scsi; make -f M)
 
 # UP KERNEL
-%{!?_without_up:BuildKernel}
+%{?with_up:BuildKernel}
 
 # SMP KERNEL
-%{!?_without_smp:BuildKernel smp}
+%{?with_smp:BuildKernel smp}
+
+%if ! %{with up} && ! %{with smp}
+# We need include/asm created somewhere
+make symlinks
+%endif
 
 # BOOT kernel
 %ifnarch i586 i686 athlon
 KERNEL_INSTALL_DIR="$KERNEL_BUILD_DIR-installed%{_libdir}/bootdisk"
 rm -rf $KERNEL_INSTALL_DIR
-%{!?_without_boot:BuildKernel BOOT}
+%{?with_boot:BuildKernel BOOT}
 %endif
 
 %install
@@ -933,8 +950,8 @@ install -d $RPM_BUILD_ROOT%{_prefix}/{include,src/linux-%{version}}
 KERNEL_BUILD_DIR=`pwd`
 
 KERNEL_BUILD_INSTALL=no
-%{!?_without_up:KERNEL_BUILD_INSTALL=yes}
-%{!?_without_smp:KERNEL_BUILD_INSTALL=yes}
+%{?with_up:KERNEL_BUILD_INSTALL=yes}
+%{?with_smp:KERNEL_BUILD_INSTALL=yes}
 [ "$KERNEL_BUILD_INSTALL" = "yes" ] && cp -a $KERNEL_BUILD_DIR-installed/* $RPM_BUILD_ROOT
 
 for i in "" smp ; do
@@ -954,7 +971,7 @@ ln -s ../src/linux/include/asm-sparc64 $RPM_BUILD_ROOT%{_includedir}/asm-sparc64
 ln -sf ../src/linux/include/asm $RPM_BUILD_ROOT/usr/include/asm
 %endif
 
-%if %{?_without_source:0}%{!?_without_source:1}
+%if %{with source}
 cp -a . $RPM_BUILD_ROOT/usr/src/linux-%{version}
 %else
 cp -a {include,scripts,Makefile,Rules.make,Documentation} $RPM_BUILD_ROOT/usr/src/linux-%{version}
@@ -967,7 +984,36 @@ cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_includedir}/asm/BuildASM
 
 cd $RPM_BUILD_ROOT%{_prefix}/src/linux-%{version}
 
-%if %{?_without_source:0}%{!?_without_source:1}
+# remove foreign architecture files
+cd include
+mkdir _asm_keep
+mv asm-generic _asm_keep
+%ifarch sparc sparc64
+       mv asm-sparc* _asm_keep
+%else
+       mv `resolvesymlink asm 2> /dev/null || readlink asm 2> /dev/null` _asm_keep
+%endif
+rm -rf asm-*
+mv _asm_keep/* .
+rmdir _asm_keep
+cd ..
+
+%if %{with source}
+MYARCH=%{_arch}
+%ifarch %{ix86}
+MYARCH=i386
+%endif
+%ifarch sparc sparc64
+MYARCH="sparc sparc64"
+%endif
+cd arch
+mv $MYARCH ..
+cd ..
+rm -rf arch/*
+mv $MYARCH arch
+%endif
+
+%if %{with source}
 %{__make} mrproper
 
 find  -name "*~" -print | xargs rm -f
@@ -993,7 +1039,7 @@ echo "CONFIG_MK7=y" >> .config
 %endif
 cat %{SOURCE1000} >> .config
 cat %{SOURCE1001} >> .config
-%{!?_without_grsec:cat %{SOURCE1002} >> .config}
+%{?with_grsec:cat %{SOURCE1002} >> .config}
 
 %ifarch sparc64
        echo -e ',s/^CONFIG_FB_I810=.*/# CONFIG_FB_I810 is not set/g\n,w' | \
@@ -1036,7 +1082,7 @@ echo "CONFIG_MK7=y" >> .config
 
 cat %{SOURCE1000} >> .config
 cat %{SOURCE1001} >> .config
-%{!?_without_grsec:cat %{SOURCE1002} >> .config}
+%{?with_grsec:cat %{SOURCE1002} >> .config}
 
 %ifarch sparc64
        echo -e ',s/^CONFIG_FB_I810=.*/# CONFIG_FB_I810 is not set/g\n,w' | \
@@ -1060,7 +1106,7 @@ cp .config config-smp
 
 install %{SOURCE1} $RPM_BUILD_ROOT/usr/src/linux-%{version}/include/linux/autoconf.h
 
-%if %{?_without_source:0}%{!?_without_source:1}
+%if %{with source}
 # this generates modversions info which we want to include and we may as
 # well include the depends stuff as well
 %{__make} symlinks
@@ -1074,7 +1120,7 @@ echo "#include <linux/modsetver.h>" > include/linux/modversions.h
 # this generates modversions info which we want to include and we may as
 # well include the depends stuff as well, after we fix the paths
 
-%if %{?_without_source:0}%{!?_without_source:1}
+%if %{with source}
 %{__make} depend
 find $RPM_BUILD_ROOT/usr/src/linux-%{version} -name ".*depend" \
        -exec /bin/sh -c "echo -e \",s|$RPM_BUILD_ROOT||g\n,w\" | ed {}" \;
@@ -1085,7 +1131,7 @@ rm -f drivers/net/hamradio/soundmodem/gentbl
 %endif
 
 # BOOT
-%if %{?_without_boot:0}%{!?_without_boot:1}
+%if %{with boot}
 %ifnarch i586 i686 athlon
 install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk
 cp -rdp $KERNEL_BUILD_DIR-installed%{_libdir}/bootdisk/* $RPM_BUILD_ROOT%{_libdir}/bootdisk
@@ -1224,7 +1270,7 @@ if [ -L /usr/src/linux ]; then
        fi
 fi
 
-%if %{?_without_up:0}%{!?_without_up:1}
+%if %{with up}
 %files
 %defattr(644,root,root,755)
 %ifarch alpha sparc sparc64 ppc
@@ -1283,10 +1329,10 @@ fi
 %files drm
 %defattr(644,root,root,755)
 /lib/modules/%{version}-%{release}/kernel/drivers/char/drm
-%endif                 # %%{_without_up}
+%endif                 # %%{with up}
 %endif
 
-%if %{?_without_smp:0}%{!?_without_smp:1}
+%if %{with smp}
 %files smp
 %defattr(644,root,root,755)
 %ifarch alpha sparc sparc64 ppc
@@ -1345,10 +1391,10 @@ fi
 %files -n kernel-smp-drm
 %defattr(644,root,root,755)
 /lib/modules/%{version}-%{release}smp/kernel/drivers/char/drm
-%endif                 # %%{_without_smp}
+%endif                 # %%{with smp}
 %endif
 
-%if %{?_without_boot:0}%{!?_without_boot:1}
+%if %{with boot}
 %ifnarch i586 i686 athlon              # narch
 %files BOOT
 %defattr(644,root,root,755)
@@ -1362,23 +1408,22 @@ fi
 %{_libdir}/bootdisk/lib/modules/%{version}-%{release}BOOT/build
 %ghost %{_libdir}/bootdisk/lib/modules/%{version}-%{release}BOOT/modules.*
 %endif                         # narch
-%endif                         # %%{_without_boot}
+%endif                         # %%{with boot}
 
 %files headers
 %defattr(644,root,root,755)
 %dir %{_prefix}/src/linux-%{version}
 %{_prefix}/src/linux-%{version}/include
-%{?_without_kheaders:%{_includedir}/asm}
-%{?_without_kheaders:%{_includedir}/linux}
+%{!?with_kheaders:%{_includedir}/asm}
+%{!?with_kheaders:%{_includedir}/linux}
 
-%if %{?_without_doc:0}%{!?_without_doc:1}
+%if %{with doc}
 %files doc
-
 %defattr(644,root,root,755)
 %{_prefix}/src/linux-%{version}/Documentation
 %endif
 
-%if %{?_without_source:0}%{!?_without_source:1}
+%if %{with source}
 %files source
 %defattr(644,root,root,755)
 %{_prefix}/src/linux-%{version}/arch
@@ -1386,7 +1431,7 @@ fi
 %{_prefix}/src/linux-%{version}/drivers
 %{_prefix}/src/linux-%{version}/fs
 %{_prefix}/src/linux-%{version}/init
-%{!?_without_grsec:%{_prefix}/src/linux-%{version}/grsecurity}
+%{?with_grsec:%{_prefix}/src/linux-%{version}/grsecurity}
 %{_prefix}/src/linux-%{version}/ipc
 #%{_prefix}/src/linux-%{version}/kdb
 %{_prefix}/src/linux-%{version}/kernel
This page took 0.065362 seconds and 4 git commands to generate.