]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- rel 2
[packages/kernel.git] / kernel.spec
index 6495d2053725e0ae1bf60d0b484c8b2381f0b6ec..770240e93be0f08c76f063edaeb98ccc29a53650 100644 (file)
@@ -16,8 +16,9 @@
 #
 # Conditional build:
 %bcond_without source          # don't build kernel-source package
-%bcond_without doc                     # don't build kernel-doc package
+%bcond_without doc             # don't build kernel-doc package
 %bcond_without pcmcia          # don't build pcmcia
+%bcond_without debuginfo       # debug info files
 
 %bcond_with    verbose         # verbose build (V=1)
 
@@ -69,7 +70,7 @@
 
 %define                rel             2
 %define                basever         4.19
-%define                postver         .15
+%define                postver         .19
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -121,7 +122,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 740a90cf810c2105df8ee12e5d0bb900
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  c5f8eaad80af211708e91398e197cab9
+# Patch0-md5:  687b992be5e0514397acc6713ea121c0
 %endif
 Source1:       kernel.sysconfig
 
@@ -195,7 +196,7 @@ Patch101:   kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.17 origin/aufs4.17
+# git checkout -b aufs4.19 origin/aufs4.19
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux; cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
@@ -838,6 +839,7 @@ BuildConfig() {
                CONFIG_HIGHMEM64G=y
                CONFIG_X86_PAE=y
                CONFIG_NUMA=n
+               CONFIG_PAGE_TABLE_ISOLATION=y
        %endif
 %endif
 
@@ -891,7 +893,7 @@ EOCONFIG
 
 cd %{objdir}
 install -d arch/%{target_arch_dir}
-BuildConfig > %{defconfig}
+BuildConfig %{!?with_debuginfo:| %{__sed} -e 's/CONFIG_DEBUG_INFO=y/# CONFIG_DEBUG_INFO is not set/'} > %{defconfig}
 ln -sf %{defconfig} .config
 cd -
 
@@ -997,6 +999,7 @@ if cp -al %{srcdir}/COPYING $RPM_BUILD_ROOT/COPYING 2>/dev/null; then
 fi
 
 cp -a$l %{srcdir}/* $RPM_BUILD_ROOT%{_kernelsrcdir}
+%{__rm} -r $RPM_BUILD_ROOT%{_kernelsrcdir}/scripts/kconfig/tests
 cp -a %{objdir}/Module.symvers $RPM_BUILD_ROOT%{_kernelsrcdir}
 cp -aL %{objdir}/.config $RPM_BUILD_ROOT%{_kernelsrcdir}
 cp -a %{objdir}/include $RPM_BUILD_ROOT%{_kernelsrcdir}
@@ -1041,7 +1044,7 @@ done
 %if %{with doc}
 # move to %{_docdir} so we wouldn't depend on any kernel package for dirs
 install -d $RPM_BUILD_ROOT%{_docdir}
-mv $RPM_BUILD_ROOT{%{_kernelsrcdir}/Documentation,%{_docdir}/%{name}-%{version}}
+%{__mv} $RPM_BUILD_ROOT{%{_kernelsrcdir}/Documentation,%{_docdir}/%{name}-%{version}}
 
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/dontdiff
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/Makefile
This page took 0.099728 seconds and 4 git commands to generate.