]> git.pld-linux.org Git - packages/jq.git/blobdiff - jq.spec
- release 5 (by relup.sh)
[packages/jq.git] / jq.spec
diff --git a/jq.spec b/jq.spec
index 5333bade6b822aaef55837fb884eafdd1310a82e..c3367658a33e346202418df1fa9e303140726ce2 100644 (file)
--- a/jq.spec
+++ b/jq.spec
@@ -1,35 +1,40 @@
 #
 # Conditional build:
-%bcond_without tests           # build without tests
+%bcond_without static_libs     # static library
+%bcond_without tests           # check target
+%bcond_with    tests_valgrind  # use valgrind for tests (suspectible to glibc false positives)
 
 %ifnarch %{ix86} %{x8664}
+# valgrind required
 %undefine      with_tests
 %endif
 
 Summary:       Command-line JSON processor
+Summary(pl.UTF-8):     Procesor JSON działający z linii poleceń
 Name:          jq
 Version:       1.5
-Release:       1
-License:       MIT and ASL 2.0 and CC-BY and GPLv3
+Release:       5
+License:       MIT, Apache, CC-BY, GPL v3
 Group:         Applications/Text
+#Source0Download: https://github.com/stedolan/jq/releases
 Source0:       https://github.com/stedolan/jq/releases/download/%{name}-%{version}/jq-%{version}.tar.gz
 # Source0-md5: 0933532b086bd8b6a41c1b162b1731f9
 Patch0:                static.patch
 URL:           https://stedolan.github.io/jq/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: bison
+BuildRequires: autoconf >= 2.64
+BuildRequires: automake >= 1:1.11.2
+BuildRequires: bison >= 3
 BuildRequires: flex
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2
 BuildRequires: oniguruma-devel
-%if %{with tests}
+%if %{with tests_valgrind}
 BuildRequires: valgrind
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-lightweight and flexible command-line JSON processor
+lightweight and flexible command-line JSON processor.
 
 jq is like sed for JSON data - you can use it to slice and filter and
 map and transform structured data with the same ease that sed, awk,
@@ -37,43 +42,74 @@ grep and friends let you play with text.
 
 It is written in portable C, and it has zero runtime dependencies.
 
-jq can mangle the data format that you have into the one that you want
-with very little effort, and the program to do so is often shorter and
-simpler than you'd expect.
+%description -l pl.UTF-8
+Lekki i elastyczny procesor JSON działający z linii poleceń.
+
+jq jest odpowiednikiem seda dla danych JSON - można go używać do
+podziału, filtrowania, odwzorowywania i przekształceń danych
+strukturalnych tak samo łatwo, jak programy sed, awk, grep i podobne
+pozwalają bawić się tekstem.
+
+Jest napisany w przenośnym C i nie ma dodatkowych zależności.
 
 %package libs
-Summary:       Shared libraries for jq
+Summary:       Shared jq library
+Summary(pl.UTF-8):     Biblioteka współdzielona jq
 Group:         Libraries
 
 %description libs
-Shared libraries for jq.
+Shared jq library.
+
+%description libs -l pl.UTF-8
+Biblioteka współdzielona jq.
 
 %package devel
-Summary:       Development files for %{name}
+Summary:       Header files for jq library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki jq
+Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
-Development files for %{name}
+Header files for jq library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki jq.
+
+%package static
+Summary:       Static jq library
+Summary(pl.UTF-8):     Statyczna biblioteka jq
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static jq library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka jq.
 
 %prep
 %setup -q
 %patch0 -p1
 
 %build
-%{__aclocal} -I config/m4
 %{__libtoolize}
+%{__aclocal} -I config/m4
 %{__autoconf}
 %{__automake}
 %configure \
-       --disable-static \
+       --disable-docs \
+       %{!?with_static_libs:--disable-static} \
        --disable-all-static \
-       --disable-silent-rules
+       --disable-silent-rules \
+       %{!?with_tests_valgrind:--disable-valgrind}
+
+echo -e '#!/bin/sh\necho "'%{version}'"' > scripts/version
 
 %{__make}
 
 # Docs already shipped in jq's tarball.
 # In order to build the manual page, it
-# is necessary to install rake, rubygem-ronn
+# is necessary to install rake, rubygem-ronn, bonsai
 # and do the following steps:
 #
 # # yum install rake rubygem-ronn
@@ -112,10 +148,16 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libjq.so.*.*.*
-%ghost %{_libdir}/libjq.so.1
+%attr(755,root,root) %ghost %{_libdir}/libjq.so.1
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libjq.so
 %{_includedir}/jq.h
 %{_includedir}/jv.h
-%{_libdir}/libjq.so
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libjq.a
+%endif
This page took 0.036092 seconds and 4 git commands to generate.