]> git.pld-linux.org Git - packages/inn.git/blobdiff - inn.spec
- rediff patches
[packages/inn.git] / inn.spec
index 2397b96bbfb07cb48581640cee453ca0dfd2539f..f1ffacba19db03052dc0f6597f9541311f1518fc 100644 (file)
--- a/inn.spec
+++ b/inn.spec
@@ -1,9 +1,9 @@
-
+#
 # Conditional build:
 %bcond_with    lfs             # enable largefiles (disables tagged hash)
 %bcond_without python          # embedded Python module support
+%bcond_with    python3         # Python 3.x instead of 2.x
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       INN, the InterNet News System (news server)
 Summary(de.UTF-8):     das InterNet News System (News-Server)
 Summary(es.UTF-8):     INN, InterNet News System (servidor news)
@@ -12,12 +12,12 @@ Summary(pl.UTF-8):  INN, serwer nowinek
 Summary(pt_BR.UTF-8):  INN, InterNet News System (servidor news)
 Summary(tr.UTF-8):     INN, InterNet Haber Sistemi (haber sunucu)
 Name:          inn
-Version:       2.6.1
-Release:       3
+Version:       2.6.4
+Release:       1
 License:       distributable
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/inn/%{name}-%{version}.tar.gz
-# Source0-md5: 0db916b0be0b4a2dd7a87409a8bc7558
+# Source0-md5: 720aafc4c1b6c22f37356685d7e4747c
 Source1:       %{name}-default-active
 Source2:       %{name}-default-distributions
 Source3:       %{name}-default-newsgroups
@@ -46,7 +46,10 @@ BuildRequires:       heimdal-devel
 BuildRequires: libtool >= 2:2
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: perl-devel >= 1:5.8.0
-%{?with_python:BuildRequires:  python-devel >= 2.2}
+%if %{with python}
+%{!?with_python3:BuildRequires:        python-devel >= 1:2.3}
+%{?with_python3:BuildRequires: python3-devel >= 1:3.3}
+%endif
 BuildRequires: rpm-perlprov
 BuildRequires: rpmbuild(macros) >= 1.663
 BuildRequires: zlib-devel
@@ -74,7 +77,6 @@ Conflicts:    logrotate < 3.7-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/news
-%define                _includedir     %{_prefix}/include/inn
 
 %define                skip_post_check_so      libstorage.so.*
 # /usr/bin/pullnews doesn't provide perl(Net::NNTP) - perl-libnet does.
@@ -258,7 +260,10 @@ sunucuya makaleyi yollar.
 touch innfeed/*.[ly]
 
 %build
+# INN uses modified install-sh file
+%{__mv} support/install-sh{,.inn}
 %{__libtoolize}
+%{__mv} support/install-sh{.inn,}
 # not updated automatically by libtool
 cp -f /usr/share/aclocal/{libtool,lt*}.m4 m4
 cp -f /usr/share/automake/config.* support
@@ -266,7 +271,8 @@ cp -f /usr/share/automake/config.* support
 %{__autoconf}
 %{__autoheader} -I include
 %configure \
-       CPPFLAGS="-D_GNU_SOURCE" \
+       CPPFLAGS="%{rpmcppflags} -D_GNU_SOURCE" \
+       %{?with_python3:PYTHON=%{__python3}} \
        --with-news-group=news \
        --with-news-master=news \
        --with-news-user=news \
@@ -295,12 +301,13 @@ cp -f /usr/share/automake/config.* support
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{news/pgp,rc.d/init.d,cron.d,logrotate.d} \
-       $RPM_BUILD_ROOT{%{_libdir}/news/{rnews,auth/generic},%{_includedir}} \
-       $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/news/{control,filter,auth}} \
-       $RPM_BUILD_ROOT%{_mandir}/{man{1,3,5,8},pl/man{1,8}} \
-       $RPM_BUILD_ROOT/var/{run/news,lib/news/backoff,log/{news,archive/news}} \
-       $RPM_BUILD_ROOT/var/spool/news/{articles,overview,incoming/{tmp,bad},outgoing,archive,uniover,innfeed,cycbuffs} \
+install -d $RPM_BUILD_ROOT/etc/{cron.d,logrotate.d,news/pgp,rc.d/init.d} \
+       $RPM_BUILD_ROOT%{_libdir}/news/auth/generic \
+       $RPM_BUILD_ROOT%{_datadir}/news/auth \
+       $RPM_BUILD_ROOT%{_mandir}/pl/man{1,8} \
+       $RPM_BUILD_ROOT/var/lib/news/backoff \
+       $RPM_BUILD_ROOT/var/log/archive/news \
+       $RPM_BUILD_ROOT/var/spool/news/{cycbuffs,uniover} \
        $RPM_BUILD_ROOT/home/services/news \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
@@ -313,6 +320,9 @@ install -d $RPM_BUILD_ROOT/etc/{news/pgp,rc.d/init.d,cron.d,logrotate.d} \
        PATHAUTHPASSWD=%{_libdir}/news/auth/passwd \
        PATHAUTHRESOLV=%{_libdir}/news/auth/resolv
 
+# avoid conflict with glibc (synced with man-pages >= 5.09)
+%{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/list.{3,3inn}
+
 cp -p samples/readers.conf $RPM_BUILD_ROOT%{_sysconfdir}/readers.conf
 touch $RPM_BUILD_ROOT%{_sysconfdir}/motd.{innd,nnrpd}
 
@@ -709,7 +719,7 @@ sed -e 's/^\(listenonipv6\)/#\1/;s/^bindipv6address/bindaddress6/;s/^sourceipv6a
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libinn.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libinn.so.4
+%attr(755,root,root) %ghost %{_libdir}/libinn.so.6
 %attr(755,root,root) %{_libdir}/libinnhist.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libinnhist.so.3
 %attr(755,root,root) %{_libdir}/libstorage.so.*.*.*
@@ -723,7 +733,7 @@ sed -e 's/^\(listenonipv6\)/#\1/;s/^bindipv6address/bindaddress6/;s/^sourceipv6a
 %{_libdir}/libinn.la
 %{_libdir}/libinnhist.la
 %{_libdir}/libstorage.la
-%{_includedir}
+%{_includedir}/inn
 %{_mandir}/man3/clientlib.3*
 %{_mandir}/man3/dbz.3*
 %{_mandir}/man3/inndcomm.3*
@@ -731,8 +741,7 @@ sed -e 's/^\(listenonipv6\)/#\1/;s/^bindipv6address/bindaddress6/;s/^sourceipv6a
 %{_mandir}/man3/libinn.3*
 %{_mandir}/man3/libinnhist.3*
 %{_mandir}/man3/libstorage.3*
-# XXX: too generic name?
-%{_mandir}/man3/list.3*
+%{_mandir}/man3/list.3inn*
 %{_mandir}/man3/qio.3*
 # XXX: too generic name?
 %{_mandir}/man3/tst.3*
This page took 0.052769 seconds and 4 git commands to generate.