]> git.pld-linux.org Git - packages/gxml.git/blobdiff - gxml.spec
Update to 0.12.0 (note: new soname)
[packages/gxml.git] / gxml.spec
index 6db26ac30c1e15505ee8e318734e9aed006b0e57..32c086ed4a102c4807a6ff06abb7e78333fce218 100644 (file)
--- a/gxml.spec
+++ b/gxml.spec
@@ -1,17 +1,19 @@
 #
 # Conditional build:
-%bcond_with    apidocs         # API documentation [doesn't build up to 0.8.0 release]
+%bcond_without apidocs         # API documentation
 %bcond_without static_libs     # static library
-#
+
 Summary:       GXml - GObject API that wraps around libxml2
 Summary(pl.UTF-8):     GXml - API GObject obudowujące libxml2
 Name:          gxml
-Version:       0.8.2
+Version:       0.12.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gxml/0.8/%{name}-%{version}.tar.xz
-# Source0-md5: 77af0fb4e1e178b60fc898b8beeaabfe
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gxml/0.12/%{name}-%{version}.tar.xz
+# Source0-md5: 203922473ca4c37dc7fef54b32764b91
+Patch0:                %{name}-missing.patch
+Patch1:                %{name}-normalize.patch
 URL:           https://github.com/GNOME/gxml
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -27,8 +29,8 @@ BuildRequires:        sed >= 4.0
 BuildRequires: tar >= 1:1.22
 BuildRequires: vala >= 2:0.26
 %{?with_apidocs:BuildRequires: valadoc >= 0.3.1}
-BuildRequires: yelp-tools
 BuildRequires: xz
+BuildRequires: yelp-tools
 Requires:      glib2 >= 1:2.32.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -72,6 +74,9 @@ Group:                Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      vala >= 2:0.26
 Requires:      vala-libgee >= 0.10.5
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n vala-gxml
 Vala API for GXml library.
@@ -79,8 +84,21 @@ Vala API for GXml library.
 %description -n vala-gxml -l pl.UTF-8
 API języka Vala dla biblioteki GXml.
 
+%package apidocs
+Summary:       API documentation for GXml library
+Summary(pl.UTF-8):     Dokumentacja API biblioteki GXml
+Group:         Documentation
+
+%description apidocs
+API documentation for GXml library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki GXml.
+
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__intltoolize}
@@ -90,25 +108,31 @@ API języka Vala dla biblioteki GXml.
 %{__autoheader}
 %{__automake}
 %configure \
-       --enable-gi-system-install \
        --disable-silent-rules \
        %{?with_static_libs:--enable-static} \
        %{?with_apidocs:--enable-docs --enable-gtk-docs --enable-valadoc}
-# --enable-gir-docs --enable-devhelp-docs ???
+# --enable-devhelp-docs is almost the same as gtk-docs html, but built with valadoc(?) and installed to devhelp dirs
+# --enable-gir-docs ???
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       gxmlgtkdocdir=%{_gtkdocdir}/gxml
 
 # obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.6.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.12.la
 # packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
-%find_lang GXml
+# what a mess... gtk-doc XML intermediate files are installed to html dir...
+%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/gxml/*.{bottom,top,stamp,txt,types,xml}
+cp -p docs/valadoc/gtk-doc/gtk-doc/gxml/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/gxml
+
+# "GXml" gettext domain, "gxml" gnome help
+%find_lang GXml --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -119,24 +143,30 @@ rm -rf $RPM_BUILD_ROOT
 %files -f GXml.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_libdir}/libgxml-0.6.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgxml-0.6.so.8
-%{_libdir}/girepository-1.0/GXml-0.6.typelib
+%attr(755,root,root) %{_libdir}/libgxml-0.12.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgxml-0.12.so.12
+%{_libdir}/girepository-1.0/GXml-0.12.typelib
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgxml-0.6.so
-%{_includedir}/gxml-0.6
-%{_datadir}/gir-1.0/GXml-0.6.gir
-%{_pkgconfigdir}/gxml-0.6.pc
+%attr(755,root,root) %{_libdir}/libgxml-0.12.so
+%{_includedir}/gxml-0.12
+%{_datadir}/gir-1.0/GXml-0.12.gir
+%{_pkgconfigdir}/gxml-0.12.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libgxml-0.6.a
+%{_libdir}/libgxml-0.12.a
 %endif
 
 %files -n vala-gxml
 %defattr(644,root,root,755)
-%{_datadir}/vala/vapi/gxml-0.6.deps
-%{_datadir}/vala/vapi/gxml-0.6.vapi
+%{_datadir}/vala/vapi/gxml-0.12.deps
+%{_datadir}/vala/vapi/gxml-0.12.vapi
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_gtkdocdir}/gxml
+%endif
This page took 0.057591 seconds and 4 git commands to generate.