]> git.pld-linux.org Git - packages/google-gadgets.git/blobdiff - google-gadgets.spec
Drop XUL support, as it doesn't build since xulrunner 4.0 (15.0 is current)
[packages/google-gadgets.git] / google-gadgets.spec
index d40cdf72a92ea1599ea4621242032c298bafc1ad..52b79bccdaa8ae5e3b57e75dac902086b3cef046 100644 (file)
 # svn export http://google-gadgets-for-linux.googlecode.com/svn/trunk/ google-gadgets-for-linux
 Summary:       Google Gadgets for Linux
 Name:          google-gadgets
-Version:       0.10.5
-Release:       2
+Version:       0.11.2
+Release:       8
 License:       Apache License v2.0
 Group:         X11/Applications
 #Source0:      %{name}-for-linux-%{version}-%{rev}.tar.bz2
 Source0:       http://google-gadgets-for-linux.googlecode.com/files/%{name}-for-linux-%{version}.tar.bz2
-# Source0-md5: fdad6bd761b6c603e457b5d0d92ec2f9
+# Source0-md5: 279305553bcbf74f3e3615f6abc36a5e
 Source1:       %{name}-for-linux-gtk.desktop
 Source2:       %{name}-for-linux-qt.desktop
 Patch0:                %{name}-for-linux-cmake.patch
 Patch1:                %{name}-for-linux-link_with_qtnetwork.patch
 Patch2:                %{name}-for-linux-js.patch
+Patch3:                gcc-4.7.patch
+Patch4:                glib-2.32.patch
+Patch5:                nm09.patch
+Patch6:                nm-mobile-devtypes.patch
 URL:           http://code.google.com/p/google-gadgets-for-linux/
+BuildRequires: NetworkManager-devel >= 0.6.5
 %if %{with qt}
 BuildRequires: QtCore-devel >= 4.4.3
 BuildRequires: QtNetwork-devel >= 4.4.3
@@ -36,18 +41,17 @@ BuildRequires:      cairo-devel >= 1.2.0
 BuildRequires: gtk+2-devel >= 2:2.10.0
 BuildRequires: startup-notification-devel
 %endif
-BuildRequires: NetworkManager-devel >= 0.6.5
-#BuildRequires:        cmake >= 2.6.1-2
 BuildRequires: curl-devel >= 7.18.2
 BuildRequires: dbus-devel >= 1.0.2
 BuildRequires: flex
 BuildRequires: gstreamer-plugins-base-devel >= 0.10.0
+BuildRequires: gtk-webkit-devel
 BuildRequires: libltdl-devel
 BuildRequires: librsvg-devel
 BuildRequires: libtool >= 2:1.5.22
 BuildRequires: libxml2-devel >= 1:2.4.0
 BuildRequires: pkgconfig
-BuildRequires: xulrunner-devel >= 1.8
+BuildRequires: qt4-build
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.2.0
 Requires:      libggadget = %{version}-%{release}
@@ -138,7 +142,6 @@ Summary:    GTK+ Version of Google Gadgets
 Group:         X11/Applications
 Requires:      google-gadgets = %{version}-%{release}
 Requires:      google-gadgets-gst = %{version}-%{release}
-Requires:      google-gadgets-xul = %{version}-%{release}
 Requires:      libggadget-gtk = %{version}-%{release}
 Obsoletes:     google-gadgets-for-linux-gtk
 
@@ -180,25 +183,15 @@ well as the Universal Gadgets on iGoogle.
 
 This package includes the GStreamer modules.
 
-%package xul
-Summary:       XULRunner modules for Google Gadgets
-Group:         X11/Applications
-Requires:      libggadget = %{version}-%{release}
-Requires:      xulrunner
-
-%description xul
-Google Gadgets for Linux provides a platform for running desktop
-gadgets under Linux, catering to the unique needs of Linux users. It's
-compatible with the gadgets written for Google Desktop for Windows as
-well as the Universal Gadgets on iGoogle.
-
-This package includes the XULRunner modules.
-
 %prep
 %setup -q -n %{name}-for-linux-%{version}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
 install -d libltdl
@@ -212,7 +205,9 @@ install -d libltdl
        --disable-static \
        --disable-werror \
        --with-oem-brand=pld-linux \
-       --with-browser-plugins-dir=%{_libdir}/browser-plugins
+       --with-browser-plugins-dir=%{_libdir}/browser-plugins \
+       --disable-gtkmoz-browser-element \
+       --disable-smjs-script-runtime
 
 %{__make}
 
@@ -220,7 +215,7 @@ install -d libltdl
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # desync with cmake/ac makefiles
@@ -256,6 +251,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/google-gadget-manager.so
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/libxml2-xml-parser.so
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/linux-system-framework.so
+%attr(755,root,root) %{_libdir}/google-gadgets/modules/html-flash-element.so
+%attr(755,root,root) %{_libdir}/google-gadgets/modules/soup-xml-http-request.so
+%attr(755,root,root) %{_libdir}/google-gadgets/modules/webkit-script-runtime.so
 %dir %{_datadir}/google-gadgets
 %{_datadir}/google-gadgets/*.gg
 %{_datadir}/mime/packages/google-gadgets.xml
@@ -274,6 +272,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libggadget-npapi-1.0.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libggadget-xdg-1.0.so.0
 %attr(755,root,root) %{_libdir}/libggadget-xdg-1.0.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libggadget-webkitjs-1.0.so.0
+%attr(755,root,root) %{_libdir}/libggadget-webkitjs-1.0.so.*.*.*
 
 %files -n libggadget-devel
 %defattr(644,root,root,755)
@@ -296,6 +296,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libggadget-js-1.0*.so
 %{_libdir}/libggadget-xdg-1.0*.so
 %{_libdir}/libggadget-npapi-1.0*.so
+%{_libdir}/libggadget-webkitjs-1.0*.so
 %if 0
 %{_libdir}/libggadget-1.0*.la
 %{_libdir}/libggadget-dbus-1.0*.la
@@ -341,6 +342,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtk-edit-element.so
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtk-flash-element.so
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtk-system-framework.so
+%attr(755,root,root) %{_libdir}/google-gadgets/modules/gtkwebkit-browser-element.so
 %{_desktopdir}/ggl-gtk.desktop
 %{_desktopdir}/ggl-designer.desktop
 
@@ -358,9 +360,3 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gst-audio-framework.so
 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gst-video-element.so
-
-%files xul
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/google-gadgets/modules/smjs-script-runtime.so
-%attr(755,root,root) %{_libdir}/google-gadgets/modules/gtkmoz-browser-element.so
-%attr(755,root,root) %{_libdir}/google-gadgets/gtkmoz-browser-child
This page took 0.054785 seconds and 4 git commands to generate.