]> git.pld-linux.org Git - packages/gnutls.git/blobdiff - gnutls.spec
rel 1
[packages/gnutls.git] / gnutls.spec
index 6d17e7fca90a92b505c05dd5710930c5563790c6..7fe6ca3563ef77a16dba0a67ade9049f2a456e9e 100644 (file)
@@ -3,48 +3,56 @@
 %bcond_without dane            # libdane (DANE with DNSSEC certificate verification)
 %bcond_without openssl         # libgnutls-openssl compatibility library
 %bcond_without tpm             # TPM support in gnutls
+%bcond_without tpm2            # TPM2 support in gnutls
 %bcond_without static_libs     # static libraries
 %bcond_without doc             # do not generate documentation
 %bcond_without guile           # Guile binding
-#
+%bcond_with    af_alg          # Linux kernel AF_ALG based acceleration
+%bcond_with    ktls            # Kernel TLS support
+
+%if %{with tpm2}
+%undefine      with_tpm
+%endif
+
 Summary:       The GNU Transport Layer Security Library
 Summary(pl.UTF-8):     Biblioteka GNU TLS (Transport Layer Security)
 Name:          gnutls
-Version:       3.6.11
+Version:       3.7.3
 Release:       1
 License:       LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
 Group:         Libraries
-Source0:       ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/%{name}-%{version}.tar.xz
-# Source0-md5: 2e99334a40bdfa1ec170f9be9170a136
+Source0:       ftp://ftp.gnutls.org/gcrypt/gnutls/v3.7/%{name}-%{version}.tar.xz
+# Source0-md5: 3723d8fee66c5d45d780ca64c089ed23
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-pl.po-update.patch
-URL:           http://www.gnutls.org/
+URL:           https://www.gnutls.org/
 BuildRequires: autoconf >= 2.63
-BuildRequires: autogen >= 5.16
-BuildRequires: autogen-devel >= 5.16
 BuildRequires: automake >= 1:1.12.2
 BuildRequires: gcc >= 5:3.2
 BuildRequires: gettext-tools >= 0.19
 BuildRequires: gmp-devel
 %{?with_doc:BuildRequires:     gtk-doc >= 1.14}
 %{?with_guile:BuildRequires:   guile-devel >= 5:2.2.0}
-BuildRequires: libidn2-devel
+BuildRequires: libidn2-devel >= 2.0.0
+%{?with_af_alg:BuildRequires:  libkcapi-devel >= 1.3.0}
 BuildRequires: libstdc++-devel
 BuildRequires: libtasn1-devel >= 4.11
 BuildRequires: libunistring-devel
 BuildRequires: libtool >= 2:2
-BuildRequires: nettle-devel >= 3.3
+%{?with_ktls:BuildRequires:    linux-libc-headers >= 7:4.13}
+BuildRequires: nettle-devel >= 3.6
 # miniopencdk is included in sources and currently maintained
 # as part of gnutls, not external package
 #BuildRequires:        opencdk-devel >= 0.6.6
 BuildRequires: p11-kit-devel >= 0.23.1
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
-BuildRequires: rpmbuild(macros) >= 1.383
+BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: sed >= 4.0
 BuildRequires: tar >= 1:1.22
 %{?with_doc:BuildRequires:     texinfo >= 4.8}
+%{?with_tpm2:BuildRequires:    tpm2-tss-devel}
 %{?with_tpm:BuildRequires:     trousers-devel >= 0.3.11}
 %{?with_dane:BuildRequires:    unbound-devel}
 BuildRequires: xz
@@ -71,8 +79,10 @@ grupę roboczą IETF TLS.
 Summary:       GnuTLS shared libraries
 Summary(pl.UTF-8):     Biblioteki współdzielone GnuTLS
 Group:         Libraries
+Requires:      libidn2 >= 2.0.0
+%{?with_af_alg:Requires:       libkcapi >= 1.3.0}
 Requires:      libtasn1 >= 4.11
-Requires:      nettle >= 3.3
+Requires:      nettle >= 3.6
 #Requires:     opencdk >= 0.6.6
 Requires:      p11-kit >= 0.23.1
 %{?with_tpm:Requires:  trousers-libs >= 0.3.11}
@@ -93,7 +103,7 @@ Requires:    %{name}-libs = %{version}-%{release}
 Requires:      libidn2-devel
 Requires:      libtasn1-devel >= 4.11
 Requires:      libunistring-devel
-Requires:      nettle-devel >= 3.3
+Requires:      nettle-devel >= 3.6
 #Requires:     opencdk-devel >= 0.6.6
 Requires:      p11-kit-devel >= 0.23.1
 %{?with_tpm:Requires:  trousers-devel >= 0.3.11}
@@ -258,22 +268,24 @@ Wiązania Guile do GnuTLS.
 
 %build
 %{__libtoolize}
-%{__aclocal} -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4
+%{__aclocal} -I m4 -I src/gl/m4 -I lib/unistring/m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
+       %{?with_af_alg:--enable-afalg} \
        %{!?with_doc:--disable-doc} \
        %{!?with_guile:--disable-guile} \
+       %{__enable_disable ktls} \
        %{?with_openssl:--enable-openssl-compatibility} \
        --disable-silent-rules \
        %{?with_static_libs:--enable-static} \
        --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
        %{!?with_tpm:--without-tpm} \
+       %{__with_without tpm2} \
        --with-trousers-lib=%{_libdir}/libtspi.so.1
 
-# docs build is broken with -jN
-%{__make} -j1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -293,7 +305,9 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 # images for (not installed) htmlized infos - already packaged with infos
+%if %{with doc}
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnutls/*.png
+%endif
 
 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
 
@@ -399,7 +413,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgnutls-dane.la
 %{_includedir}/gnutls/dane.h
 %{_pkgconfigdir}/gnutls-dane.pc
+%if %{with doc}
 %{_mandir}/man3/dane_*.3*
+%endif
 
 %if %{with static_libs}
 %files dane-static
@@ -420,10 +436,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgnutls-openssl.la
 %{_includedir}/gnutls/openssl.h
 
+%if %{with static_libs}
 %files openssl-static
 %defattr(644,root,root,755)
 %{_libdir}/libgnutls-openssl.a
 %endif
+%endif
 
 %if %{with guile}
 %files -n guile-gnutls
@@ -433,5 +451,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/guile/2.*/site-ccache/gnutls
 %{_datadir}/guile/site/2.*/gnutls.scm
 %{_datadir}/guile/site/2.*/gnutls
+%if %{with doc}
 %{_infodir}/gnutls-guile.info*
 %endif
+%endif
This page took 0.085537 seconds and 4 git commands to generate.