]> git.pld-linux.org Git - packages/gnustep-gui.git/blobdiff - gnustep-gui.spec
- rel 4 for aspell 0.50 rebuild
[packages/gnustep-gui.git] / gnustep-gui.spec
index 4afc10cf63de4f0c6ab8b0c3c28be5b26449ba98..cd922c175ee35d4c722a02006e4956d0f0a0b55a 100644 (file)
@@ -1,19 +1,37 @@
 Summary:       GNUstep GUI library package
+Summary(pl):   Biblioteka GNUstep GUI
 Name:          gnustep-gui
-Version:       0.6.0
-Release:       1
-License:       GPL
-Vendor:                The Seawood Project
-Group:         Development/Tools
-Group(fr):     Development/Outils
-Group(pl):     Programowanie/Narzêdzia
+Version:       0.9.4
+Release:       4
+License:       LGPL/GPL
+Group:         Libraries
 Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
-Source0:       /cvs/gnustep-gui-%{version}-%{date}.tar.gz
-Patch0:                gstep-gui-headers.patch
+# Source0-md5: 399b3a2341899d12710f4d1ed36f3002
+Patch0:                %{name}-themes.patch
+Patch1:                %{name}-nocompressdocs.patch
+Patch2:                %{name}-segv.patch
+Patch3:                %{name}-doc.patch
 URL:           http://www.gnustep.org/
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: audiofile-devel
+BuildRequires: gcc-objc
+BuildRequires: gnustep-base-devel >= 1.10.0
+BuildRequires: libjpeg-devel
+BuildRequires: libtiff-devel
+BuildRequires: zlib-devel
+Requires:      gnustep-base >= 1.10.0
 Conflicts:     gnustep-core
-Requires:      gnustep-base
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define         _prefix         /usr/%{_lib}/GNUstep
+
+%define                libcombo        gnu-gnu-gnu
+%define                gsos            linux-gnu
+%ifarch %{ix86}
+%define                gscpu           ix86
+%else
+# also s/alpha.*/alpha/, but we use only "alpha" arch for now
+%define                gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
+%endif
 
 %description
 It is a library of graphical user interface classes written completely
@@ -25,105 +43,143 @@ include graphical objects such as buttons, text fields, popup lists,
 browser lists, and windows; there are also many associated classes for
 handling events, colors, fonts, pasteboards and images.
 
-Library combo is %{libcombo}. %{_buildblurb}
+%description -l pl
+To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
+Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
+NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
+zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
+zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
+rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
+obs³ugi zdarzeñ, kolorów, fontów i obrazków.
 
 %package devel
-Summary:       GNUstep GUI headers and libs.
+Summary:       GNUstep GUI headers and libs
+Summary(pl):   Pliki nag³ówkowe GNUstep GUI
 Group:         Development/Libraries
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Requires:      %{name} = %{version}, gnustep-base-devel
+Requires:      %{name} = %{version}-%{release}
+Requires:      audiofile-devel
+Requires:      gnustep-base-devel >= 1.9.0
+Requires:      libjpeg-devel
+Requires:      libtiff-devel
 Conflicts:     gnustep-core
 
 %description devel
 Header files required to build applications against the GNUstep GUI
-library. Library combo is %{libcombo}. %{_buildblurb}
+library.
+
+%description devel -l pl
+Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
+biblioteki GNUstep GUI.
 
 %prep
-%setup -q -n gstep-%{ver}/gui
-%patch -p2
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
-if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
-   . %{_prefix}/GNUstep/Makefiles/GNUstep.sh 
-fi
-CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}/GNUstep --with-library-combo=%{libcombo}
-%{__make}
+. %{_prefix}/System/Library/Makefiles/GNUstep.sh
+%configure
+
+%{__make} \
+       messages=yes
 
 %install
 rm -rf $RPM_BUILD_ROOT
-if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
-   . %{_prefix}/GNUstep/Makefiles/GNUstep.sh 
-fi
-install -d ${RPM_BUILD_ROOT}%{_prefix}/GNUstep/Library/Services
+. %{_prefix}/System/Library/Makefiles/GNUstep.sh
 
-%{__make} install GNUSTEP_INSTALLATION_DIR=${RPM_BUILD_ROOT}%{_prefix}/GNUstep
+%{__make} install \
+       GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
+       INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
+%{__make} install -C Documentation \
+       GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
+       INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
 
-cat > filelist.rpm.in << EOF
-%defattr (-, bin, bin)
-%doc ANNOUNCE COPYING* ChangeLog INSTALL NEWS NOTES README SUPPORT Version
+find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
+       -type f -name .cvsignore | xargs rm -f
+# not (yet?) supported by rpm-compress-doc
+find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
+       -type f -a ! -name '*.html' | xargs gzip -9nf
 
-%dir %{_prefix}/GNUstep/Library
+mv $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/manual.info.gz $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation/info/gnustep-gui.info.gz
 
-%{_prefix}/GNUstep/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so.*
-%{_prefix}/GNUstep/Libraries/Resources
-%{_prefix}/GNUstep/Library/Model
-%{_prefix}/GNUstep/Library/Services/*
-%{_prefix}/GNUstep/Tools/make_services
-%{_prefix}/GNUstep/Tools/set_show_service
-# gpbs is now provided by xgps
-#%{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/gpbs
-%{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/make_services
-%{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/set_show_service
-
-EOF
-
-cat > filelist-devel.rpm.in  << EOF
-%defattr(-, bin, bin)
-%{_prefix}/GNUstep/Headers/gnustep/gui
-%{_prefix}/GNUstep/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so
-
-EOF
-
-sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist.rpm.in > filelist.rpm
-sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist-devel.rpm.in > filelist-devel.rpm
-
-# Don't worry about ld.so.conf on linux as gnustep-base should take care of it.
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files -f filelist.rpm
+%files
 %defattr(644,root,root,755)
-
-%files -f filelist-devel.rpm devel
+%doc ChangeLog
+
+%docdir %{_prefix}/System/Library/Documentation
+%dir %{_prefix}/System/Library/Documentation/Developer/Gui
+%{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
+%{_prefix}/System/Library/Documentation/User/Gui
+%{_prefix}/System/Library/Documentation/man/man1/*
+
+%dir %{_prefix}/System/Library/Bundles/TextConverters
+%dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
+%{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
+%dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
+%{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
+
+%dir %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle
+%{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources
+%{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/%{gscpu}
+
+
+%dir %{_prefix}/System/Library/ColorPickers
+%dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
+%dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
+%{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
+%{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
+%{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
+%lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
+%lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
+%attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
+%dir %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle
+%{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/%{gscpu}
+%dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
+%{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
+
+%{_prefix}/System/Library/Images/*
+%{_prefix}/System/Library/KeyBindings/*.dict
+
+%dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
+%{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
+%lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
+
+%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
+
+%dir %{_prefix}/System/Library/PostScript
+%{_prefix}/System/Library/PostScript/GSProlog.ps
+%dir %{_prefix}/System/Library/PostScript/PPD
+%{_prefix}/System/Library/PostScript/PPD/English.lproj
+%dir %{_prefix}/System/Library/Services/GSspell.service
+%{_prefix}/System/Library/Services/GSspell.service/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
+
+%attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
+
+%files devel
 %defattr(644,root,root,755)
-
-%changelog
-* %{date} PLD Team <pld-list@pld.org.pl>
-All persons listed below can be reached at <cvs_login>@pld.org.pl
-
-$Log: gnustep-gui.spec,v $
-Revision 1.5  2000-06-09 07:54:42  kloczek
-- more %%{__make} macros.
-
-Revision 1.4  2000/06/09 07:22:52  kloczek
-- added using %%{__make} macro.
-
-Revision 1.3  2000/05/20 13:37:50  kloczek
-- spec adapterized and partialy rewrited.
-
-* Sat Sep 18 1999 Christopher Seawood <cls@seawood.org>
-- Version 0.6.0
-- Added headers patch
-
-* Sat Aug 07 1999 Christopher Seawood <cls@seawood.org>
-- Updated to cvs dawn_6 branch
-
-* Sat Jun 26 1999 Christopher Seawood <cls@seawood.org>
-- Split into separate rpm from gnustep-core
-- Build from cvs snapshot
-- Split into -devel, -libs & -zoneinfo packages
+%docdir %{_prefix}/System/Library/Documentation
+%{_prefix}/System/Library/Documentation/Developer/Gui/Additions
+%{_prefix}/System/Library/Documentation/Developer/Gui/General
+%{_prefix}/System/Library/Documentation/Developer/Gui/ProgrammingManual
+%{_prefix}/System/Library/Documentation/Developer/Gui/Reference
+%{_prefix}/System/Library/Documentation/info/gnustep-gui.info*
+
+%{_prefix}/System/Library/Headers/%{libcombo}/AppKit
+%{_prefix}/System/Library/Headers/%{libcombo}/GNUstepGUI
+%{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
+
+%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
+%{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.077587 seconds and 4 git commands to generate.