]> git.pld-linux.org Git - packages/gnustep-back.git/blobdiff - gnustep-back.spec
- destdir install fix
[packages/gnustep-back.git] / gnustep-back.spec
index 9e595a080c593d82c5c55f2c9e23645105ba6def..d0160e108a31014a79fef17c6c3bd555642aeb40 100644 (file)
@@ -1,30 +1,36 @@
+#
+# Conditional build:
+%bcond_without art     # don't build art backend
+#
 Summary:       The GNUstep backend bundle
 Summary(pl):   Pakiet backendowy GNUstep
 Name:          gnustep-back
-Version:       0.8.5
+Version:       0.9.4
 Release:       1
 License:       LGPL/GPL
 Vendor:                The GNUstep Project
 Group:         X11/Libraries
 Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
-Patch0:                %{name}-art-freetype213.patch
-Patch1:                %{name}-xdps-fix.patch
+# Source0-md5: 9bbd37749e8bdd355533bdf5d1d08050
+Patch0:                %{name}-freetype.patch
 URL:           http://www.gnustep.org/
 BuildRequires: OpenGL-devel
-BuildRequires: WindowMaker-devel
 BuildRequires: XFree86-devel
 BuildRequires: XFree86-DPS-devel
-BuildRequires: freetype-devel >= 2.1.3
-BuildRequires: gnustep-gui-devel
-BuildRequires: libart_lgpl-devel
+BuildRequires: cairo-devel
+%{?with_art:BuildRequires:     freetype-devel >= 2.1.4}
+BuildRequires: gnustep-gui-devel >= %{version}
+%{?with_art:BuildRequires:     libart_lgpl-devel}
+BuildRequires: pkgconfig
 BuildRequires: xft-devel
 Requires:      OpenGL
-Requires:      gnustep-gui
+Requires:      gnustep-gui >= %{version}
+Obsoletes:     gnustep-back-devel
 Obsoletes:     gnustep-xgps
 Conflicts:     gnustep-core
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _prefix         /usr/lib/GNUstep
+%define                _prefix         /usr/%{_lib}/GNUstep
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 
@@ -34,12 +40,12 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                gscpu           ix86
 %else
 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
-%define                gscpu           %{_target_cpu}
+%define                gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
 %endif
 
 %description
 This is a backend for the GNUstep gui Library which allows you to use
-the GNUstep gui Library on an X Windows System (other backends will
+the GNUstep gui Library on an X Window System (other backends will
 be added later to allow you to use the GNUstep gui Library in other
 windowing environments).
 
@@ -57,7 +63,8 @@ Ten pakiet zawiera cz
 Summary:       GNUstep graphics backend - art
 Summary(pl):   Graficzny backend GNUstep - art
 Group:         X11/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      freetype >= 2.1.4
 Conflicts:     gnustep-core
 
 %description art
@@ -66,11 +73,23 @@ GNUstep graphics backend - art.
 %description art -l pl
 Graficzny backend GNUstep - art.
 
+%package cairo
+Summary:       GNUstep graphics backend - cairo
+Summary(pl):   Graficzny backend GNUstep - cairo
+Group:         X11/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description cairo
+GNUstep graphics backend - cairo.
+
+%description cairo -l pl
+Graficzny backend GNUstep - cairo.
+
 %package xdps
 Summary:       GNUstep graphics backend - xdps
 Summary(pl):   Graficzny backend GNUstep - xdps
 Group:         X11/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Obsoletes:     gnustep-xdps
 Conflicts:     gnustep-core
 
@@ -80,36 +99,27 @@ GNUstep graphics backend - xdps.
 %description xdps -l pl
 Graficzny backend GNUstep - xdps.
 
-%package devel
-Summary:       Headers for GNUstep backends
-Summary(pl):   Pliki nag³ówkowe backendów GNUstep
-Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
-Requires:      XFree86-devel
-Requires:      gnustep-gui-devel
-Requires:      xft-devel
-Obsoletes:     gnustep-xdps-devel
-Obsoletes:     gnustep-xgps-devel
-Conflicts:     gnustep-core
-
-%description devel
-This package contains development headers for GNUstep backends. It
-includes also files specific for all x11 graphic backends (xlib,
-art, xdps).
-
-%description devel -l pl
-Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
-specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
-xdps).
-
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+
+# prepare the trees (for art, cairo, xdps, xlib backends)
+echo * > files.list
+%if %{with art}
+install -d back-art 
+cp -a `cat files.list` back-art
+%endif
+install -d back-cairo
+cp -a `cat files.list` back-cairo
+install -d back-xdps
+cp -a `cat files.list` back-xdps
+ln -sf . back-xlib
 
 %build
-. %{_prefix}/System/Makefiles/GNUstep.sh
-for g in art xdps xlib ; do
+. %{_prefix}/System/Library/Makefiles/GNUstep.sh
+
+for g in %{?with_art:art} cairo xdps xlib ; do
+cd back-$g
 if [ "$g" = "xlib" ]; then
        INC='--with-include-flags=-I/usr/include/freetype2'
        NAME="back"
@@ -124,28 +134,22 @@ fi
 
 %{__make} \
        messages=yes
-cp -f back.make back-$g.make
-# preserve timestamp of config.h
-cp -pf config.h config-$g.h
+cd ..
 done
 
 %{__make} -C Documentation
 
 %install
 rm -rf $RPM_BUILD_ROOT
-. %{_prefix}/System/Makefiles/GNUstep.sh
+. %{_prefix}/System/Library/Makefiles/GNUstep.sh
 
-for g in art xdps xlib ; do
+for g in %{?with_art:art} cairo xdps xlib ; do
 if [ "$g" = "xlib" ]; then
        NAME="back"
 else
        NAME="back-$g"
 fi
-# hack - restore timestamps to prevent rebuilding
-cp -pf config-$g.h config.h
-cp -pf config.h Source/%{gscpu}/%{gsos}/config.h
-touch config.status -r config.h
-%{__make} install \
+%{__make} install -C back-$g \
        GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
        BUILD_GRAPHICS="$g" \
        BACKEND_NAME="$NAME"
@@ -153,8 +157,10 @@ done
 
 %{__make} install -C Documentation \
        GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
+
 # not (yet?) supported by rpm-compress-doc
-find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
+find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
+       ! -name '*.gz' | xargs gzip -9nf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -165,7 +171,9 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog
-%{_prefix}/System/Documentation/Developer/Back
+%docdir %{_prefix}/System/Library/Documentation
+%{_prefix}/System/Library/Documentation/Developer/Back
+%{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
 
 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
@@ -173,23 +181,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
 
+%if %{with art}
 %files art
 %defattr(644,root,root,755)
 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
+%endif
+
+%files cairo
+%defattr(644,root,root,755)
+%dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle
+%{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/%{gscpu}
 
 %files xdps
 %defattr(644,root,root,755)
 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
-
-%files devel
-%defattr(644,root,root,755)
-%{_prefix}/System/Headers/gnustep/gsc
-%{_prefix}/System/Headers/gnustep/x11
-
-%{_prefix}/System/Headers/gnustep/xlib
-%{_prefix}/System/Headers/gnustep/art
-%{_prefix}/System/Headers/gnustep/xdps
This page took 0.037062 seconds and 4 git commands to generate.