]> git.pld-linux.org Git - packages/gnustep-back.git/blobdiff - gnustep-back.spec
- destdir install fix
[packages/gnustep-back.git] / gnustep-back.spec
index 85b4b55124528744aeb2de0114bffa1b9e1632e6..d0160e108a31014a79fef17c6c3bd555642aeb40 100644 (file)
@@ -1,21 +1,27 @@
+#
+# Conditional build:
+%bcond_without art     # don't build art backend
+#
 Summary:       The GNUstep backend bundle
 Summary(pl):   Pakiet backendowy GNUstep
 Name:          gnustep-back
-Version:       0.9.2
-Release:       2
+Version:       0.9.4
+Release:       1
 License:       LGPL/GPL
 Vendor:                The GNUstep Project
 Group:         X11/Libraries
 Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
-# Source0-md5: 8c011a6663f6d9703ae2d879c317e7d7
+# Source0-md5: 9bbd37749e8bdd355533bdf5d1d08050
+Patch0:                %{name}-freetype.patch
 URL:           http://www.gnustep.org/
 BuildRequires: OpenGL-devel
-BuildRequires: WindowMaker-devel
 BuildRequires: XFree86-devel
 BuildRequires: XFree86-DPS-devel
-BuildRequires: freetype-devel >= 2.1.4
+BuildRequires: cairo-devel
+%{?with_art:BuildRequires:     freetype-devel >= 2.1.4}
 BuildRequires: gnustep-gui-devel >= %{version}
-BuildRequires: libart_lgpl-devel
+%{?with_art:BuildRequires:     libart_lgpl-devel}
+BuildRequires: pkgconfig
 BuildRequires: xft-devel
 Requires:      OpenGL
 Requires:      gnustep-gui >= %{version}
@@ -24,7 +30,7 @@ Obsoletes:    gnustep-xgps
 Conflicts:     gnustep-core
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/lib/GNUstep
+%define                _prefix         /usr/%{_lib}/GNUstep
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 
@@ -34,7 +40,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                gscpu           ix86
 %else
 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
-%define                gscpu           %{_target_cpu}
+%define                gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
 %endif
 
 %description
@@ -57,7 +63,7 @@ Ten pakiet zawiera cz
 Summary:       GNUstep graphics backend - art
 Summary(pl):   Graficzny backend GNUstep - art
 Group:         X11/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      freetype >= 2.1.4
 Conflicts:     gnustep-core
 
@@ -67,11 +73,23 @@ GNUstep graphics backend - art.
 %description art -l pl
 Graficzny backend GNUstep - art.
 
+%package cairo
+Summary:       GNUstep graphics backend - cairo
+Summary(pl):   Graficzny backend GNUstep - cairo
+Group:         X11/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description cairo
+GNUstep graphics backend - cairo.
+
+%description cairo -l pl
+Graficzny backend GNUstep - cairo.
+
 %package xdps
 Summary:       GNUstep graphics backend - xdps
 Summary(pl):   Graficzny backend GNUstep - xdps
 Group:         X11/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Obsoletes:     gnustep-xdps
 Conflicts:     gnustep-core
 
@@ -83,18 +101,24 @@ Graficzny backend GNUstep - xdps.
 
 %prep
 %setup -q
+%patch0 -p1
 
-# prepare three trees (for art, xdps and xlib backends)
+# prepare the trees (for art, cairo, xdps, xlib backends)
 echo * > files.list
-install -d back-art back-xdps
+%if %{with art}
+install -d back-art 
 cp -a `cat files.list` back-art
+%endif
+install -d back-cairo
+cp -a `cat files.list` back-cairo
+install -d back-xdps
 cp -a `cat files.list` back-xdps
 ln -sf . back-xlib
 
 %build
 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
 
-for g in art xdps xlib ; do
+for g in %{?with_art:art} cairo xdps xlib ; do
 cd back-$g
 if [ "$g" = "xlib" ]; then
        INC='--with-include-flags=-I/usr/include/freetype2'
@@ -119,7 +143,7 @@ done
 rm -rf $RPM_BUILD_ROOT
 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
 
-for g in art xdps xlib ; do
+for g in %{?with_art:art} cairo xdps xlib ; do
 if [ "$g" = "xlib" ]; then
        NAME="back"
 else
@@ -157,11 +181,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
 
+%if %{with art}
 %files art
 %defattr(644,root,root,755)
 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
+%endif
+
+%files cairo
+%defattr(644,root,root,755)
+%dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle
+%{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/%{gscpu}
 
 %files xdps
 %defattr(644,root,root,755)
This page took 0.033583 seconds and 4 git commands to generate.