]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - ghc-package.spec
clean is after install section
[projects/template-specs.git] / ghc-package.spec
index 614decb1b0ee4b11e44cece73a705ed0185df8f4..f70c4419a77c7084a7b6f6f46bd6349165db1ee8 100644 (file)
@@ -1,4 +1,4 @@
-%define        pkgname NAME
+%define                pkgname PACKAGE_NAME
 Summary:       -
 Name:          ghc-%{pkgname}
 Version:       -
@@ -7,54 +7,63 @@ License:      - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
 Group:         Development/Languages
 Source0:       http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
 # Source0-md5: -
-URL:           http://hackage.haskell.org/package/NAME/
+URL:           http://hackage.haskell.org/package/PACKAGE_NAME/
 BuildRequires: ghc >= 6.12.3
+#BuildRequires:        ghc-prof
 #BuildRequires:        ghc-OTHERMODULE
 BuildRequires: rpmbuild(macros) >= 1.608
 %requires_releq        ghc
+Requires(post,postun): /usr/bin/ghc-pkg
 #Requires:     ghc-OTHERMODULE
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # debuginfo is not useful for ghc
 %define                _enable_debug_packages  0
 
+# don't compress haddoc files
+%define                _noautocompressdoc      *.haddock
+
 %description
 
-%package doc
-Summary:       HTML documentation for %{pkgname}
-Summary(pl.UTF-8):     Dokumentacja w formacie HTML dla %{pkgname}
-Group:         Documentation
+%package prof
+Summary:       Profiling %{pkgname} library for GHC
+Summary(pl.UTF-8):     Biblioteka profilująca %{pkgname} dla GHC.
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
-%description doc
-HTML documentation for %{pkgname}.
+%description prof
+Profiling %{pkgname} library for GHC.  Should be installed when
+GHC's profiling subsystem is needed.
 
-%description doc -l pl.UTF-8
-Dokumentacja w formacie HTML dla %{pkgname}.
+%description prof -l pl.UTF-8
+Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
+kiedy potrzebujemy systemu profilującego z GHC.
 
 %prep
 %setup -q -n %{pkgname}-%{version}
 
 %build
-runhaskell Setup.hs configure -v2 \
+runhaskell Setup.lhs configure -v2 --enable-library-profiling \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
        --docdir=%{_docdir}/%{name}-%{version}
 
-runhaskell Setup.hs build
-runhaskell Setup.hs haddock --executables
+runhaskell Setup.lhs build
+runhaskell Setup.lhs haddock --executables
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
 
-runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
+runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
 
 # work around automatic haddock docs installation
-rm -rf %{name}-%{version}-doc
-cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
+%{__rm} -rf %{name}-%{version}-doc
+cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
-runhaskell Setup.hs register \
+runhaskell Setup.lhs register \
        --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
 
 %clean
@@ -69,9 +78,17 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc NEWS
+%doc %{name}-%{version}-doc/*
 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
-%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
+%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
+%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
 
-%files doc
+%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.hi
+
+%files prof
 %defattr(644,root,root,755)
-%doc %{name}-%{version}-doc/*
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.p_hi
This page took 0.028743 seconds and 4 git commands to generate.