]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - ghc-package.spec
Add .tar.xz deps
[projects/template-specs.git] / ghc-package.spec
index 9ac44b1239b210cf52ce0a6062e1f98beb318726..e8fcfaf6a5f33377c6839171b6d506cfd2c2a311 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_without prof    # profiling library
+#
 %define                pkgname PACKAGE_NAME
 Summary:       -
 Name:          ghc-%{pkgname}
@@ -5,29 +9,36 @@ Version:      -
 Release:       0.1
 License:       - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
 Group:         Development/Languages
-Source0:       http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
+#Source0Download: http://hackage.haskell.org/package/PACKAGE_NAME
+Source0:       http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
 # Source0-md5: -
-URL:           http://hackage.haskell.org/package/PACKAGE_NAME/
+URL:           http://hackage.haskell.org/package/PACKAGE_NAME
 BuildRequires: ghc >= 6.12.3
 #BuildRequires:        ghc-OTHERMODULE
+%if %{with prof}
+BuildRequires: ghc-prof
+#BuildRequires:        ghc-OTHERMODULE-prof
+%endif
 BuildRequires: rpmbuild(macros) >= 1.608
-%requires_releq        ghc
+%requires_eq   ghc
+Requires(post,postun): /usr/bin/ghc-pkg
 #Requires:     ghc-OTHERMODULE
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # debuginfo is not useful for ghc
 %define                _enable_debug_packages  0
 
-# don't compress haddoc files
+# don't compress haddock files
 %define                _noautocompressdoc      *.haddock
 
 %description
 
 %package prof
 Summary:       Profiling %{pkgname} library for GHC
-Summary(pl.UTF-8):     Biblioteka profilująca %{pkgname} dla GHC.
+Summary(pl.UTF-8):     Biblioteka profilująca %{pkgname} dla GHC
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+#Requires:     ghc-OTHERMODULE-prof
 
 %description prof
 Profiling %{pkgname} library for GHC.  Should be installed when
@@ -41,27 +52,29 @@ kiedy potrzebujemy systemu profilującego z GHC.
 %setup -q -n %{pkgname}-%{version}
 
 %build
-runhaskell Setup.hs configure -v2 --enable-library-profiling \
+runhaskell Setup.lhs configure -v2 \
+       %{?with_prof:--enable-library-profiling} \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
        --docdir=%{_docdir}/%{name}-%{version}
 
-runhaskell Setup.hs build
-runhaskell Setup.hs haddock --executables
+runhaskell Setup.lhs build %{?_smp_mflags}
+runhaskell Setup.lhs haddock --executables
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
 
-runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
+runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
 
 # work around automatic haddock docs installation
-rm -rf %{name}-%{version}-doc
+%{__rm} -rf %{name}-%{version}-doc
 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
-runhaskell Setup.hs register \
-       --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
+runhaskell Setup.lhs register \
+       --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -74,18 +87,20 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc NEWS
-%doc %{name}-%{version}-doc/*
+%doc NEWS %{name}-%{version}-doc/*
 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
-%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
 
 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE
 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.hi
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.dyn_hi
 
+%if %{with prof}
 %files prof
 %defattr(644,root,root,755)
 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.p_hi
+%endif
This page took 0.057616 seconds and 4 git commands to generate.