]> git.pld-linux.org Git - packages/geoclue2.git/blobdiff - geoclue2.spec
- updated to 2.4.4
[packages/geoclue2.git] / geoclue2.spec
index 468c0261688b25631f449cc7a32d0edc095fe2fe..76a888d65611cb7f38e70c1e6eb08da05fe8559a 100644 (file)
@@ -1,29 +1,41 @@
+#
+# Conditional build:
+%bcond_without static_libs     # static library
+#
 Summary:       A modular geoinformation service
 Summary(pl.UTF-8):     Modularna usługa geoinformacyjna
 Name:          geoclue2
-Version:       1.99.2
+Version:       2.4.4
 Release:       1
-License:       GPL v2+
+License:       GPL v2+ (programs), LGPL v2.1+ (library)
 Group:         Applications
-Source0:       http://cgit.freedesktop.org/geoclue/snapshot/geoclue-%{version}.tar.gz
-# Source0-md5: 21551a387a9e5e3e5ebea11254f94a77
-URL:           http://geoclue.freedesktop.org/
-BuildRequires: GeoIP-devel >= 1.5.1
+Source0:       https://www.freedesktop.org/software/geoclue/releases/2.4/geoclue-%{version}.tar.xz
+# Source0-md5: d2a5b05f4bad032673fe23afbce27926
+URL:           https://geoclue.freedesktop.org/
+BuildRequires: ModemManager-devel >= 1.0.0
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
+BuildRequires: avahi-devel >= 0.6.10
+BuildRequires: avahi-glib-devel >= 0.6.10
 BuildRequires: glib2-devel >= 1:2.34.0
+BuildRequires: gnome-common
+BuildRequires: gobject-introspection-devel >= 0.10
+BuildRequires: gtk-doc >= 1.0
+BuildRequires: intltool >= 0.40.0
 BuildRequires: json-glib-devel >= 0.14
-BuildRequires: libsoup-devel >= 2.4.0
+BuildRequires: libnotify-devel
+BuildRequires: libsoup-devel >= 2.42
 BuildRequires: libtool >= 2:2.2
-BuildRequires: libxml2-devel >= 2.0
 BuildRequires: pkgconfig >= 1:0.22
-BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
 BuildRequires: yelp-tools
-Requires:      GeoIP >= 1.5.1
+BuildRequires: xz
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      avahi-libs >= 0.6.10
+Requires:      avahi-glib >= 0.6.10
 Requires:      dbus
-Requires:      glib2 >= 1:2.34.0
 Requires:      json-glib >= 0.14
-Requires:      libsoup >= 2.4.0
+Requires:      libsoup >= 2.42
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -36,14 +48,26 @@ Geoclue to modularna usługa geoinformacyjna zbudowana w oparciu o
 system komunikacji D-Bus. Celem projektu jest jak największe
 ułatwienie tworzenia aplikacji uwzględniających lokalizację.
 
+%package libs
+Summary:       Library to interact with Geoclue service
+Summary(pl.UTF-8):     Biblioteka do współpracy z usługą Geoclue
+License:       LGPL v2.1+
+Group:         Libraries
+Requires:      glib2 >= 1:2.34.0
+
+%description libs
+Library to interact with Geoclue service.
+
+%description libs -l pl.UTF-8
+Biblioteka do współpracy z usługą Geoclue.
+
 %package devel
 Summary:       Development package for geoclue2
 Summary(pl.UTF-8):     Pakiet programistyczny geoclue2
+License:       LGPL v2.1+
 Group:         Development/Libraries
-# doesn't require base
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      glib2-devel >= 1:2.34.0
-Requires:      json-glib-devel >= 0.14
-Requires:      libsoup-devel >= 2.4.0
 
 %description devel
 Header files for development with geoclue2.
@@ -51,20 +75,34 @@ Header files for development with geoclue2.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe do programowania z użyciem geoclue2.
 
+%package static
+Summary:       Static geoclue2 library
+Summary(pl.UTF-8):     Statyczna biblioteka geoclue2
+License:       LGPL v2.1+
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static geoclue2 library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka geoclue2.
+
 %prep
 %setup -q -n geoclue-%{version}
 
-%{__sed} -i -e '/po\/Makefile.in/d' -e '/IT_PROG_INTLTOOL/d' configure.ac
-%{__sed} -i -e 's/ po$//' Makefile.am
-
 %build
+%{__intltoolize}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --disable-silent-rules
+       --enable-demo-agent \
+       --disable-silent-rules \
+       %{?with_static_libs:--enable-static} \
+       --with-systemdsystemunitdir=%{systemdunitdir}
 
 %{__make}
 
@@ -74,19 +112,54 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgeoclue-2.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc NEWS README
-%attr(755,root,root) %{_bindir}/geoip-lookup
-%attr(755,root,root) %{_bindir}/geoip-update
 %attr(755,root,root) %{_libexecdir}/geoclue
+%dir %{_sysconfdir}/geoclue
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/geoclue/geoclue.conf
+%{systemdunitdir}/geoclue.service
 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.conf
-%{_datadir}/geoclue-2.0
+/etc/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
 %{_datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service
+# demos
+%dir %{_libexecdir}/geoclue-2.0
+%dir %{_libexecdir}/geoclue-2.0/demos
+%attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/agent
+%attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/where-am-i
+%{_desktopdir}/geoclue-demo-agent.desktop
+%{_desktopdir}/geoclue-where-am-i.desktop
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgeoclue-2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgeoclue-2.so.0
+%{_libdir}/girepository-1.0/Geoclue-2.0.typelib
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgeoclue-2.so
+%{_includedir}/libgeoclue-2.0
+%{_datadir}/gir-1.0/Geoclue-2.0.gir
 %{_pkgconfigdir}/geoclue-2.0.pc
+%{_pkgconfigdir}/libgeoclue-2.0.pc
+%{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Client.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Location.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Manager.xml
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libgeoclue-2.a
+%endif
This page took 0.036418 seconds and 4 git commands to generate.